Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Post Bredolab, Sheur2 and Agent2 Start Up Loop


  • Please log in to reply
No replies to this topic

#1 sandycreed

sandycreed

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:53 AM

Posted 26 January 2010 - 10:50 PM

Hi, my mother's XP SP2 pc was infected by the bredolab trojan via an email attachment. AVG Free scan showed infection with Sheur2.chna and agent2.agfy. After removal I restarted pc only to find it could not go past the user log on page and constantly restarts both in normal start up and in safe mode. No safe mode is accessible.

I managed to get recovery console cd burnt via iso image as only have OEM XP disk. Replaced userinit.exe with same from DLLcache on hard drive but suspect that too was affected but was unable to get fresh file to pc as it wouldn't recognise usb drive or allow change of cd while in recovery console mode.

Tried non-destructive system restore but it made no difference.

I ran chkdsk/r in recovery console and it reported it had found and fixed one error.

I then tried system repair via recovery console but afterwards it doesn't even give me the log on option in safe mode. Just tells me windows setup can not continue in safe mode and restarts after clicking the OK button. In normal start up it reaches the "windows is starting up" screen then automatically restarts. I am assuming this is at the log on point too. I can not switch machine off without holding down the main start button on unit.

I suspect the registry may have been affected but don't know how to access it when the pc won't start.

Is there a way I can get the userinit file replaced via a usb flash drive? What else is likely to be the problem? Will I need to to do a fresh install?

Will upgrading to Windows 7 fix the problem or just carry it along with it?

Any help will be greatly appreciated. Many thanks.

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users