Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Ports not working correctly...


  • Please log in to reply
2 replies to this topic

#1 hm3buzz

hm3buzz

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Location:In Denial
  • Local time:09:29 AM

Posted 18 January 2010 - 02:01 AM

I am working on a Dell Precision 380 computer and the USB ports are not working correctly. I checked the Device manager and it stated that everything was working properly. I tried uninstalling the root controllers and hubs, letting them reinstall on restart. When I restarted, leaving a Flash drive in one of the ports, it recognised the flash drive. After I removed it and replaced it, the PC no longer recognized the drive. I am at a loss for a solution and any help would be appreciated. Thanks. System specs below....



Dell Precision 380

Windows XP Pro SP3
Pentium 4 3.20 GHz
3.5 GB RAM

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,723 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:08:29 AM

Posted 18 January 2010 - 08:27 AM

Remove the flash drive...go to Device Manager and uninstall all controllers only (leave hubs alone)...reboot.

FWIW: You might pay attention to the Safely Remove Hardware functions in the future. I don't use flash drives or external drives in my USB ports, but it seems that some users have problems when they fail to heed the Safely Remove Hardware function.

Louis

#3 hm3buzz

hm3buzz
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Location:In Denial
  • Local time:09:29 AM

Posted 18 January 2010 - 06:12 PM

I used the safely remove hardware function and got the same result as when I didn't use it. I will try to uninstall the contollers only and see if that works. Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users