Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Lexmark X2550 printer, not working on Win 7


  • Please log in to reply
No replies to this topic

#1 Vanedil

Vanedil

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:08:23 AM

Posted 17 January 2010 - 08:03 PM

Greetings, I was wondering if anyone out there has faced a problem when upgrading to Windows 7, in finding that suddenly their printers do not work?

Well, this problem happened to me.

Recently, I bought a new computer with Win 7 Starter. One of the first inconveniences that I found, was that the OS would try to automatically seek/install drivers on my computer immediatly after plugging it. Always, was this installation process end up with the printer not propery being installed, with the driver reflecting an error.

So, everytime I manually try to install the drivers, I have to disable the automatic driver update, and make sure to uninstall the incorrect driver if it had not been done before. Well, the real issue is that I have spent 10 hours trying to figure how to install this all-in-one printer, I already downloaded all the available drivers from the Lexmark website, those who are labeled to be drivers precisely for Win 7 (64/32 bit), and even previous drivers. The result is the same: device manager appropietly labels the hardware as an Imagining Device, and the printer appears listed without problems. However, when I go to the Control Panel, to check the installed devices, the Printer is detected with a yellow shield, and says that the printer needs to undergo troubleshooting, and in properties that the Driver is not installed. Worse, is that the Scanning function DOES work, however, try as I might, I am not able to get the printer to actually print.


Please, someone tell me how to solve he issue. I am at my wit's end, already trying to extract, and manually go through the setup process using Drivers from Vista 64/32-bit to Win 7 32-bit driver. Already tried contacting the techs at Lexmark, however, they oly referred to the aforementioned already tried drivers.

Edited by Vanedil, 17 January 2010 - 09:45 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users