Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop keeps disconecting from wireless


  • Please log in to reply
22 replies to this topic

#1 Connor!

Connor!

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 14 January 2010 - 01:36 PM

Hi

Wasn't sure where to post this, but I think the problem is to do with my wireless card.

I just bought a new netbook (Toshiba T100) and have been trying to connect it to my also new router (Netgear WNB2100)
Everytime I connect to the network, it will stay connected for a few minutes and then disconnect and show on my laptop for a few seconds that no wireless networks are available and then it will rescan and connect... and repeat the process. I have made sure that the computer is unable to put my wireless card to sleep. My Wireless card is Realtek RTL8191SE Wireless LAN 802.11n PCI-E NIC and I am running Windows 7.

Thanks
Connor
Posted Image
Thanks Shaba! :)

BC AdBot (Login to Remove)

 


#2 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 14 January 2010 - 06:11 PM

Hi

I've just found out that this only happens when on battery power, but I'm sure I've checked all the power settings and they're all set to maximum performance for networking while on battery power, and not to turn the device to sleep.

Thanks
Connor
Posted Image
Thanks Shaba! :)

#3 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:33 AM

Posted 14 January 2010 - 06:21 PM

There may be as many as 4 places that I am aware of to check power settings. 1 Device manager. 2 The device in questions properties > power management or advanced tab. 3 Control Panel > Power management 4 There may be a setting in the BIOS as well.

The first three may slightly vary depending on your OS. The fourth should be able to access by a certain key strike when the machine is first started.

#4 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 14 January 2010 - 06:48 PM

Hi, Thanks for the reply.

I've checked in power managment and in device manager. I was a bit confused, as I thought the Device Manager and The devices properites were the same option. I checked the bios aswell, but it had no power options. I'm not really sure what to do next, is it possible the laptop is faulty and I should return it?

Thanks

Connor
Posted Image
Thanks Shaba! :)

#5 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:33 AM

Posted 14 January 2010 - 07:32 PM

I`m going to make an assumptions :thumbsup: here so please bear with me. It is that you are using the wireless connection utility that was installed from the factory and was written by the wireless NIC driver provider or Toshiba.


There should be an option to use the Windows built in wireless configuration utility. See if you are able to find it and give it a try.

#6 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 14 January 2010 - 08:10 PM

I've looked, but that doesn't seem to interfere with the windows utility, they seem to work in sync with each other. I don't see any option to disable it either. I have been using windows to connect/disconnect but it seems the Toshiba utility is always working. I will remove it from startup and then see if it makes a difference.

Thanks again for reply
Posted Image
Thanks Shaba! :)

#7 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 14 January 2010 - 08:20 PM

I ended the process for the Toshiba utility, but unfortunately the problem still exists.
I really don't know what else to check.

Connor
Posted Image
Thanks Shaba! :)

#8 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:33 AM

Posted 14 January 2010 - 11:21 PM

You ended the process then used the Windows Wireless Zero Configuration utility to configure the connection?

Edited by ThunderZ, 15 January 2010 - 08:44 AM.


#9 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 15 January 2010 - 02:17 AM

You the process then used the Windows Wireless Zero Configuration utility to configure the connection?


Sorry, I didn't really understand your question.

I use Windows to connect to my wireless network, but the toshiba utility is always on in the background. I didn't see any settings for disabling the toshiba utility so I ended its process (CFSwMgr.exe) but the wireless still kept disconnecting and reconnecting on battery.

Thanks
Posted Image
Thanks Shaba! :)

#10 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:33 AM

Posted 15 January 2010 - 08:44 AM

The fact that is disconnects is somewhat understandable. May still be a power management setting somewhere. The ability to reconnect makes me think that it is not a power management setting.

Since you do use Windows to connect let`s try this. There is no reason for the Toshiba utility to be running. Look around in the utility to see if it can be disabled from running at Windows start-up. If not the go to Start > Run... > type in msconfig. On the Startup tab find the associated Toshiba program and remove the check mark. Click Apply > OK then restart when prompted. When the PC starts back up you can place a check mark in the Do not show..... box of the notice that msconfig has been used.

See if your connection will hold.

#11 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 16 January 2010 - 09:11 AM

The Toshiba wireless utility is not in that startup list, although there is Toshiba Service Station which might be in charge for a group of different utilities/software opening?

I'm going to try creating my own power plan, as the two default ones are balanced and eco.

Thanks
Posted Image
Thanks Shaba! :)

#12 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 16 January 2010 - 08:19 PM

I uninstalled ConfigFree (Toshiba Wireless Utility) but still have the same problem.

Thanks
Posted Image
Thanks Shaba! :)

#13 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:33 AM

Posted 16 January 2010 - 08:48 PM

The only other software related suggestion I can think of right now is to check the channel that both the router and wireless NIC are using. The same channel should be used on both. In the US I believe routers are normally 6. Some software for wireless NICs will show 1 thru 11 and 12 thru.....I forget.

With you being in the UK you will want the higher range on both the wireless NIC and router.

The other thought I have regards interference. Cordless phones, microwaves, a monitor to close, the list go`s on.

#14 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 16 January 2010 - 09:44 PM

I don't think it is interference as my other laptop with a Realtek adapter installed works fine, and my computer with a Netgear dongle works fine.
On my Router, the channel is set to auto. I could not find any settings on my laptop to change the channel for my wireless adapter.

Thanks once again for your replies
Posted Image
Thanks Shaba! :)

#15 Connor!

Connor!
  • Topic Starter

  • Members
  • 118 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland, UK
  • Local time:12:33 AM

Posted 16 January 2010 - 10:22 PM

Now I am really confused...

On the High Performance setting (which my laptop is not designed for as it's main attraction is its long battery life) the problem does not happen.
But I have made sure that the wireless adapter is set to Maximum Peformance for the balanced and eco power settings. I have also set it not to sleep in device manager. I'm not really sure what to do/check now, I don't know what further settings I can change

Thanks
Posted Image
Thanks Shaba! :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users