Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

W7 take so much time to shutdown on my laptop


  • Please log in to reply
9 replies to this topic

#1 JwenqC

JwenqC

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:28 AM

Posted 07 January 2010 - 02:51 AM

Hi there,

i have problem with my W7 installation, its was a home premium and i installed it as multi OS, i have my previous vista and its is working fine. When i boot on windows7 it is also working fine, the only problem is when I shutdown it takes so much time, maybe around 15 minutes before it can shut itself off. its displays shutting down all that time. my unit is acer 5378 2ghz, 3gb ram. has anyone encounter same problem and or has anyone has idea about it? thanx in advance.
Posted Image The MATRIX
BrainStorm..Power Up...

BC AdBot (Login to Remove)

 


#2 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:03:28 AM

Posted 07 January 2010 - 12:29 PM

Yeah, I used to have problems with this. It's usually a couple incorrect settings that make it take so long.

Copy and paste the following into Notepad, then save it to the Desktop as "settings.reg" without the quotes. (the .reg is important!):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\Memory Management]
"ClearPageFileAtShutdown"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
"WaitToKillServiceTimeout"="1000"

[HKEY_USERS\.DEFAULT\Control Panel\Desktop]
"WaitToKillAppTimeout"="1000"
"HungAppTimeout"="1000"

Double click this settings file you saved. "Yes" at the UAC prompt. "Yes" when regedit asks if you want to merge this, yada yada...

This tell Windows to not clear the pagefile (can really delay things), and to wait less time before killing applications that hang up the shutdown process (1000 milliseconds or 1 second in this case). :huh:

Let me know if it speeds things up. :huh:

Edited by keyboardNinja, 07 January 2010 - 12:32 PM.

PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#3 JwenqC

JwenqC
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:28 AM

Posted 08 January 2010 - 02:02 AM

Thanx a lot sir. I haven't tried it yet. I'll tell you if this works for me. i'll come back soon.
Posted Image The MATRIX
BrainStorm..Power Up...

#4 JwenqC

JwenqC
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:28 AM

Posted 08 January 2010 - 05:57 AM

@keyboardninja

Sir, I have tried the procedure you told me and it was added in the registry but when I shutdown the computer still same thing happens..
Posted Image The MATRIX
BrainStorm..Power Up...

#5 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:03:28 AM

Posted 08 January 2010 - 11:31 AM

Well, then your issue must be caused by something else.

First the obvious:

Are you running a genuine, legal copy of Windows 7?
Do you keep Automatic Updates turned on and regularly check to make sure Windows is up to date?
Do you use anti-malware software (this includes but is not limited to: anti-virus, anti-spyware, firewall, etc..) and keep it updated?
Do you defragment your hard drive?
Have you used cleaning software like Ccleaner to clean the junk out of your computer?

Take a look here also:

Control Panel > All Control Panel Items > Performance Information and Tools > Advanced Tools (on the left side)

If there are any pressing issues that are hurting your performance (such as programs making shutdown slow), they will be at the top of the screen. If you see "No issues reported", click "Generate a system health report" at the bottom of the list. This will generate a report about the overall health of your system. Review it and report back here with any issues. :huh:
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#6 JwenqC

JwenqC
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:28 AM

Posted 09 January 2010 - 12:04 AM

My problem was solve and the culprit was me, because i have not install the drivers before I complain.. after installation I checked the device manager and I did not see yellow question marks on it and so I assume all the drivers are fine. I also tried to install the display driver but its not supporting windows7.

Thanx a lot keyboardNinja...
Posted Image The MATRIX
BrainStorm..Power Up...

#7 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:03:28 AM

Posted 09 January 2010 - 12:27 AM

Oh yes, I forgot to include drivers in my list of things to check.

You're welcome. Good to know you got it fixed. :huh:

It it shutting down faster now?
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#8 tryn2learn

tryn2learn

  • Members
  • 220 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Upstate NY
  • Local time:05:28 AM

Posted 13 February 2010 - 01:57 PM

I am having the same problem on boot up and shut down. Although I have tracked my down to security monitoring being the culprit. I am running 2 computers, both with the same issues and my sisters as well. Her's is running vista home premium and I am running Win 7 64 bit on a brand new dell inspiron 1750 and on custom built Nextag. I had disabled windows defender and windows firewall on all 3 machines. I have installed Norton Internet Security 2010 on all 3 machines. Seems that Microsoft doesn't recognize the antivirus portion of the Norton Internet Security 2010. Researching thru google, some say that I should disable security monitoring since I know I have antivirus running and this will solve the problem.

My question is: Is it okay to disable Security monitoring??

Many thanks

#9 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:03:28 AM

Posted 13 February 2010 - 03:32 PM

Yes, if you have anti-virus installed, it is okay to disable the nagging in the Action Center about it. This usually happens when Windows 7 is not 100% compatible with the software being used. Which means that you might need to find one that is compatible (I don't like Norton). It will probably still work as advertised, but Windows 7 just doesn't know it. :huh:
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#10 tryn2learn

tryn2learn

  • Members
  • 220 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Upstate NY
  • Local time:05:28 AM

Posted 13 February 2010 - 06:16 PM

I haven't been a fan of Norton, had it years ago and it really was a resource pig. Decided to give it a try after bad customer and tech support with Panda. This version (Norton Internet Security 2010) was written up by PC Mag. and a few others as being halfway decent. I like the look and feel, but the jury is still out as to whether it works well as I have only had it on the machines for a couple of weeks.

Win 7 recognizes Norton for the firewall, but not for the anti virus. Thanks for the info, I will give that a try and see if things speed up. That was the only item showing repeatedly in the events log for performance.

Again, thanks much for the information! :huh:

TryN




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users