Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Administrator permissons


  • Please log in to reply
10 replies to this topic

#1 SNW

SNW

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:12:32 PM

Posted 06 January 2010 - 07:46 PM

So i recently installed Windows 7. And today while i was installing anti-virus programs i was using spy-bot search and destroy to edit my start-up list.
When i went to edit it, it said i did not have administrator permissions or whatever. I'm the only account on here, and i tried to reboot into safe mode since their was an extra log-in account on that one but it just had my own. Is their a way i can change my permissions?

BC AdBot (Login to Remove)

 


#2 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:11:32 AM

Posted 06 January 2010 - 08:23 PM

If you are the only user, there is a high probability that you are admin. Just right-click on any program and select Run as administrator then you can make any system changes using that account.

#3 nauni

nauni

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Pittsburgh Pa
  • Local time:11:32 AM

Posted 06 January 2010 - 08:44 PM

Hello SNW,

First a brief explanation of why. You are the administrator of your machine, but a limited administrator. There is an administrator account with full permissions but this is disabled by default in vista and Windows 7, so even if you do boot into Safe Mode you will not see it as an account to log into.

The fix :huh: there are two ways to fix this and the first one is best and preferred practice. But it will be your choice.

First Option:

Go to the program you want to open, do not open it, right click it and select "Run as administrator"

Second Option:

Disable or Turn Off UAC (User Account Control) in Control Panel

1.Go to Start Menu -> Control Panel -> User Accounts.
2.Click on User Account Control settings link.
3.Slide the slider bar to the lowest value (towards Never Notify), with description showing Never notify me.
4.Click OK to make the change effective.
5.Restart the computer to turn off User Access Control.

This should take care of you :huh:

Thank you
Naunid
NAUNI

"Your life is an occasion. Rise to it."

by Zach Helm

#4 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:11:32 AM

Posted 06 January 2010 - 10:30 PM

Yes you can disable the UAC but it is not recommended. Because then any program can make change to your system without you even knowing.

#5 nauni

nauni

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Pittsburgh Pa
  • Local time:11:32 AM

Posted 06 January 2010 - 11:49 PM

Hi Romeo29

I agree fully :huh: , hey sorry for posting after you. I opened to answer before any one had answered on this and got a phone call during and well so goes the story, posted before I realized you had.

:huh:
NAUNI

"Your life is an occasion. Rise to it."

by Zach Helm

#6 SNW

SNW
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:12:32 PM

Posted 07 January 2010 - 02:22 AM

Thank you :huh: problem solved.

#7 nauni

nauni

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Pittsburgh Pa
  • Local time:11:32 AM

Posted 11 January 2010 - 04:14 PM

Hello SNW,

Great glad to hear the problem is solved. :huh:

Nauni
NAUNI

"Your life is an occasion. Rise to it."

by Zach Helm

#8 Aussieroo

Aussieroo

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:02:32 AM

Posted 19 January 2010 - 07:37 PM

Whilst on this topic, I had an occasion where using Phtoshop CS4 in bridge mode I was trying to alocate ratings and it wouldn't work.
Finally in fustraion I opened up a file that was saved on my C drive and it allowed me to save the ratings changes. It occured to me
that it had to be a secruities issue so I went and changed the securities on my F drive ( A drive where I keep all my photo files) and then I was able to
have PS write to those files. I keep coming across this issue from tiem to time where it says you don't have permission to access etc and even
though I have tried the above and applied security settings to the whole of the C drive and even though,like "SNW" I am the only user and the administrator
I still get instances where I don't have permission. My question is, is there a way to have total blanket authority over my own computer or do I
have to have MS in control of what I can do? And, Naunid, is there a way of setting full administrator permanently, so I don't have to go through this all the time?

Aussie

#9 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:11:32 AM

Posted 19 January 2010 - 09:14 PM

And, Naunid, is there a way of setting full administrator permanently, so I don't have to go through this all the time?


Read Second Option in post #3

#10 Aussieroo

Aussieroo

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:02:32 AM

Posted 19 January 2010 - 10:32 PM

And, Naunid, is there a way of setting full administrator permanently, so I don't have to go through this all the time?


Read Second Option in post #3


Thank you, my eyes aren't quite that bad yet that I would miss that. It wasn't clear to me that this process would then change to full administrator rights all the time. I have tried that and while it stopped the pop ups for installing it didn't seem to stop the "You don't have permission to access this folder" type pop ups. I will give it another go to be sure though

Edited by Aussieroo, 19 January 2010 - 10:33 PM.


#11 nauni

nauni

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Pittsburgh Pa
  • Local time:11:32 AM

Posted 19 January 2010 - 11:19 PM

Hello Aussieroo,

Double check to see if you are trying to access the link to the folder or if you are trying to access the actual file. Vista and Windows 7 both use links to files and folders. If you are trying to access through one of the links it will not work, you must go to the actual file/folder.

Thank you
Naunid
NAUNI

"Your life is an occasion. Rise to it."

by Zach Helm




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users