Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

networking a printer


  • Please log in to reply
63 replies to this topic

#1 dempseyjosh

dempseyjosh

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 28 December 2009 - 05:58 AM

Hi,
I'm trying to set up my printer to be used by my laptop, while it is connected to my desktop.
the desktop has win7 64bit, and the laptop has win7 32 bit.
they are both in the same homegroup, and the driver is installed on each computer, but when i try to add teh printer it says "windows cannot connect to the printer." "operation failed with error 0x0000000d."

i don't know why it isn't working for me

BC AdBot (Login to Remove)

 


#2 dempseyjosh

dempseyjosh
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 28 December 2009 - 06:40 AM

this is really annoying, now the laptop isn't even finding the printer when i click search

#3 Techguy27

Techguy27

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:26 PM

Posted 28 December 2009 - 06:01 PM

Do either computers have Windows Firewall turned on, or any other Anti Virus program with built in firewall turned on? (ie. Norton)

Did you download both the 64bit and 32bit drivers for each operating system?

#4 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:26 PM

Posted 28 December 2009 - 09:17 PM

You have to actually share it. Just putting both PCs it in the same homegroup doesn't share it. You'll also want to right click it once its shared and make sure the permissions are set to Everyone

I found this site on how to share it on Win7.

I found this site sharing it between Win 7 and XP. Altho the screens are different the steps are almost the same on adding a printer in XP and Win 7.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#5 dempseyjosh

dempseyjosh
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 28 December 2009 - 09:39 PM

ok, both computers have the driver required for it to print off of that computer if it is directly plugged into it. Then i plug it into the desktop. Both computers have Everything shared, that you can share by checking a check box. then from the laptop i try to add the printer(it can find it on the network, but i get the error when trying to add it as a printer on the laptop)
i do have mcafee on both computers. i turned everything off and then tried installing and it still didn't work.
i don't know how to have more than one driver on each computer, without the latest one installed overwriting the previous one.

#6 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:26 PM

Posted 28 December 2009 - 10:29 PM

Are you adding it as a network printer? Because that is what it is.

When you shared it what did you name it? In one of those sites it has how to add the printer to the client PC(which ever one it is not directly connected). In the network address it has //Print_server/name of share. It is not a driver issue it is a share/permissions issue. In that example the Print_server is the name of the PC with the printer directly connected to it. I can't browse for my print server and find it but if I put the IP address in that box it connects right to it.

And when you share it and its all done, right click, look at the permissions just to make sure it has Everyone listed.

McaFee what? AV? FW?

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#7 dempseyjosh

dempseyjosh
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 28 December 2009 - 10:42 PM

i'm actually discovering that it isn't a sharing problem with the printer. i've done all that correctly. it is a network problem
i can see things from the desktop on the laptop, but from the desktop, i cannot see anything on the laptop.

if i create a homegroup from the desktop, i can join it from the laptop.
but if i create a homegroup from the laptop, the desktop doesn't see it.

mcafee antivirus and firewall and whatever else is packaged together with it.

the printer is connected directly to the desktop //josh-pc/lexmark 1200 series i know all that. i just get an error. file and printer sharing is on, network discovery is on, password protected sharing is off

#8 dempseyjosh

dempseyjosh
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 28 December 2009 - 10:52 PM

So the topic should be changed to networking windows7 64bit and windows7 32 bit. I have to get that squared away so i can see each computer from each, before i worry about the printer.

#9 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:03:26 PM

Posted 28 December 2009 - 11:07 PM

Yeah, this homegroup stuff is supposed to be simplified in Windows 7, but it can be just as tricky as before.

But yeah, I think you should create the homegroup on the desktop and join with the laptop.

One thing I found out is this: if the settings for the built-in Guest account aren't correct, the sharing stuff won't work correctly (one of my major issues I had). I don't know if that is what is keeping yours from working, but try it and see.

Here is how I fixed it:

Start Menu > type in "cmd" without the quotes > right-click > Run as Administrator > "Yes" to the UAC prompt > type in the following:

net user guest *

(that's a space between each word including the asterisk)
hit "Enter" key 3 times (nothing else!)

You should see "The command completed successfully."

Basically, what you did is reset the Guest password to nothing (required for sharing of network stuff like printers). It took me a few hours of internet searching to find that solution. Fixed it right away. Because if there is a password (yes, even if you didn't set one!), you can see the printer over the network, but trying to connect gives an error (fiddled with this a lot with my college roommate). It's a quirky thing, but that was the solution to it.

That may or may not be your issue, but it fixed mine. Yours could simply be 64 to 32 bit problems. Not really sure.

I had a printer connected to my Dell running Windows 7 Pro trying to share it with an HP running XP Home. Now that can be tricky!! But after a few hours of head scratching (and banging), I got it to work (more than once actually, after I screwed it up a couple times afterward).

Let us know if that fixed it....
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#10 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:26 PM

Posted 29 December 2009 - 01:39 AM

If they can both surf the net connected to the same router, I'm doubting its a networking issue. I'm willing to bet that something is blocking your access.

To test the networking - get the IP address of each PC and ping it from the other. Also try pinging the names of the PCs.

HomeGroup how-to

Setting up McaFee
  • On the McAfee SecurityCenter pane, click Internet & Network, then click Configure.
  • On the Internet & Network Configuration pane, under Firewall protection is enabled, click Advanced.
  • On the Firewall pane, click Trusted and Banned IPs.
  • On the Trusted and Banned IPs pane, select Trusted IP Addresses, and then click Add.
  • Under Add Trusted IP Address Rule, do one of the following:
    a ) Select Single IP Address, and then enter the IP address. b ) Select IP Address Range, and then enter the starting and ending IP addresses in the From IP Address and To IP Address boxes. This should go from the Default gateway(DG) you saw when you typed ipconfig at a command prompt and add 10 to the last number (Example - DG = 192.168.1.1. You should enter 192.168.1.1 to 192.168.1.12)
  • Optionally, select Rule expires in, and enter the number of days to enforce the rule.
  • Optionally, type a description for the rule.
  • Click OK.
  • On the Trusted and Banned IPs dialog, click Yes to confirm.
"i can see things from the desktop on the laptop, but from the desktop, i cannot see anything on the laptop" So from the laptop you can see the desktop but from the desktop you can't see the laptop. So how is the statement below possible?

"if i create a homegroup from the desktop, i can join it from the laptop. but if i create a homegroup from the laptop, the desktop doesn't see it." Are you doing this at the same time? Because if the desktop is joined by the laptop and you goto the laptop to join the desktop, that's not how it works. There is one HomeGroup per network.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#11 dempseyjosh

dempseyjosh
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 29 December 2009 - 09:12 AM

i don't have time to try fixing it now. but as for this....

"i can see things from the desktop on the laptop, but from the desktop, i cannot see anything on the laptop" So from the laptop you can see the desktop but from the desktop you can't see the laptop. So how is the statement below possible?

"if i create a homegroup from the desktop, i can join it from the laptop. but if i create a homegroup from the laptop, the desktop doesn't see it." Are you doing this at the same time? Because if the desktop is joined by the laptop and you goto the laptop to join the desktop, that's not how it works. There is one HomeGroup per network.


i would try them one at a time..... create the group from the desktop then join from the laptop. when it didn't work, i left the group from both computers and tried with the laptop and joining from the desktop

#12 dempseyjosh

dempseyjosh
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 29 December 2009 - 10:29 AM

ok, so i checked mcafee and the ip range of the network is already in the trusted range on both computers

i turned on guest accounts and made sure there were no passwords.

from right then, on the laptop if i click network and sharing center i was able to see the desktop was on the network, but it was not able to be mapped
and on the desktop, by clicking network and sharing center, all i saw was the desktop connected to the router. ( there was no homegroup at this point)

i created a homegroup from the desktop, and the laptop did not see this homegroup. I had to run the homegoup troubleshooter, on both computers, to get it to see that.

Then i joined the homegroup from the laptop.

then for some reason, from the desktop, i can only see the laptop as a media device. and from the laptop i only see the desktop computer, not as a media device, neither computer is set to stream media.

then i restarted and now from the laptop i don't see the desktop at all, and from the desktop i see the laptop as a computer, but can't access it, it says to check the spelling, otherwise there might be a problem with the network.

and this is where i am stuck now..........

Edited by dempseyjosh, 29 December 2009 - 10:38 AM.


#13 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:26 PM

Posted 29 December 2009 - 12:54 PM

LMAO!! Sorry to laugh but from what I have read about this HomeGroup thing its supposed to make all this a snap! And yet here you are about to throw the crap out the window lol.

Maybe Ninja hit it with its a 64 bit to 32 bit thing. But I have no idea what that "thing" might be. Besides the 64 vs 32, are they the same flavor? Ultimate or whatever flavors Win7 has.

Did you ping the IP and names? I am willing to bet that the IP will work but the name won't.

Is IPv6 installed on both? If it is you could try removing that on both. Might be a conflict there.

Let me know about the pings and we'll go from there.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#14 Techguy27

Techguy27

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:26 PM

Posted 29 December 2009 - 01:28 PM

Maybe Ninja hit it with its a 64 bit to 32 bit thing. But I have no idea what that "thing" might be. Besides the 64 vs 32, are they the same flavor? Ultimate or whatever flavors Win7 has.


I wouldn't imagine that the 64bit vs. 32bit makes a difference. You should be able to download the 32bit driver for the laptop and while installing the printer located at \\desktop\"Printer Name" it will ask you for the driver. At which point you would point it to the folder you unpacked the 32bit driver in.

If you are unable to see the printer, I still believe it is a software issue blocking you from doing so. Just for testing purposes, I would disable all AV software, and windows firewall.

Here is a link for Windows 7 to XP. It does not exactly apply, but take a look at the Sharing settings for the Windows 7 portion to verify it is shared correctly.

Sharing Windows 7 to XP

#15 dempseyjosh

dempseyjosh
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 29 December 2009 - 02:15 PM

At this point I've given up on the printer and just want to get the homegroup set up right. I'm pretty positive that I had all the right things checked for sharing.
I don't know how to ping The ip and/or names




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users