Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Restarts insteads of Shuts down. (Win7 32-bit, desktop)


  • Please log in to reply
13 replies to this topic

#1 andrewset

andrewset

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:12:43 AM

Posted 16 December 2009 - 06:28 PM

Approximately 2-week old Windows 7 (32-bit) installation. Desktop computer.
I shut down my computer every night. Starting 3 days ago, for 2 nights in a row, after clicking "Shut down," the computer only got as far as showing the desktop with nothing else, but never got to the point of shutting down, so I switched the computer off from the back of the tower. Then, last night, "Shut down" was taken as "Restart." I waited for the computer to boot up again, tried "Shut down" again, and, again, the computer instead restarted. Then I tried all sorts of things, like "Hibernate," and the computer restarted. I even went into Safe Mode, selected "Shut down," and, yes, the computer restarted.
How can I get "Shut down" to shut the blasted thing down already?:huh:

BC AdBot (Login to Remove)

 


#2 WalkerA_WinTeam

WalkerA_WinTeam

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:09:43 PM

Posted 17 December 2009 - 03:02 PM

Make sure Wake-on-LAN is disabled in the BIOS (also disable WoWLAN if you're on a newer PC).

This is an older article but it should point you in the right direction: http://www.windowsnetworking.com/articles_...s-Shutdown.html

There's a Microsoft Answers thread about this as well - you might try asking there too: http://social.answers.microsoft.com/Forums...5b-2935c8c3e108

Good luck, let us know if you get anywhere with this...

Walker
Windows Outreach Team

#3 andrewset

andrewset
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:12:43 AM

Posted 17 December 2009 - 06:07 PM

Unfortunately, I looked through my BIOS in detail and couldn't find a Wake-on-LAN or WoWLAN option.

I read the article and thread you gave me and made the applicable changes, but still no joy.

As I'm running out of options, is there another way to shut down the computer safely other than 'Shut down'? Or, is there a point during the shut down sequence, such as as soon as it turns black but before it restarts, that I can flip off the system from the back?

EDIT: Another forum also has me delete all my drivers and reinstall them, which took me a few hours, especially to figure out how to get online again, and still no good.

Edited by andrewset, 17 December 2009 - 06:09 PM.


#4 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:10:43 PM

Posted 17 December 2009 - 08:24 PM

I know you are frustrated, but by trying to get help on two different forums, the likely outcome is that something is going to go very, very wrong when you get conflicting advice.

Reinstalling your drivers is going to have no effect. When drivers are corrupt, very bad things happen, mostly along the line of BSODs. So there are a couple of things that could be happening. First, have you noticed if maybe your system was trying to apply updates at the time of shutdown? Next, it may be that one of the hardware devices has been set to keep the system awake. The Bios has a wake on lan, but the network card has settings in the device manager that can be set to allow the device to wake the computer, which could prevent it from shutting down.

When you say that it won't sht down, are you waiting ten seconds, 20 minutes, 2 hours?

You want to use the power off option in Windows to shut down your computer. Just because the screen is black doesn't mean that the system has completed housecleaning. Shutting down the power before the system is done definitely will cause problems.

#5 andrewset

andrewset
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:12:43 AM

Posted 17 December 2009 - 08:51 PM

I set the network card to not wake the computer too, but still no improvement. Is there something else that can be set to wake the computer besides the network card?
It acts like it shuts down but immediately reboots after turning black. Instead of a peaceful quiet, the computer starts up again. It happens pretty quickly.

#6 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:10:43 PM

Posted 17 December 2009 - 09:07 PM

It could be the keyboard, the mouse, the hard drive, really anything.

#7 andrewset

andrewset
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:12:43 AM

Posted 17 December 2009 - 09:24 PM

I'll focus on my NVIDIA graphics card for now, then. How would I make sure it isn't waking the computer up, like I did with the network card?

EDIT: I think I just spent the last 15min going down the list of every single item in my Device Manager, right-clicking, going to Properties, and checking if it had a "Power Management" tab, which is where the "do not wake the computer" option would be, and only the Keyboard had the option checked, so I unchecked it.

Edited by andrewset, 17 December 2009 - 09:39 PM.


#8 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:10:43 PM

Posted 17 December 2009 - 09:54 PM

An output device is not going to cause your system to wake. It is only input devices like keyboard, mouse, network cards, microphones, cameras, etc. Although I doubt cameras and microphones have the ability to wake the system. Most of the devices should have power management settings available in the device manager.

Hit the Windows key on your keyboard, type in 'device manager' in the search box, then open the device manager. Right click on the various input devices, select properties, and see if they have a 'power management' tab.

The other thing you can check is your event viewer to see if there is something there that is waking the system, or causing an error that is derailing the shutdown process. I have no idea where that would be, or what the classification would be, so that might take a bit of research.

One other thing to try is going to the command prompt, and typing in shutdown /f. If an application is preventing the system from shutting down, this should force a shutdown. This would also might give some idea of whether it is a device preventing shutdown, or an application.

#9 andrewset

andrewset
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:12:43 AM

Posted 17 December 2009 - 11:53 PM

As I said, I already checked for every device that has the 'power management' tab and turned off any that had the wake box checked.
Unfortunately, shutdown /f only acts as if I selected "Log off."
The Event Viewer gives an error at the time of attempted Shut down of "The NVIDIA Display Driver Service service has reported an invalid current state 32."

#10 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:10:43 PM

Posted 18 December 2009 - 01:29 AM

My Nvidia drivers occasionally throw that error also. My system shuts down just fine, so I am out of ideas right now.

#11 andrewset

andrewset
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:12:43 AM

Posted 18 December 2009 - 09:01 AM

My computer hasn't rested for 3 days and 2 nights. What's the safest way to use the switch at the back of the computer tower to force a shut down when absolutely necessary?

#12 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:10:43 PM

Posted 18 December 2009 - 11:59 AM

There is no safest way to use the switch on the back of the computer. You would be better off shutting it down by holding down the on/off button until the computer shuts down.

#13 andrewset

andrewset
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:12:43 AM

Posted 18 December 2009 - 03:38 PM

I DID IT!!!!!!!!!!!!!!!
BIOS setting:
Power tab
* * * Remote Power-on: [Disabled] * * *
(originally was [Enabled], though i don't remember ever turning it on)

Thanks!! Hope this helps someone in the future<3

#14 WalkerA_WinTeam

WalkerA_WinTeam

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:09:43 PM

Posted 18 December 2009 - 05:25 PM

I DID IT!!!!!!!!!!!!!!!
BIOS setting:
Power tab
* * * Remote Power-on: [Disabled] * * *
(originally was [Enabled], though i don't remember ever turning it on)

Thanks!! Hope this helps someone in the future<3


Awesome! Thanks for your persistence and patience :huh: People will definitely benefit from this thread now, just as soon as it's indexed in the search engines!

Let us know if you need anything else.

Cheers,

Walker
Windows Outreach Team

Edited by WalkerA_WinTeam, 18 December 2009 - 05:26 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users