Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My laptop is all messed up after Windows 7 upgrade


  • Please log in to reply
7 replies to this topic

#1 btrflywngs88

btrflywngs88

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:40 AM

Posted 10 December 2009 - 06:06 PM

Hi, I have an Acer Aspire 5517 laptop and it's a few weeks old. It came with Windows Vista, and I got a free upgrade for Windows 7 in the mail. This laptop was running perfectly until the other day when I installed Win 7. Now when I go to shut it down, it stays on that screen, and just keeps saying "shutting down". Then I have to manually shut it down w/ the power button. Then when it starts up again it opens with an error saying it was shut down improperly, and I have to select "normal startup". When it does start up, the Windows logo is all distorted for a second then goes to my desktop. Also, when I close the lid on my laptop it used to go to sleep, then upon opening lid, it would turn right on. Now it does not do this, it stays in the sleep mode, but never turns back on, unless I manually shut it down, then start again.

Any help would be greatly appreciated.

Kimmie

BC AdBot (Login to Remove)

 


#2 SweetnLow

SweetnLow

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Location:Oregon, USA
  • Local time:05:40 AM

Posted 11 December 2009 - 12:48 PM

I just installed Win7 the other day, and I have other issues. It seems like my video drivers are acting unresponsive and my wireless internet connection is spotty. I have half a mind to send my computer back to Alienware and tell them to fix it or give me a Mac.

#3 ReviverSoft

ReviverSoft

    Happy to help!


  • Members
  • 1,552 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Somewhere on this planet...
  • Local time:03:40 AM

Posted 11 December 2009 - 01:55 PM

Hi, I have an Acer Aspire 5517 laptop and it's a few weeks old. It came with Windows Vista, and I got a free upgrade for Windows 7 in the mail. This laptop was running perfectly until the other day when I installed Win 7. Now when I go to shut it down, it stays on that screen, and just keeps saying "shutting down". Then I have to manually shut it down w/ the power button. Then when it starts up again it opens with an error saying it was shut down improperly, and I have to select "normal startup". When it does start up, the Windows logo is all distorted for a second then goes to my desktop. Also, when I close the lid on my laptop it used to go to sleep, then upon opening lid, it would turn right on. Now it does not do this, it stays in the sleep mode, but never turns back on, unless I manually shut it down, then start again.

Any help would be greatly appreciated.

Kimmie


Are you sure you have Win7 drivers installed?
Only with those drivers installed, will your hardware be fully compatible with Windows 7.

Acer Drivers [Notebook > Aspire > 5517]
^ Make sure you select the right version of Windows 7.

Edited by ReviverSoft, 11 December 2009 - 01:58 PM.

ReviverSoft - Happy to help!

#4 windows.user

windows.user

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:40 AM

Posted 11 December 2009 - 06:25 PM

I have a HP Pavilion Laptop it came with Vista Home Premium on it and the free upgrade to win 7 when it was released.

I am not sure the protocol Acer or other companies have with the upgrade process to Win 7, but HP sent two discs, one was a prep disc and the other the full Win 7 upgrade disc.

The prep disc I had to run in vista before upgrading and it went through and updated drivers and it actually did a BIOS upgrade on the laptop. Once those things were done I was able to go through the upgrade process and after it was completed all the hardware worked fine. Some of the software did not work and still doesn't that HP pre installed but it isn't a big issue to me because I don't really use those software.

I did do a full backup of the hard disk before I upgraded and also after the upgrade once I got things configured.

If you are having problems with hardware, check to see if there is a bios update available for your computer and also check your hardware websites for updated drivers.

If you did not get a update prep disc for your computer, you may want to do a reformat and clean install because vista drivers are not going to work well with win 7.

I was surprised about the bios update but everything seems to work. The only thing on my HP that wont work is a linux based backup disc to access my hard disk. It just freezes, when before the bios update it worked fine. The win pe version of the backup software discs works though so I am not out of luck.

Check for Bios Updates
Check for updated drivers
Uninstall all antivirus and firewall software before upgrading to win 7

Do those three things and you should be ok.

It is possible when you did the update and you had firewall and av software installed it corrupted the update process and is causing the shut down and other issues reported. In those cases if it is not possible to do a restore to before the update you will have to reformat and do a clean install.

#5 SweetnLow

SweetnLow

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Location:Oregon, USA
  • Local time:05:40 AM

Posted 11 December 2009 - 11:29 PM

I received one disk with Win7 in it from Alienware. However, I downloaded a Win7 upgrade advisor that scanned my software and told me about the compatibility with Win7. Everything checked out. I did not uninstall my anti-virus and firewall, I disabled them like the instructions told me to. I backed everything up using CA anti-virus' backup program onto an external hard drive. Which reminds me that CA's firewall won't re-enable after I disabled it to install Win7.

#6 Derek Ellis

Derek Ellis

  • Members
  • 257 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut, USA
  • Local time:06:40 AM

Posted 12 December 2009 - 03:39 AM

I personally would never do an upgrade.
I would always do a clean install.
This means that all data has to be backed up first, since a clean install wipes the hard drive.
Wiping the hard drive also gets rid of bad drivers, viruses, registry errors, and other stuff.

#7 btrflywngs88

btrflywngs88
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:40 AM

Posted 14 December 2009 - 03:01 PM

Hi, I have an Acer Aspire 5517 laptop and it's a few weeks old. It came with Windows Vista, and I got a free upgrade for Windows 7 in the mail. This laptop was running perfectly until the other day when I installed Win 7. Now when I go to shut it down, it stays on that screen, and just keeps saying "shutting down". Then I have to manually shut it down w/ the power button. Then when it starts up again it opens with an error saying it was shut down improperly, and I have to select "normal startup". When it does start up, the Windows logo is all distorted for a second then goes to my desktop. Also, when I close the lid on my laptop it used to go to sleep, then upon opening lid, it would turn right on. Now it does not do this, it stays in the sleep mode, but never turns back on, unless I manually shut it down, then start again.

Any help would be greatly appreciated.

Kimmie


Are you sure you have Win7 drivers installed?
Only with those drivers installed, will your hardware be fully compatible with Windows 7.

Acer Drivers [Notebook > Aspire > 5517]
^ Make sure you select the right version of Windows 7.



Thank you for your response.
I went to the link you provided, but there were a bunch of drivers for my Acer model...I wasn't sure if I am supposed to download all of them or not. I'm totally lost on this one.

#8 ReviverSoft

ReviverSoft

    Happy to help!


  • Members
  • 1,552 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Somewhere on this planet...
  • Local time:03:40 AM

Posted 14 December 2009 - 04:33 PM

Hi, I have an Acer Aspire 5517 laptop and it's a few weeks old. It came with Windows Vista, and I got a free upgrade for Windows 7 in the mail. This laptop was running perfectly until the other day when I installed Win 7. Now when I go to shut it down, it stays on that screen, and just keeps saying "shutting down". Then I have to manually shut it down w/ the power button. Then when it starts up again it opens with an error saying it was shut down improperly, and I have to select "normal startup". When it does start up, the Windows logo is all distorted for a second then goes to my desktop. Also, when I close the lid on my laptop it used to go to sleep, then upon opening lid, it would turn right on. Now it does not do this, it stays in the sleep mode, but never turns back on, unless I manually shut it down, then start again.

Any help would be greatly appreciated.

Kimmie


Are you sure you have Win7 drivers installed?
Only with those drivers installed, will your hardware be fully compatible with Windows 7.

Acer Drivers [Notebook > Aspire > 5517]
^ Make sure you select the right version of Windows 7.



Thank you for your response.
I went to the link you provided, but there were a bunch of drivers for my Acer model...I wasn't sure if I am supposed to download all of them or not. I'm totally lost on this one.


You need to get them all and make sure you get the right version (Win 7...).

Edited by ReviverSoft, 14 December 2009 - 04:34 PM.

ReviverSoft - Happy to help!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users