Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7: 100% CPU Usage After Unplugging AC Power


  • Please log in to reply
2 replies to this topic

#1 tamas413

tamas413

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:39 PM

Posted 09 December 2009 - 09:02 PM

I've had Win7 for a few months now (thanks to MSDN Academic Alliance) but I've just recently started having this problem. I'm running Win7 Professional on my HP HDX16 laptop. My laptop basically runs flawless when plugged into AC power. When I unplug it, however, CPU usage skyrockets to 95%-100%. I managed to look at the task manager one time at noticed that it isn't necessarily one process that is crippling my computer; It's more like 4 or 5 programs that run around 20 CPU and the rest of the processor is used by various other programs. The process hogging programs vary sometimes, but it usually includes audiodg (audio device graph), mcshield (Mcafee), and a few other svchost (usually Win Defender, Win Firewall and AudioEndpointBuilder). I have the IDT HD audio card for those wondering (and all of the latest drivers from HP). Does anyone have any ideas as to how I can fix this?

BC AdBot (Login to Remove)

 


#2 Bugeyed

Bugeyed

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:39 AM

Posted 30 December 2009 - 12:33 PM

This is Windows 7 switching to battery mode and the power saving parts of those programs are being turned on. Because they are trusted services they get CPU priority
If you find this CPU overload a nuisance, switch power mode from power saver option (type 'power mode' into run box found from start button to get quick link to power options)

#3 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:07:39 PM

Posted 30 December 2009 - 04:24 PM

Yeah, check your power settings. Look at the max and min processor states under "Processor power management".

MSDN AA is great isn't it?! :huh: I'll never go back to Vista.

I hope you get this fixed because Windows 7 is awesome. :huh:
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users