Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How to set service to Automatic on remote workstations


  • Please log in to reply
2 replies to this topic

#1 Jimhank114

Jimhank114

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:57 PM

Posted 01 December 2009 - 12:37 PM

I have about 200 remote workstations scattered across 5 remote sites.
The workstations all log onto domain controllers and logon scripts run.

I need to make sure the "Messenger" service is set to "Automatic" and "Started" when users log on.

I don't want to specify each workstation to set the service on, I would much rather just set it in their logon script.

Ideally, something like:

sc config Messenger start=Automatic

However, this is not setting the value; instead it returns a help file type screen.
What am I missing?

sc start Messenger

works fine, but if the service is set to "Disabled" it won't start. Hence my need to set it to Automatic, or at the minimum Manual and force it to start.

Thanks in advance.

BC AdBot (Login to Remove)

 


#2 Jimhank114

Jimhank114
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:57 PM

Posted 01 December 2009 - 12:48 PM

Figured it out.
Silly Microsoft.

Answer:

sc config Messenger start= Auto

not Automatic, but Auto even though the service displays Automatic and so does the help file.

thanks to all

#3 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:08:57 PM

Posted 01 December 2009 - 01:28 PM

Thank you for posting back with your resolution
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users