Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Google redirect


  • This topic is locked This topic is locked
4 replies to this topic

#1 baylor

baylor

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:17 PM

Posted 01 December 2009 - 02:44 AM

This is a followup to the post at http://www.bleepingcomputer.com/forums/t/274514/google-redirect/. i was told i should move to the HJT forum

Problem 1. Links at Google.com end up at other sites. Redirect through site rle822x.cn. Happens in Firefox but to see if it was FF-specific, i verified that it also happens in Chrome. Problem happens even when i disable cookies, java and javascript
Problem 2. Sometimes a Google link opens the page but pops up a second tab, normally advertising DirecTV or work from home (not common other than when you first start the browser)
Problem 3. According to Tcpview, every 15-60 minutes, invisible IE processes open connections to 212.117.185.16, 213.174.149.70 and maybe 78.159.121.49 and 93.174.95.145 (it's two of those four). Both sites appear to be in China and are on malware listings i found. Note: my default browser is Firefox, and i never use IE, which is why those processes stuck out. Note 2: This happens even if i have no browser running
Problem 4. Infrequently (not sure how often), svchost runs something (DcomSvcs?) and opens a connection to the other two IP addresses in problem 3. Includes the URL canadapharmacy4you.com, which is one of the above IPs

i read manga at OneManga and they have occasional problems with their Google ads popping up bad ads. Early in the week, one of the ads popped up a modal window telling me i was infected and to buy their program. i immediately terminated the window (via Process Explorer) and ran Malware Bytes to clear out any bad things (don't remember but it might have found a trojan). After that, no noticeable virus activity but Firefox kept telling me when it restarted that it couldn't restore my tabs, which upset me. It no longer does that but now i see the Google redirect problem, which is when i started investigating more. i don't know if these three issues are related

Over the last 3 days, i've run every virus and rootkit scanner i can think of. Not one of them has identified a problem. The ones i've tried - McAfee Security Center (this is my normal program, full license), Malware Bytes (i run this at least once a week because i'm paranoid), Ad-Aware, CW Shredder, Eset, GooredFix, Housecall, Panda, Rootkit Buster, Rootkit Revealer, Root Repeal, RUBotted, Spyware Doctor, Spybot Search and Destroy and Super AntiSpyware (i think that's it, there might have been others; i run scanners one at a time, uninstalling those that can't be quit or which were getting flagged by RootRepeal). i've searched various registry keys, driver names, Google add-in caches, etc. per various posts i've found here and elsewhere. i've cleaned all temp files with CCleaner and i regularly checked my startup programs with autoruns. i've also updated Java as some people thought it might be a java exploit. i've rebooted several times. i've offered sacrifices to ancient gods. i've yelled a whole lot. i really thought the yelling would work

Current status: i set my home firewall to block outgoing connections to the IPs listed above. i installed NoScript in Firefox to prevent Google redirects. i installed Process Blocker to kill iexplore.exe whenever it launches (i never use IE, only the virus does). The problem is (mostly?) contained but not solved

i ran a win32kDiag log but it was basically blank

Here's the Root Repeal log the instructions for this forum ask for:

ROOTREPEAL AD, 2007-2009
==================================================
Scan Start Time: 2009/12/01 00:57
Program Version: Version 1.3.5.0
Windows Version: Windows XP SP3
==================================================

Drivers
-------------------
Name: dump_iaStor.sys
Image Path: C:\WINDOWS\System32\Drivers\dump_iaStor.sys
Address: 0x9F213000 Size: 815104 File Visible: No Signed: -
Status: -

Name: PROCEXP111.SYS
Image Path: C:\WINDOWS\system32\Drivers\PROCEXP111.SYS
Address: 0xF79B9000 Size: 7680 File Visible: No Signed: -
Status: -

Name: rootrepeal.sys
Image Path: C:\WINDOWS\system32\drivers\rootrepeal.sys
Address: 0x9E3A6000 Size: 49152 File Visible: No Signed: -
Status: -

Hidden/Locked Files
-------------------
Path: c:\windows\temp\mcafee_8qugezk7gfxplps
Status: Allocation size mismatch (API: 4096, Raw: 0)

Path: c:\windows\temp\mcmsc_vtjp7kje69ykosx
Status: Allocation size mismatch (API: 4096, Raw: 0)

==EOF==



Here's the DDS log:

DDS (Ver_09-11-29.01) - NTFSx86
Run by baylor at 0:20:59.06 on Tue 12/01/2009
Internet Explorer: 8.0.6001.18702 BrowserJavaVersion: 1.6.0_17
Microsoft Windows XP Professional 5.1.2600.3.1252.1.1033.18.3063.2446 [GMT -6:00]

AV: McAfee VirusScan *On-access scanning enabled* (Updated) {84B5EE75-6421-4CDE-A33A-DD43BA9FAD83}
FW: McAfee Personal Firewall *enabled* {94894B63-8C7F-4050-BDA4-813CA00DA3E8}

============== Running Processes ===============

C:\WINDOWS\system32\svchost -k DcomLaunch
svchost.exe
C:\WINDOWS\System32\svchost.exe -k netsvcs
svchost.exe
svchost.exe
C:\WINDOWS\system32\spoolsv.exe
C:\WINDOWS\Explorer.EXE
C:\Program Files\TortoiseSVN\bin\TSVNCache.exe
C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
C:\Program Files\Hewlett-Packard\HP Quick Launch Buttons\QlbCtrl.exe
C:\WINDOWS\system32\WTClient.exe
C:\Program Files\McAfee.com\Agent\mcagent.exe
C:\Program Files\Analog Devices\Core\smax4pnp.exe
C:\WINDOWS\system32\igfxpers.exe
C:\WINDOWS\system32\ctfmon.exe
C:\WINDOWS\system32\igfxsrvc.exe
svchost.exe
C:\PROGRA~1\McAfee\MSC\mcmscsvc.exe
c:\PROGRA~1\COMMON~1\mcafee\mna\mcnasvc.exe
c:\PROGRA~1\COMMON~1\mcafee\mcproxy\mcproxy.exe
C:\PROGRA~1\McAfee\VIRUSS~1\mcshield.exe
C:\Program Files\McAfee\MPF\MPFSrv.exe
C:\WINDOWS\System32\svchost.exe -k HPZ12
C:\WINDOWS\System32\svchost.exe -k HPZ12
C:\utils\system\Process Blocker\Process Blocker.exe
C:\WINDOWS\system32\tcpsvcs.exe
C:\WINDOWS\system32\svchost.exe -k imgsvc
C:\WINDOWS\System32\Drivers\WTSRV.EXE
C:\UTILS\SYSTEM\PROCESS EXPLORER\PROCEXP.EXE
C:\Program Files\Hewlett-Packard\Shared\hpqwmiex.exe
C:\WINDOWS\system32\WISPTIS.EXE
C:\PROGRA~1\McAfee\VIRUSS~1\mcsysmon.exe
C:\utils\system\Process Blocker\Tray Informer.exe
C:\Internet\Firefox\firefox.exe
C:\downloads\dds.scr

============== Pseudo HJT Report ===============

uStart Page = hxxp://www.onemanga.com/
uInternet Connection Wizard,ShellNext = hxxp://onemanga.com/
BHO: AutorunsDisabled - No File
BHO: {02478D38-C3F9-4efb-9B51-7695ECA05670} - No File
BHO: CmjBrowserHelperObject Object: {6fe6a929-59d1-4763-91ad-29b61cffb35b} - c:\program files\mindjet\mindmanager 8\Mm8InternetExplorer.dll
BHO: scriptproxy: {7db2d5a0-7241-4e79-b68d-6309f01c5231} - c:\program files\mcafee\virusscan\scriptsn.dll
BHO: Google Toolbar Notifier BHO: {af69de43-7d58-4638-b6fa-ce66b5ad205d} - c:\program files\google\googletoolbarnotifier\5.2.4204.1700\swg.dll
BHO: Java™ Plug-In 2 SSV Helper: {dbc80044-a445-435b-bc74-9c25c1c588a9} - c:\program files\java\jre6\bin\jp2ssv.dll
TB: Adobe PDF: {47833539-d0c5-4125-9fa8-0819e2eaac93} - c:\program files\adobe\acrobat 8.0\acrobat\AcroIEFavClient.dll
uRun: [swg] c:\program files\google\googletoolbarnotifier\GoogleToolbarNotifier.exe
uRun: [ctfmon.exe] c:\windows\system32\ctfmon.exe
mRun: [SynTPEnh] c:\program files\synaptics\syntp\SynTPEnh.exe
mRun: [QlbCtrl] %ProgramFiles%\Hewlett-Packard\HP Quick Launch Buttons\QlbCtrl.exe /Start
mRun: [{0228e555-4f9c-4e35-a3ec-b109a192b4c2}] c:\utils\internet\gmail notifier\gnotify.exe
mRun: [WTClient] WTClient.exe
mRun: [mcagent_exe] "c:\program files\mcafee.com\agent\mcagent.exe" /runkey
mRun: [SoundMAXPnP] c:\program files\analog devices\core\smax4pnp.exe
mRun: [IgfxTray] c:\windows\system32\igfxtray.exe
mRun: [HotKeysCmds] c:\windows\system32\hkcmd.exe
mRun: [Persistence] c:\windows\system32\igfxpers.exe
mRun: [Malwarebytes Anti-Malware (reboot)] "c:\utils\system\malwarebytes' anti-malware\mbam.exe" /runcleanupscript
StartupFolder: c:\docume~1\alluse~1\startm~1\programs\startup\yahoo!~1.lnk - c:\utils\internet\yahoo!\messenger\YahooMessenger.exe
uPolicies-explorer: NoSMHelp = 01000000
uPolicies-explorer: NoRecentDocsNetHood = 01000000
uPolicies-explorer: NoSMMyDocs = 01000000
uPolicies-explorer: NoSMMyPictures = 01000000
IE: E&xport to Microsoft Excel - c:\progra~1\micros~2\office11\EXCEL.EXE/3000
IE: {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe
IE: {2F72393D-2472-4F82-B600-ED77F354B7FF} - {6FE6A929-59D1-4763-91AD-29B61CFFB35B} - c:\program files\mindjet\mindmanager 8\Mm8InternetExplorer.dll
IE: {5067A26B-1337-4436-8AFE-EE169C2DA79F} - {77BF5300-1474-4EC7-9980-D32B190E9B07} - c:\program files\skype\toolbars\internet explorer\SkypeIEPlugin.dll
IE: {77BF5300-1474-4EC7-9980-D32B190E9B07} - {77BF5300-1474-4EC7-9980-D32B190E9B07} - c:\program files\skype\toolbars\internet explorer\SkypeIEPlugin.dll
IE: {92780B25-18CC-41C8-B9BE-3C9C571A8263} - {FF059E31-CC5A-4E2E-BF3B-96E929D65503} - c:\progra~1\micros~2\office11\REFIEBAR.DLL
DPF: {00000055-9980-0010-8000-00AA00389B71} - hxxp://codecs.microsoft.com/codecs/i386/fhg.CAB
DPF: {166B1BCA-3F9C-11CF-8075-444553540000} - hxxp://download.macromedia.com/pub/shockwave/cabs/director/sw.cab
DPF: {6C275925-A1ED-4DD2-9CEE-9823F5FDAA10} - hxxps://ra.idq.com/vdesk/terminal/urTermProxy.cab#version=5400,0,50412,1
DPF: {7584c670-2274-4efb-b00b-d6aaba6d3850} - hxxps://ra.idq.com/vdesk/terminal/msrdp.cab#version=5,2,3790,0
DPF: {8AD9C840-044E-11D1-B3E9-00805F499D93} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_17-windows-i586.cab
DPF: {9191F686-7F0A-441D-8A98-2FE3AC1BD913} - hxxp://acs.pandasoftware.com/activescan/cabs/as2stubie.cab
DPF: {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_17-windows-i586.cab
DPF: {CAFEEFAC-FFFF-FFFF-FFFF-ABCDEFFEDCBA} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_17-windows-i586.cab
DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} - hxxp://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab
DPF: {E0FF21FA-B857-45C5-8621-F120A0C17FF2} - hxxps://ra.idq.com/vdesk/terminal/urxhost.cab
Handler: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - c:\progra~1\common~1\skype\SKYPE4~1.DLL
Notify: !SASWinLogon - c:\utils\system\superantispyware\SASWINLO.DLL
Notify: igfxcui - igfxdev.dll
SSODL: WPDShServiceObj - {AAA288BA-9A4C-45B0-95D7-94D524869DB5} - c:\windows\system32\WPDShServiceObj.dll
SEH: SABShellExecuteHook Class: {5ae067d3-9afb-48e0-853a-ebb7f4a000da} - c:\utils\system\superantispyware\SASSEH.DLL
SecurityProviders: msapsspc.dll, schannel.dll, digest.dll
mASetup: {10880D85-AAD9-4558-ABDC-2AB1552D831F} - "c:\program files\common files\lightscribe\LSRunOnce.exe"
IFEO: taskmgr.exe - "c:\utils\system\process explorer\PROCEXP.EXE"

================= FIREFOX ===================

FF - ProfilePath - c:\docume~1\baylor\applic~1\mozilla\firefox\profiles\52qmfdgf.default\
FF - prefs.js: browser.startup.homepage - hxxp://onemanga.com/
FF - plugin: c:\documents and settings\baylor\application data\move networks\plugins\npqmp071505000010.dll
FF - plugin: c:\documents and settings\baylor\local settings\application data\google\update\1.2.183.7\npGoogleOneClick8.dll
FF - plugin: c:\documents and settings\baylor\local settings\application data\unity\webplayer\loader\npUnity3D32.dll
FF - plugin: c:\internet\firefox\plugins\npbittorrent.dll
FF - plugin: c:\program files\google\google updater\2.4.1739.5352\npCIDetect13.dll
FF - plugin: c:\program files\google\update\1.2.183.7\npGoogleOneClick8.dll
FF - plugin: c:\program files\unity\webplayer\loader\npUnity3D32.dll
FF - plugin: c:\utils\graphics\divx\divx player\npDivxPlayerPlugin.dll
FF - plugin: c:\utils\graphics\divx\divx web player\npdivx32.dll
FF - plugin: c:\utils\graphics\vlc\npvlc.dll
FF - HiddenExtension: Microsoft .NET Framework Assistant: {20a82645-c095-46ed-80e3-08825760534b} - c:\windows\microsoft.net\framework\v3.5\windows presentation foundation\dotnetassistantextension\
FF - HiddenExtension: Java Console: No Registry Reference - c:\internet\firefox\extensions\{CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}

---- FIREFOX POLICIES ----
c:\internet\firefox\greprefs\security-prefs.js - pref("security.ssl3.rsa_seed_sha", true);

============= SERVICES / DRIVERS ===============

R0 pavboot;pavboot;c:\windows\system32\drivers\pavboot.sys [2009-11-27 28552]
R1 mfehidk;McAfee Inc. mfehidk;c:\windows\system32\drivers\mfehidk.sys [2009-1-1 214664]
R1 SASDIFSV;SASDIFSV;c:\utils\system\superantispyware\sasdifsv.sys [2009-8-5 9968]
R1 SASKUTIL;SASKUTIL;c:\utils\system\superantispyware\SASKUTIL.SYS [2009-8-5 74480]
R2 McProxy;McAfee Proxy Service;c:\progra~1\common~1\mcafee\mcproxy\mcproxy.exe [2009-1-1 359952]
R2 McShield;McAfee Real-time Scanner;c:\progra~1\mcafee\viruss~1\mcshield.exe [2009-1-1 144704]
R2 Process Blocker;Process Blocker;c:\utils\system\process blocker\Process Blocker.exe [2009-5-20 96472]
R3 IFXTPM;IFXTPM;c:\windows\system32\drivers\ifxtpm.sys [2007-12-16 36608]
R3 McSysmon;McAfee SystemGuards;c:\progra~1\mcafee\viruss~1\mcsysmon.exe [2009-1-1 606736]
R3 mfeavfk;McAfee Inc. mfeavfk;c:\windows\system32\drivers\mfeavfk.sys [2009-1-1 79816]
R3 mfebopk;McAfee Inc. mfebopk;c:\windows\system32\drivers\mfebopk.sys [2009-1-1 35272]
R3 mfesmfk;McAfee Inc. mfesmfk;c:\windows\system32\drivers\mfesmfk.sys [2009-1-1 40552]
R3 PTSimBus;PenTablet Bus Enumerator;c:\windows\system32\drivers\PTSimBus.sys [2007-6-7 18944]
S3 HP24X;HP PC Card Smart Card Reader;c:\windows\system32\drivers\HP24X.sys [2007-12-16 33024]
S3 mferkdk;McAfee Inc. mferkdk;c:\windows\system32\drivers\mferkdk.sys [2009-1-1 34248]
S3 PTSimHid;PenTablet Simulated HID MiniDriver;c:\windows\system32\drivers\PTSimHid.sys [2007-4-23 10752]
S3 SASENUM;SASENUM;c:\utils\system\superantispyware\SASENUM.SYS [2009-8-5 7408]
S3 SWIHPWMI;SWIHPWMI;c:\program files\hpq\shared\sierra wireless\win32\unicode\SWIHPWMI.exe [2006-12-4 292384]
S3 TMPassthruMP;TMPassthruMP;c:\windows\system32\drivers\tmpassthru.sys --> c:\windows\system32\drivers\TMPassthru.sys [?]

=============== Created Last 30 ================

2009-12-01 05:01:07 161296 ----a-w- c:\windows\system32\drivers\tmcomm.sys
2009-12-01 02:27:11 7235 ----a-w- c:\windows\system32\Config.MPF
2009-11-29 23:56:36 237600 ----a-w- c:\windows\system32\drivers\str.sys
2009-11-29 23:56:34 78720 ----a-w- c:\windows\system32\drivers\azdnvz.sys
2009-11-29 20:11:09 0 d-----w- c:\program files\Sun
2009-11-29 20:08:46 73728 ----a-w- c:\windows\system32\javacpl.cpl
2009-11-29 04:05:19 0 d-----w- c:\program files\ESET
2009-11-29 01:53:29 0 ---ha-w- C:\aaw7boot.cmd
2009-11-28 22:04:35 93360 ----a-w- c:\windows\system32\drivers\SBREDrv.sys
2009-11-28 07:13:01 820 ----a-w- c:\documents and settings\baylor\t
2009-11-28 03:45:14 50176 -c--a-w- c:\windows\system32\dllcache\proquota.exe
2009-11-28 03:45:14 50176 ----a-w- c:\windows\system32\proquota.exe
2009-11-28 03:14:19 0 d-sha-r- C:\cmdcons
2009-11-28 03:12:02 77312 ----a-w- c:\windows\MBR.exe
2009-11-28 03:11:59 98816 ----a-w- c:\windows\sed.exe
2009-11-28 03:11:59 260608 ----a-w- c:\windows\PEV.exe
2009-11-28 03:11:59 161792 ----a-w- c:\windows\SWREG.exe
2009-11-28 00:37:08 28552 ----a-w- c:\windows\system32\drivers\pavboot.sys
2009-11-28 00:37:03 0 d-----w- c:\program files\Panda Security
2009-11-20 16:25:35 0 d-----w- c:\docume~1\baylor\applic~1\TortoiseSVN
2009-11-20 16:22:53 0 d-----w- c:\docume~1\baylor\applic~1\Subversion
2009-11-20 16:21:53 0 d-----w- c:\program files\TortoiseSVN
2009-11-20 16:21:53 0 d-----w- c:\program files\common files\TortoiseOverlays
2009-11-16 23:50:07 0 d--h--w- c:\windows\msdownld.tmp
2009-11-03 16:17:48 0 d-----w- c:\program files\common files\PACE Anti-Piracy
2009-11-03 16:17:48 0 d-----w- c:\docume~1\baylor\applic~1\PACE Anti-Piracy
2009-11-03 16:17:48 0 d-----w- c:\docume~1\alluse~1\applic~1\PACE Anti-Piracy

==================== Find3M ====================

2009-11-29 20:08:13 411368 ----a-w- c:\windows\system32\deploytk.dll
2009-11-16 23:54:05 444952 ----a-w- c:\windows\system32\wrap_oal.dll
2009-11-16 23:54:05 109080 ----a-w- c:\windows\system32\OpenAL32.dll
2009-09-17 00:03:56 376832 ----a-w- c:\windows\system32\AegisI5Installer.exe
2009-09-16 01:06:40 6400 ----a-w- c:\windows\system32\d3d9caps.dat
2009-09-11 14:18:39 136192 ----a-w- c:\windows\system32\msv1_0.dll
2009-09-04 23:44:40 69464 ----a-w- c:\windows\system32\XAPOFX1_3.dll
2009-09-04 23:44:40 515416 ----a-w- c:\windows\system32\XAudio2_5.dll
2009-09-04 23:44:40 238936 ----a-w- c:\windows\system32\xactengine3_5.dll
2009-09-04 23:29:34 453456 ----a-w- c:\windows\system32\d3dx10_42.dll
2009-09-04 23:29:34 235344 ----a-w- c:\windows\system32\d3dx11_42.dll
2009-09-04 23:29:32 5501792 ----a-w- c:\windows\system32\d3dcsx_42.dll
2009-09-04 23:29:32 1974616 ----a-w- c:\windows\system32\D3DCompiler_42.dll
2009-09-04 23:29:30 1892184 ----a-w- c:\windows\system32\D3DX9_42.dll
2009-09-04 21:03:36 58880 ----a-w- c:\windows\system32\msasn1.dll
2008-09-13 01:08:43 32768 --sha-w- c:\windows\system32\config\systemprofile\local settings\history\history.ie5\mshist012008091220080913\index.dat

============= FINISH: 0:22:56.48 ===============

Attached Files



BC AdBot (Login to Remove)

 


#2 Elise

Elise

    Bleepin' Blonde


  • Malware Study Hall Admin
  • 61,648 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Romania
  • Local time:02:17 AM

Posted 14 December 2009 - 04:11 PM

Hello ,
And :( to the Bleeping Computer Malware Removal Forum
. My name is Elise and I'll be glad to help you with your computer problems.


I will be working on your malware issues, this may or may not solve other issues you may have with your machine.

Please note that whatever repairs we make, are for fixing your computer problems only and by no means should be used on another computer.

You may want to keep the link to this topic in your favorites. Alternatively, you can click the button at the top bar of this topic and Track this Topic, where you can choose email notifications. The topics you are tracking are shown here.
-----------------------------------------------------------
If you have since resolved the original problem you were having, we would appreciate you letting us know. If not please perform the following steps below so we can have a look at the current condition of your machine.

If you have not done so, include a clear description of the problems you're having, along with any steps you may have performed so far.

If you have already posted a DDS log, please do so again, as your situation may have changed.
Use the 'Add Reply' and add the new log to this thread.

We need to see some information about what is happening in your machine. Please perform the following scan:
  • Download DDS by sUBs from one of the following links. Save it to your desktop.
  • Double click on the DDS icon, allow it to run.
  • A small box will open, with an explanation about the tool. No input is needed, the scan is running.
  • Notepad will open with the results.
  • Follow the instructions that pop up for posting the results. Post both logs (no need to zip attach.txt).
  • Close the program window, and delete the program from your desktop.
Please note: You may have to disable any script protection running if the scan fails to run. After downloading the tool, disconnect from the internet and disable all antivirus protection. Run the scan, enable your A/V and reconnect to the internet.

Information on A/V control HERE


Please download GMER from one of the following locations and save it to your desktop:
  • Main Mirror
    This version will download a randomly named file (Recommended)
  • Zipped Mirror
    This version will download a zip file you will need to extract first. If you use this mirror, please extract the zip file to your desktop.
  • Disconnect from the Internet and close all running programs.
  • Temporarily disable any real-time active protection so your security programs will not conflict with gmer's driver.
  • Double-click on the randomly named GMER file (i.e. n7gmo46c.exe) and allow the gmer.sys driver to load if asked.
  • Note: If you downloaded the zipped version, extract the file to its own folder such as C:\gmer and then double-click on gmer.exe.

    Posted Image
  • GMER will open to the Rootkit/Malware tab and perform an automatic quick scan when first run. (do not use the computer while the scan is in progress)
  • If you receive a WARNING!!! about rootkit activity and are asked to fully scan your system...click NO.
  • Now click the Scan button. If you see a rootkit warning window, click OK.
  • When the scan is finished, click the Save... button to save the scan results to your Desktop. Save the file as gmer.log.
  • Click the Copy button and paste the results into your next reply.
  • Exit GMER and re-enable all active protection when done.
-- If you encounter any problems, try running GMER in Safe Mode.

-------------------------------------------------------------
Please be patient and I'd be grateful if you would note the following
  • The cleaning process is not instant. DDS logs can take some time to research, so please be patient with me. I know that you need your computer working as quickly as possible, and I will work hard to help see that happen.
  • Please reply using the Add/Reply button in the lower right hand corner of your screen. Do not start a new topic.
  • The logs that you post should be pasted directly into the reply. Only attach them if requested or if they do not fit into the post.
  • Unfortunately, if I do not hear back from you within 5 days, I will be forced to close your topic. If you still need help after I have closed your topic, send me or a moderator a personal message with the address of the thread or feel free to create a new one.
In the meantime please, do NOT install any new programs or update anything unless told to do so while we are fixing your problem

If you still need help, please include the following in your next reply
  • A detailed description of your problems
  • A new DDS log (don't forget attach.txt)
  • GMER log


Please give me some time to review your logs and take the steps necessary with you to get your machine back in working order clean and free of malware.

Thanks and again sorry for the delay
.

regards, Elise


"Now faith is the substance of things hoped for, the evidence of things not seen."

 

Follow BleepingComputer on: Facebook | Twitter | Google+ | lockerdome

 

Malware analyst @ Emsisoft

 

animinionsmalltext.gif


#3 baylor

baylor
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:17 PM

Posted 15 December 2009 - 12:45 AM

What odd timing. My computer has had this virus for close to a month. i moved from the virus forum to this one (HJ) 2 weeks ago. And in all that time i've tried really hard to not let anything on my machine change, which is hard because this trojan keeps dialing out to various sites and trying to download things. Just today, the trojan finally managed to succeed, flooding my machine with a ton of junk, changing my background and erasing my MBAM.exe. So i was forced to erase files, change settings and install a new virus scanner. And an hour later, i get a response to this forum! If only my laptop could have held out another day

The good news is that i think the trojan is gone now. Since a LOT of the recent posts on this forum are about this Google hijack virus (and since i haven't found much information on it), i thought i'd tell you what i've learned about it

First, to remove the virus, i used combofix from Dec 13 2009. i ran combofix three weeks ago and it didn't detect anything, so whatever i had was added to its database recently. i should mention that another member here suggested the latest combofix to me via PM (he had the same behavior i was seeing)

That did NOT remove the trojan, but it detected it and removed a lot of the files i had (list below). When i rebooted, i noticed in Process Explorer that the file comcatq.exe was running under svchost. i manually killed this. i also found one file in system32 (i think it was called msilojzb.dll but i'm guessing the name is random; i found it by checking the timestamp) which originally i couldn't remove (it was locked by igfx, which i think is my Intel graphics driver) but eventually the file handle unlocked and i could erase it

After that, i re-installed Malware Bytes, scanned and found the following:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{1f422243-4a4b-4eb5-9c3f-2a1cf522fa45}\NameServer (Trojan.DNSChanger) -> Data: 193.104.110.38,4.2.2.1
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{d357aba3-7ec6-4401-b980-b8c44e552a03}\NameServer (Trojan.DNSChanger) -> Data: 193.104.110.38,4.2.2.1,192.168.1.1
C:\WINDOWS\system32\jikuvege.dll (Trojan.Vundo.H)
C:\WINDOWS\system32\puzisifi.dll (Trojan.Vundo.H)
C:\WINDOWS\system32\royakote.dll (Trojan.Vundo.H)
C:\WINDOWS\system32\zapebosi.dll (Trojan.Vundo.H)
C:\WINDOWS\system32\comcatq.exe (Trojan.HostsfileMod)
C:\WINDOWS\system32\config\SystemProfile\ntload.dll (Trojan.Agent)
C:\WINDOWS\system32\config\Systemprofile\Start Menu\Programs\Startup\scandisk.dll (Trojan.Agent)

Note that MBAM hadn't found any of these before, even with the latest database, but then a lot of them were probably installed today when the base trojan finally managed to download something

Prior to this, combofix removed the following files:
c:\documents and settings\baylor\Start Menu\Programs\Startup\scandisk.dll
c:\documents and settings\baylor\Start Menu\Programs\Startup\scandisk.lnk
c:\windows\system32\gulokivu.dll
c:\windows\system32\hedusovo.dll.tmp
c:\windows\system32\hiholozo.dll
c:\windows\system32\hoyagumu.dll
c:\windows\system32\notepad.dll
c:\windows\system32\pipitoba.dll.tmp
c:\windows\system32\vejonoto.dll.tmp
c:\windows\system32\winlogon86.exe
c:\windows\system32\wufirihi.dll
c:\windows\system32\zosomusa.exe
c:\windows\Tasks\gmmytnuk.job
Infected copy of c:\windows\system32\DRIVERS\atapi.sys was found and disinfected
Infected copy of c:\windows\system32\DRIVERS\iaStor.sys was found and disinfected

It did something called "ORPHANS REMOVED" but i'm not sure what that means:
BHO-{3138bb3c-3403-4eb7-827e-640827cc8500} - wufirihi.dll
BHO-{b88d6613-ed39-4b24-9d53-8feb8bb55d87} - hiholozo.dll
HKLM-Run-notepad - c:\windows\system32\notepad.dll
HKLM-Run-tutuvoveno - wufirihi.dll
HKLM-Run-nihazumin - c:\windows\system32\hoyagumu.dll
SharedTaskScheduler-{9f7c5957-3f9b-44a0-8e6c-db22ce371bf8} - c:\windows\system32\hoyagumu.dll
SSODL-molatezem-{9f7c5957-3f9b-44a0-8e6c-db22ce371bf8} - c:\windows\system32\hoyagumu.dll

It also noticed the files msilojzb.dll and comcatq.exe but did not remove them (MBAM removed those after the combofix run). Combofix also noticed some other files but i'm not sure if they're related or not


What was most interesting to me was the question, how on earth was it hijacking my Google search? i thought it was Firefox specific until i got the same behavior in Chrome and IE. i think i might finally know the answer, and it might have nothing to do with a virus, trojan or any other file on my system. The problem, i'm guesing, is that there was a system setting i didn't know about where you could redirect DNS queries (i don't know, maybe it would have shown up in network settings->TCP/IP->Properties->Advanced->DNS). So when you typed in "google", the system went to a hijacked DNS server which gave the address of that pirate server in China rather than the Google search results server. In the results below, 192.168.1.1 is my switch/firewall/DHCP server which is supposed to automatically assign me a DNS server name to use, but i'm guessing the key below overrides that to point to 193.104.110.38, which is a server in Prague, Czech Republic which i presume redirects things to the Chinese site i was seeing that autoforwards results to various spam and untrustworthy search engines

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{1f422243-4a4b-4eb5-9c3f-2a1cf522fa45}\NameServer (Trojan.DNSChanger) -> Data: 193.104.110.38,4.2.2.1
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{d357aba3-7ec6-4401-b980-b8c44e552a03}\NameServer (Trojan.DNSChanger) -> Data: 193.104.110.38,4.2.2.1,192.168.1.1


So that's the story. Before this, i could tell i had a trojan from the following:
1. Google searches were redirected
2. When i opened a new tab in Firefox, it sometimes opened a second tab to spam
3. In Process Explorer, i could see it try to open a hidden IE browser every 5 minutes
4. In TCPView i could see connections to server.lu and your-server.de opening
5. In TCPView i could see svchost (DcomLauncher) launch trying to invoke a server containing a dropper program

Over the last few hours, i haven't see any of the above behavior, so i think it's gone. Fingers crossed

Edited by elise025, 15 December 2009 - 02:41 AM.
Removed a line, as explained in post.


#4 Elise

Elise

    Bleepin' Blonde


  • Malware Study Hall Admin
  • 61,648 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Romania
  • Local time:02:17 AM

Posted 15 December 2009 - 03:13 AM

I editted a few lines out of your post, I understand you try to be helpful and that is appreciated, but the files you mention belong to at least 3 types of different infections and will not likely easy be found on someones computer.

i should mention that another member here suggested the latest combofix to me via PM (he had the same behavior i was seeing)

Do NEVER run Combofix or any other advanced tool on recommendation of another member (unless they belong to the HJT/moderating team), even more so if this is done by PM. Sending a PM with malware advice is not allowed by BC forum policy and following the advice can do serious harm to your computer.

Although intentions can be good, the rootkit you had can cause serious problems after combofix is run. If you had run into trouble, you would not have had any support to get your computer back up and running again.

I would appreciate it if you could send me a copy of that PM.

I recommend you to post the combofix log for my review. You can find it at c:\combofix.txt

Let me know if you want me to have a look at it or if you want to leave it as it is now. In that case I will close this topic.

regards, Elise


"Now faith is the substance of things hoped for, the evidence of things not seen."

 

Follow BleepingComputer on: Facebook | Twitter | Google+ | lockerdome

 

Malware analyst @ Emsisoft

 

animinionsmalltext.gif


#5 Elise

Elise

    Bleepin' Blonde


  • Malware Study Hall Admin
  • 61,648 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Romania
  • Local time:02:17 AM

Posted 17 December 2009 - 05:44 AM

Due to lack of feedback, this topic is now closed.

regards, Elise


"Now faith is the substance of things hoped for, the evidence of things not seen."

 

Follow BleepingComputer on: Facebook | Twitter | Google+ | lockerdome

 

Malware analyst @ Emsisoft

 

animinionsmalltext.gif





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users