Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Win7+ATI 4870= No aero?


  • Please log in to reply
6 replies to this topic

#1 Ellypho

Ellypho

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ottawa, ON
  • Local time:11:24 AM

Posted 24 November 2009 - 11:09 AM

Hi,

My system wont run aero unless i install the drivers however once i reboot aero doesn't work again and i hafto reinstall my drivers.
This system is CLEARLY able to run aero (Unless Fallout3 ultra high graphics is lighter then aero :huh:)

My new rig is running windows 7 ultimate with the following specs:
Phenom 2 black edition 940
EAH4870 Dark Knight 1GDDR5
Asus M4A78-Plus

Thanks guys.
Lyph
CompTIA A+ certified

BC AdBot (Login to Remove)

 


#2 figgis41

figgis41

  • Members
  • 801 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hull England
  • Local time:05:24 PM

Posted 24 November 2009 - 04:00 PM

hi,,, i had real big issues running on my ATI Mobility Radeon HD4570 graphics when updating my 2 laptops,,, they are the same and have switch-able gfx,,, goes from the 4570 to onboard ati 3200,,,, these would not work after the upgrade and i had to use the mobo on board gfx,,, i installed the latest ati catalyst control centre while the drivers for the ati graphics were uninstalled,,, rebooted, drivers loaded and i started the control centre dicked around with the settings and everything was fine,,,, both sets of drivers for the switch-able gfx worked fine,,,,
hope this info is some use to you :huh:
Figgis,,,, LUFC

#3 rover3500

rover3500

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:24 PM

Posted 25 November 2009 - 06:06 PM

Hi,

My system wont run aero unless i install the drivers however once i reboot aero doesn't work again and i hafto reinstall my drivers.
This system is CLEARLY able to run aero (Unless Fallout3 ultra high graphics is lighter then aero :huh:)

My new rig is running windows 7 ultimate with the following specs:
Phenom 2 black edition 940
EAH4870 Dark Knight 1GDDR5
Asus M4A78-Plus

Thanks guys.
Lyph


Have u tried completely uninstalling the drivers b4 u install again?Is what amd recommends.Latest drivers 9.11 now.try without catalyst centre if no success,do custom install.

#4 Ellypho

Ellypho
  • Topic Starter

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ottawa, ON
  • Local time:11:24 AM

Posted 26 November 2009 - 12:12 AM

Nope, still nothing...
rawr
CompTIA A+ certified

#5 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:11:24 AM

Posted 27 November 2009 - 10:05 AM

Have you tried the registry hack to forcibly enable Aero under Windows 7?

Important : Before proceeding make registry backup using System Restore. In case anything wrong happens, you can always recover from this backup.

1. Open Registry Editor. Navigate to the following key : HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM
2. Create three REG_DWORD (32-bit) values under this key with names Animations, Blur, UseMachineCheck. If these values are already present, set their values to 0.
3. Restart your computer.

More information :
http://www.trishtech.com/win7/force_enable...n_windows_7.php

#6 figgis41

figgis41

  • Members
  • 801 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hull England
  • Local time:05:24 PM

Posted 27 November 2009 - 02:37 PM

ok,,, i have been looking through this issue for days now and apparently drivers for a lot of radion mobility gfx cards are not yet available,,,, from ati or the makers of the pc or windows,,,,
i looked all this up because i only just noticed on the lappys i have they have switchable gfx,,,, it runs on the ati hd 3200 onboard gfx while on battery and then switches to the hd 4570 graphics card when on mains,,,, the drivers for the latter will not install,,,, the reason being there not compatable with windows 7,,,, waiting to hear from acer,,, will keep you posted
good luck.
Figgis,,,, LUFC

#7 Ellypho

Ellypho
  • Topic Starter

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ottawa, ON
  • Local time:11:24 AM

Posted 27 November 2009 - 02:49 PM

ok,,, i have been looking through this issue for days now and apparently drivers for a lot of radion mobility gfx cards are not yet available,,,, from ati or the makers of the pc or windows,,,,
i looked all this up because i only just noticed on the lappys i have they have switchable gfx,,,, it runs on the ati hd 3200 onboard gfx while on battery and then switches to the hd 4570 graphics card when on mains,,,, the drivers for the latter will not install,,,, the reason being there not compatable with windows 7,,,, waiting to hear from acer,,, will keep you posted
good luck.


Umm, i built my own system from parts. It isn't an OEM.
Oh and that hack was patched once they released windows 7. So no the hack does not work. I tried it...
CompTIA A+ certified




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users