Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Flash Drive only works in back USB ports.

  • Please log in to reply
2 replies to this topic

#1 Goomba


  • Members
  • 123 posts
  • Local time:04:36 AM

Posted 23 November 2009 - 01:53 PM

When I was showing my friend something on my flash drive the other day, it suddenly said the path didn't exist anymore.

I then got "One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it" every time I tried to plug it in again. It continued to do this on my computer and the computers at school. HOWEVER, it does work on the back USB ports on my computer and on the living room computer.

Any suggestions as to why this is happeneing?


BC AdBot (Login to Remove)


#2 garmanma


    Computer Masochist

  • Members
  • 27,809 posts
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:04:36 AM

Posted 23 November 2009 - 06:11 PM

Open your Device Manager and scroll down to the USB hub controllers.
Do any have a red X or yellow exclamation point?
Delete it and reboot the computer
Windows will re-detect them and they should work
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 Goomba

  • Topic Starter

  • Members
  • 123 posts
  • Local time:04:36 AM

Posted 24 November 2009 - 01:11 PM

No, I do not have any red X's or yellow !'s.

I tried formatting my flash drive, no help.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users