Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

boot.ini issue


  • Please log in to reply
13 replies to this topic

#1 patchfree

patchfree

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:09:32 AM

Posted 22 November 2009 - 06:54 PM

After changing my motherboard (as well as processor and ram) while keeping my system HDD, evently all goes right BUT now I have a multiboot choice: That is reflected in the boot.ini which is as following:

[Boot Loader]
Timeout=10
Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professionnel" /fastdetect /NoExecute=OptIn /usepmtimer
C:\$WIN_NT$.~BT\BOOTSECT.DAT="Installation de Microsoft Windows XP Professionnel"

That was enoying because I always have to choose "Microsoft Windows XP Professionnel" before the system loads (The alternative leads to nothing, that is to the necessity to reboot and so on) in place of an automatic loading.

What about this issue?

My idea would be to edit the boot.ini to something like that (a classic boot.ini file content):

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professionnel" /fastdetect

Is it correct?

Thanks for the help.

BC AdBot (Login to Remove)

 


#2 CoolCatBad

CoolCatBad

  • Members
  • 233 posts
  • OFFLINE
  •  
  • Local time:06:32 PM

Posted 22 November 2009 - 07:10 PM

Yes, that's right. Check it here http://support.microsoft.com/kb/289022

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,119 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:32 AM

Posted 22 November 2009 - 07:17 PM

Try the following, Removing the invalid entries from Boot.ini - http://windowsxp.mvps.org/bootopt.htm .

Louis

#4 patchfree

patchfree
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:09:32 AM

Posted 22 November 2009 - 07:33 PM

Thanks guys.

I have already performed the checking suggested by Louis: there are no invalid entries.

So I think it will probably correct to edit or replace boot.ini with a standard version. But I have a side question: where is PHYSICALLY located boot.ini? and what is the first file which is run when win xp starts?

Patch

#5 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:32 PM

Posted 22 November 2009 - 07:45 PM

The boot.ini file is in the root directory of your boot partition (usually the C: drive).
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#6 patchfree

patchfree
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:09:32 AM

Posted 22 November 2009 - 08:27 PM

The boot.ini file is in the root directory of your boot partition (usually the C: drive).


My boot partition is C: but boot.ini is not located there.

Patch

#7 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:32 PM

Posted 22 November 2009 - 08:49 PM

Make sure hidden and system files are viewable.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#8 patchfree

patchfree
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:09:32 AM

Posted 23 November 2009 - 04:38 PM

Dealing with my problem of boot.ini I realize that I have an issue with showing the hidden files in the "files explorer": Changing the option to show hidden files has no effect. So that why boot.ini is not at the root of C:. In fact it is at the root but, hidden, because if I try to rename another file in "boot.ini" the answer is "impossible to rename, another file has the same name". This was confirmed by using the winrar files explorer which can vizualize boot.ini in the root of C:

So my problem now is to understand why the windows files explorer has that issue. Probably a virus or some kind of malware. And how to fix.

Any idea to help me?

Thanks

Patch

Edited by patchfree, 23 November 2009 - 04:40 PM.


#9 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:32 PM

Posted 23 November 2009 - 05:02 PM

As well as checking "Show hidden files and folders" you must uncheck "Hide protected operating system files" in the folder options.

To edit the boot.ini file you can do this. Click Start, click Run, type sysdm.cpl, and then click OK. On the Advanced tab, click Settings under Startup and Recovery. Under System Startup, click Edit.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#10 patchfree

patchfree
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:09:32 AM

Posted 23 November 2009 - 06:13 PM

All pertinent checking and unchecking have been already performed!

The problem is at the level of the files explorer...

#11 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:32 PM

Posted 23 November 2009 - 06:24 PM

Try running a scan with Malwarebytes.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#12 patchfree

patchfree
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:09:32 AM

Posted 23 November 2009 - 07:21 PM

already performed

#13 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:32 PM

Posted 23 November 2009 - 07:23 PM

Try the fix at Kelly's Korner.

Enable/Disable Show Hidden Files/Folders - #155 on the left.

Right click on it and save the .vbs file to your desktop. Then, double click on the file icon (on your desktop) to merge it into your run the script. You may need to reboot your computer for the changes to take affect.

With any fix like this you should create a new restore point and backup the registry first. For backing up the registry I like to use ERUNT.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#14 mrob

mrob

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Location:Oceanside, CA
  • Local time:11:32 PM

Posted 23 November 2009 - 08:29 PM

Thanks guys.

I have already performed the checking suggested by Louis: there are no invalid entries.

So I think it will probably correct to edit or replace boot.ini with a standard version. But I have a side question: where is PHYSICALLY located boot.ini? and what is the first file which is run when win xp starts?

Patch


Go to START, RUN, type sysdm.cpl. Click ADVANCED, STARTUP AND RECOVERY, SETTINGS, Under SYSTEM STARTUP, click EDIT.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users