Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

XP suffered a stroke I think


  • Please log in to reply
4 replies to this topic

#1 Morphyloon

Morphyloon

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:52 PM

Posted 21 November 2009 - 05:46 PM

Back on monday (11/15) something went very wrong with XP. I've tested the hardware, from the subsystems, hd, to memory, all checked out ok. The issue is most apps and services are hanging when started or soon after. I cannot figure out why and the oldest Restore Point is 11/15-- which when tried, is reported to be invalid and no changes to XP are going to be made.

I thought I might have a corrupt prefetch? Removed virtual memory and re-enabled it, no change.

Is the hd's MFT corrupt? CHKDSK says no but it did find a spot of free space that was marked as used; corrected.

McAffe was causing an odd error, mcagnt.exe was not registered with DCOM within a 2 minute time limit, and this was posted every 2 minutes in the Event Logs. So I uninstalled McAffe and got Avast AV suite. Problem solved.

Only the Dell support suite is giving errors all the time when I reboot now, although some other apps might such as em_exec (Logitech mouse driver) or LightscribeControlPanel might if they hang too. Not sure how or if I should remove the Dell support suite (warranty expired half a year ago). Small apps like Opera and Windows' Event Log Viewer usually run on the first try. Larger apps such as WoW.exe (World Of Warcraft) never run, hanging 2-3 seconds after starting. RootRepeal crashes halfway through it's scan at random locations.

If I don't get "so-and-so refuses to close, close now?" and the timer, when rebooting, I get a cryptic error:
"The instruction at "0x000000000" referenced memory at "0x00000000". The memory could not be "read". Click OK to terminate program."
(Replace addresses with numbers, such as 0x670a128f for LightscribeControlPanel at location 0x000013fd28)

The only thing I have not tried is the system file repair thing. Lacking an install CD (Thank you Dell for not giving me a XP install CD) I don't see how I can.

BC AdBot (Login to Remove)

 


#2 Orange Blossom

Orange Blossom

    OBleepin Investigator


  • Moderator
  • 36,946 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Bloomington, IN
  • Local time:01:52 PM

Posted 24 November 2009 - 04:38 PM

Topic reopened and HiJack This topic deleted.

I am moving this topic to the Am I Infected forum which is more appropriate for this topic.

Orange Blossom :thumbsup:
Help us help you. If HelpBot replies, you MUST follow step 1 in its reply so we know you need help.

Orange Blossom

An ounce of prevention is worth a pound of cure

SpywareBlaster, WinPatrol Plus, ESET Smart Security, Malwarebytes' Anti-Malware, NoScript Firefox ext., Norton noscript

#3 Morphyloon

Morphyloon
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:52 PM

Posted 25 November 2009 - 09:50 AM

Since the problem seems too vague to warrant assistance at the moment I thought I'd add some new observations.

While using the broken XP desktop, I've noticed that my main browser Opera (1 in 5 starts will hang) works as does Firefox (half the time) so HTTP services are there. Outlook Express hasn't hung yet so STMP services are also working. However, telnet does not. I tried pinging (worked) but using telnet to a few MUCK sites would not work, the socket just sitting there until telnet times out. This may go a ways in explaining why SimplyMU, a glorified telnet app will hang upon starting, as does World Of Warcraft also hanging 2 seconds after being started.

I'm also watching DSAgnt.exe crashing right now. It dies in a few ways in the week-and-a-half i've suffered this broken XP system. It may give the usual "Program can't end. End now?" dialog when shutting down. Assuming it lived that long. Otherwise it will pop up a dialog about how the C++ Runtime Library had to terminate it in an unusual way, please contact the vendor. The other error type is just DSAgnt.exe self-terminating and an OK button. This seems to be DSAgnt.exe's favorite entry (listed +several times over the past week) in my Event Log:

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 11/25/2009
Time: 1:27:53 AM
User: N/A
Computer: TRAVELLER
Description:
Faulting application dsagnt.exe, version 3.0.0.197, faulting module trgregh.dll, version 2.0.0.35, fault address 0x00017647.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 64 73 61 ure dsa
0018: 67 6e 74 2e 65 78 65 20 gnt.exe
0020: 33 2e 30 2e 30 2e 31 39 3.0.0.19
0028: 37 20 69 6e 20 74 72 67 7 in trg
0030: 72 65 67 68 2e 64 6c 6c regh.dll
0038: 20 32 2e 30 2e 30 2e 33 2.0.0.3
0040: 35 20 61 74 20 6f 66 66 5 at off
0048: 73 65 74 20 30 30 30 31 set 0001
0050: 37 36 34 37 0d 0a 7647..

I've not seen a rather disturbing error that popped up in the early days, but then I've uninstalled most of the apps that caused them. One example was:

"LightscribeControlPanel.exe" "The instruction at "0x670a128f" referenced memory at "0x0013fd28". The memory could not be "read". Click OK to terminate program."

#4 Morphyloon

Morphyloon
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:52 PM

Posted 25 November 2009 - 02:17 PM

Managed to generate seperate RootRepeal logs although it still chokes if I try the File scan (crashes or hangs at 100% CPU during the File scan). Hosted offsite because I can't tell it to just report only the dangerous information found.

RootRepeal
http://www.morphy.furtopia.org/hijackthis/091125/drivers.txt
http://www.morphy.furtopia.org/hijackthis/...5/processes.txt
http://www.morphy.furtopia.org/hijackthis/...shadow_ssdt.txt
http://www.morphy.furtopia.org/hijackthis/091125/ssdt.txt
http://www.morphy.furtopia.org/hijackthis/...lth_objects.txt

SysProt
http://www.morphy.furtopia.org/hijackthis/.../SysProtLog.txt

Hijackthis
http://www.morphy.furtopia.org/hijackthis/.../hijackthis.log

Edited by Morphyloon, 25 November 2009 - 02:23 PM.


#5 Morphyloon

Morphyloon
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:52 PM

Posted 27 November 2009 - 02:17 PM

This topic can be closed I think, I've solved the issue of WoW.exe and telnet apps hanging.

Turns out after I completely uninstalled Adobe/Macromedia software (flash, shockwave, PDF reader), all the broken functionality problems went away... amazing. I'm not sure if I should put the stuff back in unless I really need it. I have no idea what what causing the issue in XP but taking all that out fixed it. I guess it can be written off as a corrupt driver issue.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users