Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need help port forwarding - FAST


  • Please log in to reply
14 replies to this topic

#1 Richiiee

Richiiee

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 21 November 2009 - 09:46 AM

I've been trying to port forward my router to allow BitTorrent to seed but it just won't work. I've opened up numerous ports, tested them all and PortForwardChecker says they're open. I tried some online test that someone else posted on another forum and it said my ISP is NOT blocking seeding on my network. I can download things just fine, but I can never seed whether it's during or after the download completes. Went through the steps on portforward.com for my specific router and it still won't work. Restarted BitTorrent, still didn't work. Restarted my whole computer, still didn't work. It's annoying me pretty badly because I'm about to get banned from my private torrent website if I don't seed a whole bunch of data in under 48 hours so I need help pretty quickly. Anybody know what's going on?

BC AdBot (Login to Remove)

 


#2 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 AM

Posted 21 November 2009 - 12:46 PM

Port forwarding is fairly straight forward, pardon the pun. You need the port number(s), the protocol(s) and the IP address of the PC. But any one of those 3 can be easily messed up. I'd check the IP address first, its the easiest of the 3 to get wrong. Type ipconfig at a command prompt, hit Enter and the IP address it shows is the one you need. The second thing to make sure is the protocol(s), make sure if you need both TCP and UDP forwarded they are. If your router doesn't have a "both" option you'll need to make 2 entries in the port forwarding table.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#3 Richiiee

Richiiee
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 21 November 2009 - 01:02 PM

Thanks for the reply.

I've forwarded the ports for both TCP and UDP. I have the port set as 6882 in BitTorrent and forwarded the ports from ranges 6881 to 6999 in both TCP and UDP. And when I run ipconfig, it closes in less than a second before I can ever see my IP address. It just starts then stops before I can see anything.

Edit: I ran cmd and then typed in ipconfig instead and it worked, I have all my IP information. Now what do I do with it? :thumbsup:

Edited by Richiiee, 21 November 2009 - 01:03 PM.


#4 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 AM

Posted 21 November 2009 - 01:32 PM

You want to make sure that is the IP address you are forwarding those ports to.

If you have the correct ports and IP address and it still isn't working, then its either the client or your ISP. I know you said you checked the ISP but if you are 100% positive you have the correct ports forwarded to the correct IP address with the correct protocols then that just leaves ISP or client.

EDIT: I just remembered firewalls. Are you running one? If its not the one that comes with the OS, clean out all the exceptions and redo them. Its easy to block something that is needed to do some thing else.

Edited by CaveDweller2, 21 November 2009 - 01:34 PM.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#5 Richiiee

Richiiee
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 21 November 2009 - 03:37 PM

It seems like the IP address is forwarded. I'm not sure it's the client because it doesn't work with BitTorrent OR uTorrent. I use Sygate Firewall but I set it to allow connections from ports 6881 to 6999 in both TCP and UDP. Even when I disable Sygate and Avira AntiVir, it still doesn't seed.

#6 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 AM

Posted 21 November 2009 - 06:19 PM

Have you made any changes to the clients? If you have perhaps take them back to default.

Sygate - look under Tools -> Applications and make sure the clients you use are listed, Allowed and have a check by them. Here is a users guide. Chapter 6 looks like what you want to have a look at.

If its not a client thing or a firewall thing and you are sure its not an ISP thing, which btw you could call and ask if they block those ports just to make 100% sure, then I am at a loss as to what it could be.

I assume you can surf sites NP so there is no issues with your connection.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#7 Richiiee

Richiiee
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 21 November 2009 - 06:57 PM

I went to that setting in Sygate and it's indeed allowed to access the network. And no I haven't changed any settings, I haven't been able to seed since I got this laptop a couple of months ago. Reinstalled BitTorrent and uTorrent just in case to reset the settings but no luck. I'm completely stumped...

#8 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 AM

Posted 21 November 2009 - 08:53 PM

uTorrent - under Options -> Preferences -> Connection. Upper right is the port you need to forward. Right below it, is "Randomize...etc" checked? If yes uncheck it. Forward that port, TCP and UDP see if it starts seeding.

Is UPnP enabled on your router? You might want to mess with those settings IF the above doesn't work. I'd uncheck it in the client and see if it works. Disable it in the router if its enabled. Each time see if it starts seeding. But do one at a time. But try the above first before you mess with the UPnP settings

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#9 Richiiee

Richiiee
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 22 November 2009 - 02:27 PM

Randomize isn't checked, no. How do I know if UPnP is enabled on my router? Unchecked it in uTorrent and it didn't work.

#10 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 AM

Posted 22 November 2009 - 03:03 PM

Ok then the number in the box is port number you need to forward.

You'll have to look around the settings in the router. In my Belkin that setting is on the System Settings page. Not sure where it will be on your router. But just remember until you click Apply on the page no settings take affect, so you can look around all you want.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#11 Richiiee

Richiiee
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 22 November 2009 - 03:31 PM

There is an option for Strict UDP Session Control but all that would do is the opposite of what I'm trying to do. I removed the port forward settings and put them back on and still no luck. This is just getting more and more annoying because I'm going to get banned from my private torrent website if I don't seed a certain amount of data in a certain time limit, and I've done everything possible and it just won't work. :thumbsup:

Edited by Richiiee, 22 November 2009 - 03:32 PM.


#12 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 AM

Posted 22 November 2009 - 04:41 PM

Did you add the port in that was in the box beside Random port to the ports to forward?

What is the make and model of your router? Did you find the UPnP in the router?

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#13 Richiiee

Richiiee
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 22 November 2009 - 05:11 PM

Yeah the port that was in the box was the one I was trying to forward this whole time. Tried random different ports too.

My router is a 2-Wire 2701HG-G. I couldn't find anything about UPnP in my router's control panel settings. It can't be a problem with the router itself because we just got it installed by a technician from my ISP like 2 or 3 months ago.

Edited by Richiiee, 22 November 2009 - 05:12 PM.


#14 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 AM

Posted 22 November 2009 - 07:12 PM

There is no UPnP in your router/modem.

Ok so to do port forwarding on that router/modem you have to make custom application entries into the firewall, then click by "Allow individual application(s)", then add each one from the box on the left to the box on the right and then click the Done button. And that is what you have done after creating each new entry?

If you've done that and you are sure its all correct, the last thing I would suggest just as a test would be on that same page make sure you picked your PC's IP address and click beside "DMZ-plus mode" and click Done. This will bypass all firewall or limiting settings from the modem/router to you PC. This is not something you want to leave as a setting. But if you do that and you can't seed, its something on your PC. If you do that and you can seed then somewhere you didn't set something correct in the port forwarding.

Here is the user guide for that modem/router. You want the "Hosting an application" section.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#15 Richiiee

Richiiee
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 23 November 2009 - 03:16 PM

I enabled DMZ plus mode and it still wouldn't seed. I'm guessing it's a problem with my computer then. I've already been banned from my torrent website so it's too late to even bother fixing this problem, but if you ever have anymore ideas as to what the problem could be I'd love to hear them. Otherwise thanks for your help!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users