Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Search Engine Redirect Virus/ Can't Install AntiVirus


  • Please log in to reply
3 replies to this topic

#1 MiraMorningstar

MiraMorningstar

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 19 November 2009 - 10:25 PM

Hi, please help me! I have two major problems: One is that the Search Engine results keep getting redirected to other sites, and this also happens even when I type the URL directly into the address bar sometimes. Problem two is that firefox keeps crashing like crazy! And actually, there is a 3rd problem which is the worst problem of all. This is the fact that Spybot, Malware Bytes and AVG ALL stopped working and even when I uninstalled and reinstalled them over and over again, they still did not work! Please Help, thanks a bunch. :[

BC AdBot (Login to Remove)

 


#2 MiraMorningstar

MiraMorningstar
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 20 November 2009 - 11:52 AM

Can anyone please help me at all?

#3 MrBruce1959

MrBruce1959

    My cat Oreo


  • BC Advisor
  • 6,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:11:57 AM

Posted 20 November 2009 - 03:46 PM

we need more info about your problem to help you out.
Can you tell us what you did before the infection and what processes are running.
Try Hijackthis and use the hijackthis forum to post the text results.
Then we can help you out more effectively.
:thumbsup:
Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
 
My Career Involves 37 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:

#4 MiraMorningstar

MiraMorningstar
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:57 AM

Posted 22 November 2009 - 08:19 PM

I had AntiVirus System Pro, b.exe, and msa.exe infecting my system. I removed them all by deleting the registry keys and program files. After they were deleted, I was still getting my search engine results redirected to other sites and firefox started crashing regularly. Also, as mentioned, Malware Bytes and Spybot randomly stopped working.

The message I get is "Windows can not access the specific device, path, or file. You may not have the appropriate permissions to access the item."

Here are the processes running:

firefox.exe
flash.exe
driverrobot.exe
wuauclt.exe
aolsoftware.exe
wincinemamgr.exe
acrotray.exe
aim6.exe
ctfmon.exe
msmsgs.exe
jusched.exe
DrgtoDsc.exe
alg.exe
ViewpointService.exe
wdfmgr.exe
pen_tablet.exe
svchost.exe
nvsvc32.exe
MDM.exe
jqs.exe
avgwdsvc.exe
AdskScSrv.exe
svchost.exe
avgemc.exe
taskmgr.exe
spoolsv.exe
raysat_3dsmax9_32server.exe
svchost.exe
svchost.exe
svchost.exe
svchost.exe
avgrsx.exe
lsass.exe
services.exe
winlogon.exe
csrss.exe
smss.exe
Pen_Tablet.exe
Pen_TabletUser.exe
WISPTIS.exe
System
System Idle Process




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users