Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't Run Safe Mode... computer just keeps booting over and over


  • Please log in to reply
3 replies to this topic

#1 Brandon67

Brandon67

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:53 PM

Posted 19 November 2009 - 09:16 PM

Hello there,

I have recently run into some issues on my machine that runs Windows 7. I can't run Windows Media Player; it just says the file name and then "Server Execution Failed". I was advised to go into safe mode and type a command into administrator cmd. However, safe mode would not work. At first I thought it was an F8 problem, so I was advised to go into msconfig > boot and change the system to boot into safe mode. I did that to find that safe mode gets into the driver loading screen and stops at windows\system32\drivers\ClassPnP.sys and seems to load. It shows the cursor, but then disappears and my computer reboots. However, since my computer is set to load into safe mode, it constantly tries to log into safe mode, which doesn't seem to work, so it just restarts, tries to go into safe mode, but can't, so it restarts again, going through the process again and again.

I have tried pressing "Delete" key at the beginning of boot up, but it does not show any thing else I can boot from. When I do get the F8 thing working, I select "Boot Windows Normally" but it just goes straight to the bootup of safemode.

I have an Acer Aspire M3800 that only has the factory restore discs that Acer eRecovery Management has asked me to make when I first bought my computer. I obtained Windows 7 through the "free upgrade" program Acer is running.

Please help... thank you.

BC AdBot (Login to Remove)

 


#2 meandmypc

meandmypc

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:06:53 PM

Posted 21 November 2009 - 04:27 AM

You may be able to cure this Continual Rebooting issue by trying this method contained in this
Bleeping Comp. Vista,Tutorial = http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Under; Problems that can occur by forcing Safe Mode using the System Configuration Utility
Although the problem may or may not relate to a Spyware attack, the Fix may produce the the same resolution.
If all else has failed it may be worth the attempt, Good Luck.

#3 meandmypc

meandmypc

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:06:53 PM

Posted 21 November 2009 - 04:38 AM

You may be able to cure this Continual Rebooting issue by trying this method contained in this
Bleeping Comp. Vista,Tutorial = http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Under; Problems that can occur by forcing Safe Mode using the System Configuration Utility
Although the problem may or may not relate to a Spyware attack, the Fix may produce the the same resolution.
If all else has failed it may be worth the attempt, I have copied the relevant Instructions below. Good Luck.


"Problems that can occur by forcing Safe Mode using the System Configuration Utility"

It is possible to make your computer continuously boot up into safe mode using the System Configuration utility as described above. The program does this by changing your boot.ini file, the settings file that configures your computer's boot sequence, and adding the /safeboot argument to your operating systems startup line. An example of this can be seen below.

Original [operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /FASTDETECT /NOEXECUTE=OPTIN
After using MsConfig.exe [operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /FASTDETECT /NOEXECUTE=OPTIN /safeboot:minimal

When you are done using safe mode, you would then run the System Configuration utility again and uncheck the /Safeboot option, thus removing the /safeboot argument from the boot.ini file, and allowing your computer to boot up normally.

On a computer that is operating properly this is normally not a problem. Unfortunately, though, a new trick that some of the more recent malware are using is to delete certain Windows Registry keys so that your computer can not properly boot into safe mode. It is in these situations that using the System Configuration utility to boot into safe mode can cause the computer to become inoperable for many users.

This is because once you set the computer to boot into Safe Mode using /Safeboot, it will continuously attempt to start Safe Mode until the /safeboot argument is removed from the boot.ini. Since the malware is not allowing us to actually boot into safe mode, you have no way of getting to a point where you can run the System Configuration utility again to uncheck the /Safeboot option. Thus, you are stuck with a computer constantly attempting to get into safe mode and not being able to do so.

If a situation like this has happened to you it is possible to fix this problem by renaming your boot.ini file. The first step would be to use a boot disk to start your computer. If your computer does not have a floppy disk, then you can typically boot off the Windows CD that came with your computer in order to access the Windows Recovery Console. More information about the Windows Recovery Console can be found here. Once booted to a command prompt, you would simply rename your C:\Boot.ini file to another name like C:\Boot.ini.bak. The command to rename the file at the command prompt is:

ren C:\Boot.ini Boot.ini.bak

Once the file is renamed, you can then remove the boot disk and reboot your computer to get back to normal mode. When booting up after the rename, do not be surprised if you see an error stating that you do not have a valid Boot.ini file. When you get back to normal Windows mode, you can then rename C:\Boot.ini.bak to C:\Boot.ini and run Msconfig again to remove the /safeboot flag.

#4 Brandon67

Brandon67
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:53 PM

Posted 21 November 2009 - 05:14 PM

Thanks meandmypc, your suggestion has worked.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users