Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trouble with an IDE HDD


  • Please log in to reply
1 reply to this topic

#1 jgiorand

jgiorand

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:34 AM

Posted 16 November 2009 - 12:24 PM

Hello all,

The other day, I purchased a copy of Windows 7 Home Premium (before which I had XP Professional). As I was eager to upgrade, I backed up all my important files to a spare IDE harddrive. This harddrive is mounted in a swappable bay. It is an old IDE Western Digital Caviar drive, and the file system is almost certainly FAT32 (I don't believe I ever reformatted to NTFS).

Anyway, after backing up all my files, I double checked them to make sure I could access them. Everything checked out. After that, I installed Windows 7. Once installed, I tried to access the harddrive. The BIOS recognizes the IDE drive as the primary master IDE drive (with a DVDwriter as primary slave and 2 SATA drives in SATA1&2). Windows wants to "initialize" the disk before it can be given a designation and accessed. Afterward, I swapped out that IDE drive with my second IDE drive, which windows recognized and accessed immediately (so I know its not a problem with the removable hdd bay). So now I come to my two questions...

1) I hear from some people that "initializing" the disk will not affect the data on the disk, while others say its worse than formatting the disk! Which is it?

2) Has anyone had this problem before? Does anyone know what to do? I tried running a data recovery program that I've used in the past, but it doesn't seem to want to access the disk, even though it recognizes it.


Any help would be greatly appreciated. Oh, one more thing: Just for good measure, I wiped out my main hdd and reinstalled Windows XP, after which the computer still did not recognize the drive.

I just don't get it...the bios recognizes the drive, and WinXP recognized and accessed it before I installed Windows 7. I have a LARGE collection of audiobooks on this harddrive, and I would greatly like to be able to salvage the data.


Thank you in advance for any help,

Joe

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,295 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:34 AM

Posted 16 November 2009 - 01:42 PM

<>

More details would possibly be enlightening. What recovery software...and what error message did it submit/provoke?

Some data recovery programs are set for NTFS file systems (like the one I use), while others may be geared only to FAT file systems.

<>

Initializing a disk is the first step to formatting it, although initializing is not necessarily a formal step for every hard drive. Formatting is a necessary step for any hard drive to be viewed in Windows as "ready for use". For all intents and purposes, initializing and formatting are considered the same operation by me.

Google has more on hard drive initialization.

Sooo...if you elect to initialize that drive, Windows will understand that as a command to format.

My suggestion would be to convert the FAT file format to NTFS, at some point.

And...run the appropriate hard drive manufacturer's diagnostic on that drive (long test).

Hard Drive Installation and Diagnostic Tools - http://www.bleepingcomputer.com/forums/t/28744/hard-drive-installation-and-diagnostic-tools/

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users