Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Malwarebytes deleted a critical component...now having trouble getting XP to boot


  • Please log in to reply
3 replies to this topic

#1 galmc

galmc

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:51 AM

Posted 14 November 2009 - 12:15 PM

Malwarebytes deleted a critical component....
A little over a week ago, I was trying to rid my desktop of Personal Guard 2009. The guys over on the Malware forum at techguys.org were helping me there. The last 2 scans that I needed to do to ensure I was clean was to do a Malwarebyte scan and an OTS scan. Malwarebytes went through its scan, came up with 3 files that it wanted to delete and then reboot. So it did...everything but reboot. On reboot the computer went to the Dell screen then a blue screen which read something like, "A problem has been detected and windows has been shut down to prevent damage to your computer. .......Technical information: ***Stop: 0x0000007B (0xF9679528,0xC0000034,0x00000000, 0x00000000)"

The next day, we found out that Malwarebytes was giving a false positive and deleting atapi.sys from my system. I contacted the tech guy there at Malwarebytes and his fix was to use my OME reinstallation cd to do a repair install on Windows XP. So, I inserted the cd and followed directions. 30 hours later, the screen still showed 32 minutes left to complete setup. I turned the computer off and tried again. This time it went fine but I got a lot of copy errors that I had to cancel (Setup cannot copy the file migregdb.ex_. etc.) In the end, windows booted, all of my settings looked to be intact. I shut it down with the intentions of coming back this morning and connecting the desktop to the internet so I could download the service packs. However, this morning the computer was in a loop, Dell screen to Windows screen and back to Dell. I tried to boot to Last Know Config. but it just went back to the loop. Same with Safe mode.

Right now I am attempting to repair install again. Does anyone have any other suggestions??

Btw, it is a Dell Dimension that use to run Windows xp home edition. The reinstall was for service pack 1a.

Thanks!

BC AdBot (Login to Remove)

 


#2 powerjuce

powerjuce

  • Members
  • 321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:51 AM

Posted 14 November 2009 - 09:41 PM

Hey galmc

This is a frustrating problem. Before we try and fix anything however I suggest we back up all your data first. This is a good tutorial to use. However as Ubuntu has recently updated, this is the version of ubuntu they want you to use. The version they link is the latest version.

Direct Download for Ubuntu 9.04

Once your files are backed up, we can work on getting your computer up and running.

Post with any question
~powerjuce

#3 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:04:51 PM

Posted 14 November 2009 - 11:04 PM

Importing the registry keys again may be the solution you are looking for:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\atapi
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\atapi
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi


Malwarebytes Atapi.sys and Registry False Positives
http://www.iishacks.com/index.php/2009/11/...alse-positives/

To quote from the responses section under the article itself ....
Once the computer has started up and you are in Windows, re-import the keys ......... The reason this needs to be done is that when you start the system and the registry is loaded into the CurrentControlSet, it may not save it when you shutdown after the first time, then your loops will start happening again.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#4 galmc

galmc
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:51 AM

Posted 15 November 2009 - 12:40 AM

Thank you both for your replies. I really appreciate them.

Powerjuice, thanks for the suggestion of backup. I went ahead and bought an external harddrive and backed up all of my files before I started trying any of these scans. I am so thankful that I went ahead and did that!! I don't think that I lost any files in the repair but I would have been a basket case if I had not known that all of my pictures were safely tucked away.

I've also seen several references to Ubuntu while working on getting this computer going. I'm going to have to research that more.

AustrAlien, thank you for your link! Very straightforward so that even I could understand. Fortunately, the second repair install worked great and I was able to download SP3 to windows. Everything seems pretty stable now and I have rebooted the computer about 4 times now with out a hint of a problem. (Although, I was holding my breath the entire time. ) If the repair install had not worked, I would have used that website. I think that I could have followed it quite easily.

Thank you again for your time and your suggestions. :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users