Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Disabled hidden property checkbox


  • Please log in to reply
5 replies to this topic

#1 Joshua Russo

Joshua Russo

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 10 November 2009 - 10:18 AM

I just recently removed a virus and afterward noticed that all of the Word docs on a pen drive that was involved in the infection where set as hidden. When I went to un-hide them the check box was disabled. At first I thought it was a registry setting that was changed, but the computer that I was viewing this on was not part of the infection and the files on that computer are fine. It's only this way for the Word docs on the pen drive. Any ideas?

I'm running Windows XP Pro, what if any other system info would be helpful?

Thanks
Josh

Edited by Joshua Russo, 10 November 2009 - 10:21 AM.


BC AdBot (Login to Remove)

 


#2 Animal

Animal

    Bleepin' Animinion


  • Site Admin
  • 35,302 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where You Least Expect Me To Be
  • Local time:03:05 AM

Posted 10 November 2009 - 11:57 AM

Take a look at the tool mentioned here: http://www.bleepingcomputer.com/forums/ind...t&p=1483381

The Internet is so big, so powerful and pointless that for some people it is a complete substitute for life.
Andrew Brown (1938-1994)


A learning experience is one of those things that say, "You know that thing you just did? Don't do that." Douglas Adams (1952-2001)


"Imagination is more important than knowledge. Knowledge is limited. Imagination circles the world." Albert Einstein (1879-1955)


Follow BleepingComputer on: Facebook | Twitter | Google+

#3 Joshua Russo

Joshua Russo
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 10 November 2009 - 06:58 PM

Nope, the hidden check box is still disabled. Thanks for the util tho, it will come in handy I'm sure.

I'm pretty astute when it comes to the auto-run dialog box and usually cancel right out of it.

These files seem to be modified in some way I don't understand. I don't think they are actually "infected" just modified by a previous infection. I tried an experiment and uploaded one of the files into an email on my Gmail account and then downloaded it again and that fixed the problem, but I have many Word docs on the pen drive. It would be a real pain if I had to upload and download each one of them to "fix" them.

#4 Lanscader

Lanscader

  • Members
  • 466 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Colorado, USA
  • Local time:04:05 AM

Posted 10 November 2009 - 08:25 PM

I'm having exactly the same problem with my "hidden" checkbox, but it affects the folders on my flash drive. I've searched around (both on BC and Google), and most times when this issue pops up, the poster is directed to something involving the removal of the malware that caused the problem. That is not my issue (and from what I can tell, nor is it Joshua's).

I know that my flash drive was infected with the W32.sillyFDC worm. After anti-virus caught it, I noticed that all the folders in the root of the drive appeared missing, so I viewed hidden files, and there they were. Instead of taking the usual measures of letting my anti-virus take care of it, I pulled the drive out and put it in my linux box, where I discovered that the worm hid all my folders, and created identically named .exe files. I removed all these in linux, returned the drive to my Windows machine, and the drive passed virus and spyware scans.

However, all my folders are still hidden, and like Joshua, I can't uncheck the "hidden" box. I'm running Windows 7 Ultimate.

"Sir Lord Baron von Vader-han?" ~ Eddie Izzard

 


#5 Joshua Russo

Joshua Russo
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 17 November 2009 - 06:21 PM

I found my problem. It's been a while since my DOS days and I had forgotten about the System attribute. Seeing as I have hundreds of document spread across dozens of directories the attrib command didn't quite fit the bill. So I found a free utility that adds itself to the right-click menu with the creative name of Attribute Changer (http://www.petges.lu/download/download.html)

All you have to do is use Windows Search and enable 'Search hidden files and folders' under the advanced options. This will show you all of your files that are hidden (with or without the system attribute set). You can then select and change all of the file attributes right there.

I hope this helps others.

Josh

Edited by Joshua Russo, 17 November 2009 - 06:24 PM.


#6 Animal

Animal

    Bleepin' Animinion


  • Site Admin
  • 35,302 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where You Least Expect Me To Be
  • Local time:03:05 AM

Posted 17 November 2009 - 07:12 PM

Thank you for sharing your solution, with us. And congrats on resolving your issue.

The Internet is so big, so powerful and pointless that for some people it is a complete substitute for life.
Andrew Brown (1938-1994)


A learning experience is one of those things that say, "You know that thing you just did? Don't do that." Douglas Adams (1952-2001)


"Imagination is more important than knowledge. Knowledge is limited. Imagination circles the world." Albert Einstein (1879-1955)


Follow BleepingComputer on: Facebook | Twitter | Google+




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users