Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BSOD:Page fault in nonpaged area


  • Please log in to reply
4 replies to this topic

#1 naija

naija

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:14 AM

Posted 09 November 2009 - 04:25 PM

2 of the desktops in my household have suddenly started to continually reboot without fully loading. They are both WinXP machines and have AVG loaded as their antivirus software. After prompting me to log in as a user (and before I can even do this) they both display a blue screen with the following message.

PAGE_FAULT_IN_NONPAGED_AREA

If this is the first time you have seen this stop error screen, restart your computer. If this screen appears again, follow these steps.Check to make sure any new hardware or software is properly installed. If this is a new installation, ask your hardware or software manufacturer for any windows updates you might need.
If problems continue, disable or remove any newly installed hardware or software. Disable BIOS memory options such as caching or shadowing. If you need to use safe mode to remove or disable components, restart your computer, press F8 to select Advanced Startup Options, and then select safe mode.

Technical information STOP:0x00000050 (0x89c58376,0x00000000,0x8053CE32,0x00000000)

I am able to fully load the machines in Safe mode (though I can't do much in this mode) I haven't installed any new hardware, can't swear that someone hasn't tried to install neww software but think its VERY unlikely. I've tried restarting them in selective startup with all startup programs disabled, still get the BSOD. Can anyone help me please?

p.s. I am at best a dabbler in IT so I'll probably require a fair bit of guidance

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,565 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:14 PM

Posted 09 November 2009 - 04:54 PM

Hi :thumbsup:.

Official line on error...see 50, left column at http://www.aumha.org/a/stop.htm.

Have you/can you try XP's System Restore function?

Take msconfig out of selective startup.

Boot into safe mode...search Windows partition for any .dmp files that may exist. Ensure that all file extensions and system/hidden files are viewable before doing search.

If any are found, try to follow the procedures at Help Diagnosing BSODs And Crashes (BC) - http://www.bleepingcomputer.com/forums/t/176011/how-to-receive-help-diagnosing-blue-screens-and-windows-crashes/ .

Louis

#3 naija

naija
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:14 AM

Posted 10 November 2009 - 07:20 AM

Thanks for the reply, I have tried System restore without success. Below is the information acquired after using the Windows debugger and procedures as shown at Help Diagnosing BSODs And Crashes (BC).

Microsoft ® Windows Debugger Version 6.11.0001.404 X86
Copyright © Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Documents and Settings\User\Desktop\Minidump\Mini110909-99.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows XP Kernel Version 2600 (Service Pack 3) MP (2 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 2600.xpsp_sp3_gdr.080814-1236
Machine Name:
Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055d720
Debug session time: Mon Nov 9 14:28:53.578 2009 (GMT+0)
System Uptime: 0 days 0:00:29.265
Loading Kernel Symbols
...............................................................
............................................
Loading User Symbols
Loading unloaded module list
....
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 10000050, {89c58376, 0, 8053ce32, 0}

Unable to load image eLock2FSCTLDriver.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for eLock2FSCTLDriver.sys
*** ERROR: Module load completed but symbols could not be loaded for eLock2FSCTLDriver.sys

Could not read faulting driver name
Probably caused by : eLock2FSCTLDriver.sys ( eLock2FSCTLDriver+11332 )

Followup: MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced. This cannot be protected by try-except,
it must be protected by a Probe. Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: 89c58376, memory referenced.
Arg2: 00000000, value 0 = read operation, 1 = write operation.
Arg3: 8053ce32, If non-zero, the instruction address which referenced the bad memory
address.
Arg4: 00000000, (reserved)

Debugging Details:
------------------


Could not read faulting driver name

READ_ADDRESS: 89c58376

FAULTING_IP:
nt!_output+909
8053ce32 668b03 mov ax,word ptr [ebx]

MM_INTERNAL_CODE: 0

CUSTOMER_CRASH_COUNT: 99

DEFAULT_BUCKET_ID: COMMON_SYSTEM_FAULT

BUGCHECK_STR: 0x50

PROCESS_NAME: System

LAST_CONTROL_TRANSFER: from 80539ee1 to 8053ce32

STACK_TEXT:
f78de710 80539ee1 f78de72c babe5eb8 f78de9cc nt!_output+0x909
f78de74c 8052b687 f78de788 00000200 babe5eb8 nt!_vsnprintf+0x2f
f78de9a4 8052b88c 8052b86c ffffffff 00000000 nt!vDbgPrintExWithPrefix+0x91
f78de9c0 babe6332 babe5eb8 000c000a babe5d50 nt!DbgPrint+0x1a
WARNING: Stack unwind information not available. Following frames may be wrong.
f78dead0 babdfe7b 82dfcae8 f78deae0 00c80030 eLock2FSCTLDriver+0x11332
f78debb0 8057482d 82dfcae8 00000001 8055aee0 eLock2FSCTLDriver+0xae7b
f78debc8 805748ca 8055ae80 babdfdf0 00000000 nt!IopNotifyAlreadyRegisteredFileSystems+0x25
f78debe8 babe8810 82fa00d0 babdfdf0 82fa00d0 nt!IoRegisterFsRegistrationChange+0x8e
f78dec84 80581377 82fa00d0 82ee4000 00000000 eLock2FSCTLDriver+0x13810
f78ded54 80581487 80000c88 00000001 00000000 nt!IopLoadDriver+0x66d
f78ded7c 8053877d 80000c88 00000000 830498b8 nt!IopLoadUnloadDriver+0x45
f78dedac 805cff70 f4235cf4 00000000 00000000 nt!ExpWorkerThread+0xef
f78deddc 805460ee 8053868e 00000001 00000000 nt!PspSystemThreadStartup+0x34
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


STACK_COMMAND: kb

FOLLOWUP_IP:
eLock2FSCTLDriver+11332
babe6332 ?? ???

SYMBOL_STACK_INDEX: 4

SYMBOL_NAME: eLock2FSCTLDriver+11332

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: eLock2FSCTLDriver

IMAGE_NAME: eLock2FSCTLDriver.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 44855aad

FAILURE_BUCKET_ID: 0x50_eLock2FSCTLDriver+11332

BUCKET_ID: 0x50_eLock2FSCTLDriver+11332

Followup: MachineOwner
---------


Thank you, :thumbsup:

#4 Ken-in-West-Seattle

Ken-in-West-Seattle

  • Members
  • 518 posts
  • OFFLINE
  •  
  • Local time:05:14 PM

Posted 10 November 2009 - 09:33 AM

Is it an Acer computer? Some people removed the elock program to fix this. The guess is that it conflicts with something in another program. Some have blamed avg8.


http://www.experts-exchange.com/OS/Microso...Q_24085176.html

But the program shows up with a similar error in some cases where spyware and malware are also detected. Nothing conclusive though.

Acer has written their own proprietary stuff into their BIOs and I have yet to find any documentation that's either useful or younger than my dog.

I don't have a computer with these programs Acer eWhatever to test, but perhaps you could disable them in msconfig and see if the bsod stops.

Use care if you have the elock software installed and a password set.

You may want to read this page and decide if this is a good idea. Maybe uninstalling it would be cleaner.

http://acer-elock-management.software.informer.com/

#5 Ken-in-West-Seattle

Ken-in-West-Seattle

  • Members
  • 518 posts
  • OFFLINE
  •  
  • Local time:05:14 PM

Posted 10 November 2009 - 09:42 AM

This google search turns up some interesting stuff.

http://www.google.com/#hl=en&source=hp...4f5ed7994d722e7

And more than one reference to an AVG faq that no longer exist.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users