Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Devenum.dll problems!!!


  • Please log in to reply
No replies to this topic

#1 Rayak

Rayak

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:04:22 PM

Posted 08 November 2009 - 03:07 AM

Hi guys,
I've got a problem with my devenum.dll. Whenever I use my Windows Live Messenger, either signing in, or getting a message from someone, or when I plug something into my USB, a window pops up that says "C:\Windows\system32\devenum.dll is either not designed to run on Windows or it contains an error." It still lets me run the programs, but it's EXTREMELY annoying! It could pop up at some random times too.
I have tried to replace the .dll file, but the system won't allow me to delete (tried in Safe mode too, and using command prompt), or even move the original devenum.dll from the system32 folder. I've tried to gain full access of the file, but it says acces is denied (even after I turned off the UAC in control panel), I've ran the SFC, but it just said it could't fix the problem. Devenum.dll is a file from DirectShow, so I tried updating my DirectX, didn't fix the problem. Downloaded DirectX SDK and Windows SDK but couldn't fix the problemw with that too! I'm out of options! Can anyone suggest a solution to this?
I've just uninstalled and re-installed Windows Live Messenger (thought I'd give it a shot), but things remained the same. I've been told that devenum.dll is also part of WMP, but I have the latest version, and my Windows Vista is fully updated too.
This started happening a couple of months ago, at the same time I lost the ability to import any audio/video files into my Windows Movie Maker (not sure if the two are related, but still). I think it was one of those darn updates... not the first time they screw up my system... somehow :S.

Thanks a million in advance! :huh:

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users