Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot Switch Off Java Update.


  • Please log in to reply
8 replies to this topic

#1 bluesjunior

bluesjunior

  • Members
  • 761 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:25 AM

Posted 06 November 2009 - 05:04 AM

My update checker let me know there was a new Java released yesterday v6 update17. I opened my installed version u16 to remember which boxes I had unticked in the preferences tab and noticed that the search automatically for updates box which I normally had unticked was ticked. After checking my settings I uninstalled Java and reinstalled the latest version. I then went to set my preferences like uncheck the quick starter and uncheck the Java Update box in my start menu using Autoruns. I again noticed that the Automatic updates box had magically checked itself again, so I unchecked it, clicked Apply and OK closed Java and then reopened it from the shortcut in Control Panel and found that it had checked itself again. I realise it probably couldn't update anyway as I have it switched of in the start up menu but does anyone know how to switch this feature off for good?.http://www.bleepingcomputer.com/forums/style_images/bc/folder_post_icons/icon14.gif
Motherboard: Gigabyte GA-MA770T-UD3, CPU: AMD Athlon II X3 450 Processor, Memory: OCZ 4GB (2x2GB) DDR3 1333MHz,Graphics: PowerColor HD 5750 1GB GDDR5,
PSU: Corsair 430W CX PSU 4x SATA 1x PCI-E, Hard Drive:Samsung SpinPoint F3 500GB Hard Drive SATAII 7200rpm 16MB Cache.

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,236 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:25 AM

Posted 06 November 2009 - 08:34 AM

See data at http://java.com/en/download/help/java_update.xml#howto.

If yours isn't working properly, then I would try uninstalling it (via Add/Remove Programs) and then downloading the update again and installing anew.

Louis

FWIW: I can only see the Java applet if I go to Control Panel and switch to classic view (button on left), then the directions provided above work for me.

Edited by hamluis, 06 November 2009 - 08:47 AM.


#3 bluesjunior

bluesjunior
  • Topic Starter

  • Members
  • 761 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:25 AM

Posted 07 November 2009 - 05:30 AM

I have tried uninstalling and reinstalling and it is still the same, ie automatic updates refuses to switch off. I posted in order to let others try and see if theirs was the same. I would like to know if anyone has been able to successfully switch this off in such a way it stays off. It won't do it on my installation and I would like to know if any one has succeeded. All other aspects of Java are working perfectly, I just can't turn off auto updates, I can untick the box press Apply and OK close the box then reopen it from the icon in my control panel and the box is checked again. Are you absolutely sure yours isn't the same.
Motherboard: Gigabyte GA-MA770T-UD3, CPU: AMD Athlon II X3 450 Processor, Memory: OCZ 4GB (2x2GB) DDR3 1333MHz,Graphics: PowerColor HD 5750 1GB GDDR5,
PSU: Corsair 430W CX PSU 4x SATA 1x PCI-E, Hard Drive:Samsung SpinPoint F3 500GB Hard Drive SATAII 7200rpm 16MB Cache.

#4 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:25 AM

Posted 07 November 2009 - 08:33 AM

No problems here with the latest Java or any previous release.

Used the procedure as outlined in the link given by Louis.

#5 hamluis

hamluis

    Moderator


  • Moderator
  • 55,236 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:25 AM

Posted 07 November 2009 - 10:17 AM

It works for me. I tested it before posting a response.

Louis

#6 jsmart7

jsmart7

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:12:25 AM

Posted 07 November 2009 - 10:57 AM

This is just a probability so do not panic. but I think your version of Java is corrupted, and that is why it is refusing to turn off auto updates. Better you check the source of the installation.

#7 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:12:25 AM

Posted 07 November 2009 - 11:23 AM

I dont even bother to install Java. It was back in 1996-1998 when Java became so popular for dynamic web sites. Now most web sites use Adobe Flash for most of dynamic content. Using Java on web sites has become rare. You need java only if decide to use a website using some java component or install an application coded in java ( like limewire ).

#8 RedDawn

RedDawn

  • Members
  • 454 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:06:25 AM

Posted 08 November 2009 - 10:06 AM

bluesjunior,

If this is a Vista system, you need to give the Java Control Panel Admin rights.

Navigate to where Java is installed, usually something along these lines:

C:\Program Files\Java\jre6\bin

Then scroll down till you see:

javacpl.exe

Right click on it, and click Properties.

Click on the Compatability Tab.

Check the Run this Program as an Administrator.

Click Apply, then click Ok.


Now any changes you make in the Java Control Panel should stick.

Edited by RedDawn, 08 November 2009 - 10:10 AM.


#9 fugeesnfunions

fugeesnfunions

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:25 PM

Posted 08 July 2011 - 09:06 PM

If you're having the same problem with Java and you're running Windows Vista or Windows 7, DO NOT waste your time uninstalling and reinstalling Java! Technically speaking, nothing is wrong, so reinstalling won't fix anything. Vista/7 protects certain system level changes by automatically resisting any attempts at modification without "administrative rights", and that's exactly what's happening here.

RedDawn already had the problem pegged here, but I want to add that permanently giving the Java control panel applet administrator rights might not be the best idea. Am I being paranoid? Probably. But why take a chance? RedDawns solution and instructions are all just about perfect,

but..

Instead of:

Right clicking on javacpl.exe

Selecting Properties

Selecting the Compatibility Tab

And telling it to Run this Program as an Administrator

Just do this:

Right click on javacpl.exe

Then select Run as administrator.

The control panel applet will open up and you can now permanently disable the auto update feature without forever granting javacpl.exe administrative rights.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users