Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BIOS Recovery Help


  • Please log in to reply
5 replies to this topic

#1 djf041000

djf041000

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:05 AM

Posted 05 November 2009 - 05:09 PM

I had an account here before when a friend recommended me to this site, and the help was absolutely awesome so I'm hoping that someone here would be able to help me with a problem I'm having with my PC.

Alright, so I have an Alienware Area-51 M9750. I was having a problem with my SLI for whatever reason, and after trial and error and countless hours of troubleshooting I could not get it to work again. Every time I enable SLI, my system blue screens and reboots and I have to uninstall my graphics driver in order to run the system with a single card setting so that it will not crash. I don't know the cause of the problem, it was just something that I woke up to and saw the beautiful blue screen on my laptop. That's not the main problem though. In looking for some way to fix this, I decided that I needed to update my BIOS. Now, I got the BIOS file from Alienware's tech support which they packaged in a bootable .iso file to burn to a CD. Easy enough to flash with, just follow the on screen instructions and blah blah blah.

However, when I was flashing my BIOS my PC shut off, presumably from heat. It was done with the delete portion, and about 68% within the write portion. That means my computer is effectively a brick right now because I don't have a BIOS on the motherboard. After many calls and attempts to fix this with tech support, I got a few methods on how to try to fix this problem. Every solution involves using a 3.5 inch floppy drive and putting your BIOS on to it, and starting your PC and forcing your system to update the BIOS from the floppy drive. So that doesn't seem so hard. One particular solution is from this site:

Recover or Undo Corrupt AMI BIOS Flash Update My Digital Life

The problem is, however, that the ONLY form of the BIOS file you can get from Alienware is in a .iso file format. When opened up the file (m9750_BIOS_0F04_XP.iso) with Power ISO and pretty much any .iso program out there (Magic Iso, Daemon tools, etc.) you cannot see the actual BIOS files because they are hidden. So finally I got a program called IsoBuster Pro which I was able to look inside the m9750_BIOS_0F04_XP.iso successfully and find the hidden files. There was a folder within the .iso called Bootable Disc which contained 2 files: BootCatalog.cat and BootImage.img. The BootImage.img file looked interesting so I extracted that with IsoBuster Pro and then loaded that file with IsoBuster Pro. When looking inside the BootImage.img file, I finally found the .rom BIOS file I was looking for (w8350f04.rom) which is shown in this screen shot (url for screenshot is http://img.photobucket.com/albums/v239/Bur...04/Misc/Rom.jpg in case it does not show properly):

Posted Image

So now the problem is, how do I extract the w8350f04.rom file from the BootImage.img file? I've tried to use the extract command from IsoBuster Pro and it will not extract the file (I have a fully licensed and registered version of IsoBuster Pro 2.6). Every time I execute the extract command the popup progress bar disappears instantly and I hear a beep like it's been done, but it actually hasn't. I have searched high and low for programs that can extract something from a .img file successfully to no avail. I've mounted the BootImage.img using Daemon Tools and when I try to view the files within the .img it keeps giving me an error that says something like "unknown file system". WinRar cannot open the BootImage.img, but I was able to open the m9750_BIOS_0F04_XP.iso that conained the BootImage.img with it (go figure... although the BootImage.img was hidden when opened with WinRar). Neither can PowerISO or Magic ISO.

Just in case anyone knows how to or would like to extract the files themselves, here is an uploaded link for the BIOS file I have which is hosted on Mediafire. It is a .rar pack with the original m9750_BIOS_0F04_XP.iso (straight from the Alienware website) file and the extracted BootImage.img file that I am looking to extract the w8350f04.rom file from:

Bios Files.rar

Any help would be greatly appreciated. The solution is so close because I have the .rom file in my possession, but no way to actually extract it from this BootImage.img file to put on my floppy and actually use it to flash my BIOS. Without it, my computer is as good as dead. Thanks for your time for anyone who's read and/or replied to help. Cheers.

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:11:05 AM

Posted 05 November 2009 - 07:56 PM

If your BIOS is on a removable chip [it should be] you can have http://www.biosman.com/ flash it for you
You can use what you have or what they have cataloged
Around 20 bucks
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 djf041000

djf041000
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:05 AM

Posted 05 November 2009 - 10:27 PM

Garmanma, I appreciate the reply. Actually I have been able to solve the BIOS problem. A buddy of mine was able to mount the .img file in Linux and extract the w8350f04.rom for me. I am unsure of what program he used to mount the .img file, but I finally found a program called WinImage which will extract files from a .img image file. Long story short, with the extracted w8350f04.rom file I was able to successfully reflash my BIOS thanks to AMI's failsafe recovery method in their chip (which really is a Godsend). Basically I made a MSDOS bootdisk and renamed the w8350f04.rom to AMIBOOT.ROM (it really was kind of a simple fix, but the problem was getting the w8350f04.rom file out of the bootdisk.img which I was unable to do) and my computer recognized the file and flashed the BIOS. Now my computer is able to boot up and function normally (well, mostly) again which I am very happy about. So if anyone else has any BIOS issues in the future and they happen to have an AMI BIOS chip on their motherboard, I do hope they will find my experience helpful in being able to recover their BIOS without having to send their computer in for repairs, having to buy a new BIOS chip, or having to get a new motherboard.

Now that my BIOS is finally recovered, I am still having a severe issue with my SLI in my laptop. Basically, any time I enable SLI in my system, my system crashes with a blue screen stop error. I could go more in to detail, but I'm not sure if I should continue it in this topic or make a new topic? I hope one of the moderators would be able to answer that question. Thanks again for the help!

Edited by djf041000, 05 November 2009 - 10:29 PM.


#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,274 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:05 AM

Posted 06 November 2009 - 09:08 AM

<>

Same problem as originally posted...just erroneous assumptions by you what would cure it...I see no reason for a separate post.

Sounds to me like it needs to be checked out for repair/warranty considerations. You seem to have tried to avoid that by flashing the BIOS, which proved to be ineffective.

What's the data from the STOP error?

I suggest that you do a search of your XP partition and see if you have any .dmp files from these BSODs.

If so, then try the following, Help Diagnosing BSODs And Crashes (BC) - http://www.bleepingcomputer.com/forums/t/176011/how-to-receive-help-diagnosing-blue-screens-and-windows-crashes/

Louis

#5 djf041000

djf041000
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:05 AM

Posted 06 November 2009 - 09:05 PM

This is basically the information I have on the SLI problem so far.

First of all, my system specs:

Alienware Area-51 M9750
Motherboard - Arima W835DI (AMI BIOS)
CPU - Intel Core 2 Duo T7600 @2.33Ghz 667Mhz FSB 4mb Cache
HD - Hitachi SATA 200GB 7200 RPM x2 (Raid 0)
Video Cards - Nvidia GeForce Go 7950 GTX 512MB x2 (SLI)
RAM - 2GB Y9530 QIMONDA PC2-5300 DDR2 @667 Mhz
OS - Microsoft Windows XP Professional x32 bit

Second of all, my warranty is no longer in effect so that is why I'm posting on here for help with this SLI problem. So anyway, I woke up one morning (left my laptop on overnight) and my PC had a BSOD. After being puzzled by it for a minute, I decided to just shut off my PC and restart it. My PC kept getting a blue screen and rebooting right after the Windows splash screen right before the user login screen. Unable to read the output for the BSOD because auto reboot was enabled, I reinstalled Windows thinking something might have happened to Windows. After reinstalling Windows and all of my drivers my computer worked great. Then I finally got to the point where I enabled SLI, and my computer crashed and started another BSOD loop of BSOD -> reboot, etc. After a few times of this happening I finally got something from the BSOD which was "nv4_disp.dll". Figuring nv4_disp.dll had something to do with Nvidia, I decided to reboot in safe mode and uninstall my graphics driver. Problem solved, I was able to boot in to Windows normally now. So that's when I finally figured out my BSOD problem had something to do with my video cards. I searched for the most up to date video driver and installed it, then enabled SLI and again BSOD. nv4_disp.dll always kept coming up as part of the BSOD. So I did some research and just about every solution for it was to reinstall the graphics driver because apparently the issue was nv4_disp.dll going in to an infinite loop and crashing Windows.

Well, I reinstalled the driver again several times, even using the original driver I got with my Alienware straight out of the factory that I knew SLI worked with before, up to the latest driver (I can't remember the version I used at the time, but it was like... 140.something?). Anyway, I just finally said forget it and used the PC in single card rending and gave up on SLI for a while. A few months later, it was suggested by a buddy of mine that one of my video cards or the SLI cable was probably dead because I showed him the SLI problem, which is basically every time I enable SLI my computer BSOD and I have to reboot in to Safe Mode and uninstall the graphics driver. He suggested I take both of my video cards out (the Parent and the Daughter) and install one at a time in the primary slot to figure out which card was dead. Well the Daughter card worked in the primary slot (being the primary card of course) and the Parent card did NOT work, which lead me to believe that was the card that was fried. So I ended up calling Alienware for a new set of cards, and of course they do not have any because the computer is over a year old, which I thought was dumb. Anyway, I finally got a new set of cards on E-bay with a new SLI cable.

So I installed the new set of cards and then tried enabling SLI again. Now this time when I enabled SLI, the screen just went black. No BSOD, just a black screen. The backlight of the monitor kept turning on and off, but nothing would show up on screen whatsoever. Then I turned my PC off and tried installing the new SLI cable I got. Same thing. So I decided to take both cards out, and like I did before, test one at a time in the primary slot and booting up the PC to see if they both worked. Again, the Parent card did not work. So I'm wondering how did I get TWO bad Parent cards? One was brand new! I called up Alienware tech support and talked to them for a few hours several times throughout several days and got a few suggestions:

1. Update/reinstall my video driver - did it SEVERAL times before the call and again over the phone just to humor him
2. Reinstall Windows - already did but would not do over the phone because it takes a bit to do
3. Try a new set of video cards - already did, and tried a combination of both sets as well
4. Remove the CMOS battery from the motherboard and restart PC
5. Remove the SLI cable and enable SLI to try to "force" the PC in to SLI mode
6. Update my BIOS (which was what my first post was about, it went horribly wrong but I fixed the issue)

Now the agent said if any of that didn't work, one of several things could be the problem:

1. One of my video cards is bad. Well no kidding, but I got a new set and neither worked in SLI. Also, apparently the Parent and Daughter card have different BIOS on each card, so my method of figuring out which card was bad (i.e. one card at a time in the primary slot) didn't work because of that. No matter what, the Parent card won't work in the primary slot so the agent said the only way to know if that card actually works is to enable SLI... which I can't.
2. The SLI cable could be bad. Same as cards, I got a new one.
3. Heat could be an issue with either the cards or the north bridge. However, I've tried to enable SLI right after boot when the computer hasn't been used so it didn't even have time to overheat. I don't think that's the issue.
4. The SLI selector card could be bad. Yeah, but actually my laptop doesn't have one so this is impossible.
5. One of the video card slots on the mother board could be bad.
6. Some circuit that regulates the power on the mother board can be blown which apparently only affects my SLI


So after the call, I tried suggestions 4, 5, and 6 (removing battery, SLI cable, update BIOS) and none of them worked. With the new cards, I just kept getting that black screen that would never changed, and the backlight turning on and off. With the old cards, I kept getting the BSOD that always said nv4_disp.dll. I installed the latest driver from Alienware's website which was 169.something and that did not work either. So after some more digging around on the net, I found http://forums.laptopvideo2go.com/topic/160...rkaround-xpx32/ . Apparently this system has problems some times running SLI because several people have had it, so this guy posted a "workaround" for it. I followed the advice in the first post which basically suggests:

1. Uninstall your driver
2. Get the most up to date forceware driver from laptopvideo2go.com (driver v195.39) along with the new .inf file that comes with it.
3. Install the driver for your first card, but cancel the installation for the second.
4. Reboot
5. "update" the driver for your second card in the device manager, pointing to the folder of the new driver downloaded from laptopvideo2go.com (driver v195.39)
6. Reboot
7. win

Ok, so I got through steps 1-6. At this time, I had my old factory default video cards installed. I went to enable SLI in hopes of achieving step #7, but it appears that I never actually won. For the first time, I finally saw my desktop (or at least most of it) after enabling SLI. It looked like SLI was finally going to work, then after a few seconds I got a BSOD so I was wildly disappointed. My computer would reboot, get to the user login screen of windows and render part of it out on the screen, then BSOD and reboot and keep going in a cycle. This time, the BSOD referenced nv4_disp, not nv4_disp.dll. I uninstalled the driver and took my PC apart. I cleaned all connectors with denatured alcohol and put new thermal grease on it (I used OCZ Freeze which when I did research, is supposed to be one of the best out there). I forgot to put new grease on it after taking it apart the first time so it had the old grease on it. So I knew I was having a bit of a heat issue so I figured I'd seal everything up properly. Anyway, after getting it all put back together, I turn my PC on and log in to Windows, enable SLI, and this time immediate BSOD. It didn't even switch over to SLI and start rendering out my desktop before the BSOD, just immediate crash. I got the stop error code this time which read:

PAGE_FAULT_IN_NONPAGED_AREA

0x00000050 (0xD22A81BC, 0x00000000, 0x8052AB60, 0x00000000)

nv4_disp.dll is no longer in the stop error now though in any shape or form whatsoever. I did some research for that stop error online and came up with a few reasons for it. One was due to a video card problem. Another was a video driver. My cards both appeared to work, and I've reinstalled this driver about a hundred times already. The current driver I'm using is the forceware v195.39 from www.laptopvideo2go.com. Currently, I have no idea if for some reason, after all the drivers I've tried, there is some problem with them that they cannot enable SLI properly. I'm unsure if it's the Parent video card that's the problem. I put new thermal grease on my PC on all of the good parts and stress tested it and benchmarked, and the heat dissipation is working very well now so that's not an issue. I mean the PC works ok in it's current state only using one card, it's just that every time I enable SLI it crashes and I have no idea why. I just don't know what else to do or where else to go from here. Just about everything I've tried has failed. If anyone has any idea why I cannot get SLI to work or some other ways to troubleshoot this problem that would be a Godsend. I've worked on this way too long and did way too many things and I'm past the point of frustration right now. Any and all help would be appreciated.

Just editing to update with a couple more BSODs I've gotten:

0x000000EA (0x878B9020, 0x8A22B818, 0xBACEBCBC, 0x00000001)

nv4_disp

This one was from the v195.39 driver I got from laptopvideo2go.com that I reinstalled after applying new thermal grease to my CPU and GPUs.



0x0000008E (0xC0000005, 0xBF9F35E4, 0xB89A98D4, 0x00000000)

nv4_disp.dll - address BF9F35E4 base at BF9D5000, DateStamp 45ee1cc0

This one is from the original driver installed on my PC by Alienware when it left the factory which was v94.23. I tried the old driver again just for kicks mostly to see something but it didn't work either. I enabled SLI, it looked like it was going to work since it started showing bits from my desktop again, then the screen went black and nothing showed up again. I restarted my PC and instead of the Windows user login screen, it was just all black and the mouse finally showed up on the screen then the BSOD occurred. Still, whenever I enable SLI my system crashes and I still cannot figure out why.

Edited by djf041000, 06 November 2009 - 11:01 PM.


#6 djf041000

djf041000
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:05 AM

Posted 08 November 2009 - 06:50 PM

Just curious if anyone had any more suggestions about how to fix the SLI problem? Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users