Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Not getting ip and hence no connection to internet in fedora9


  • Please log in to reply
4 replies to this topic

#1 maass

maass

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:03:40 AM

Posted 01 November 2009 - 07:20 AM

Hello all,

i am very new to linux and this is my first installation .
i have installed fedora9 through virtual box on my PC.
i am not getting assigned automatically IP and i am unable to browse internet in fedora.
some of the commands i used are below.

i have selected Activate NIC as computer starts but The NIC is not getting activated after i start.
before i activate the NIC if i check "ifconfig eth0 up"
i am getting
ifconfig eth0 up
SIOCSIFFLAGS: Permission denied

after activating the NIC through GUI of network manager i am getting the below results

ifconfig
eth0 Link encap:Ethernet HWaddr 08:00:27:53:CC:F5
inet addr:10.0.2.15 Bcast:10.0.2.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:fe53:ccf5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:15 errors:0 dropped:0 overruns:0 frame:0
TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2688 (2.6 KiB) TX bytes:12435 (12.1 KiB)
Interrupt:11 Base address:0xd020

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:841 errors:0 dropped:0 overruns:0 frame:0
TX packets:841 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:44480 (43.4 KiB) TX bytes:44480 (43.4 KiB)

------------------
lspci

00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 40)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
00:06.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0b.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller
00:0d.0 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 02)

--------------------------

Thanks

Edited by maass, 01 November 2009 - 07:44 AM.


BC AdBot (Login to Remove)

 


#2 maki2012

maki2012

  • Members
  • 171 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:10:10 AM

Posted 01 November 2009 - 08:11 PM

Just a warning- I do not use Fedora, nor did I use Virtual Box to install my Ubuntu. I do have some knowledge on this matter, but I can only give you slight pointers.

May be crazy, but is the NIC card compatible? (I'm more software then hardware)
Also try assuming temp. root access due to "SIOCSIFFLAGS: Permission denied". Use the command sudo root?

Just some suggestions...

#3 skyking1

skyking1

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:10 PM

Posted 10 November 2009 - 11:01 PM

From your ifconfig entry:

eth0 Link encap:Ethernet HWaddr 08:00:27:53:CC:F5
inet addr:10.0.2.15 Bcast:10.0.2.255 Mask:255.255.255.0

looks like you have an address of 10.0.2.15
Is that a valid address on your network?
If not, try getting an address again:

dhclient eth0

Try to ping the gateway.

ping 10.0.2.1

See if that gets any results.

#4 bisquit maker

bisquit maker

  • Banned
  • 43 posts
  • OFFLINE
  •  
  • Local time:05:10 PM

Posted 11 November 2009 - 12:32 AM

http://www.fedoraforum.org/
http://linuxquestions.org

Go and ask for help in the areas that have people who use the system.
You're not going to get the help you need here.

#5 Willm

Willm

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Potsdam, NY
  • Local time:06:10 PM

Posted 01 December 2009 - 01:03 AM

Hi,

I had this exact problem with my VM's in Virtualbox a couple of weeks ago. The simple way to fix this is go into the settings of your VM's and then change the network settings to "Bridged". This will allow the router that is connected to your host computer to set the ip addresses for each of the VM's when the are turned on.

So essentially this address "inet addr:10.0.2.15" will become a 192.169.1.x address. Or if your ip addresses are 10.0.x.x then it will appear as a 10.0.x.x when you go to check what your ip is. If you want to know what it will look like open a Command Prompt on your host computer and type ipconfig, then you will know what your VM ip's should look like.

Cheers!

Edited by Willm, 01 December 2009 - 01:08 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users