Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Malware infected and restarted computer - Help!


  • Please log in to reply
1 reply to this topic

#1 AboveTheBULL

AboveTheBULL

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:GMT -6
  • Local time:11:37 AM

Posted 30 October 2009 - 12:51 AM

While working on a HTML project for school in late September, I began searching around the web for some images online. Soon enough, I landed on Mininova and found the following torrents, which I started in my bittorrent client:
  • link removed
    {Directory of actual .jpg images with a link to some unsavory site. I remember making sure the link was excluded from download.}
  • --> link removed <--
    {RAR file. The description listed this as example (although I never went to it to check): link removed
  • While attempting to navigate to above torrent page (1313017), the following pop-up appeared although I have pop-ups blocked (likely irrelevant, but wanted to include anyway):
    link removed
Well. Immediately as the RARed torrent #1313017 finished downloading, Comodo firewall began sending a barrage of messages regarding a "~.exe" that was attempting to access the internet and install components. I blocked all, of course. Then it alerted something similar about "3DE.tmp" attempting to install some components. I continued to hit "Block", all the while FURIOUS that Avast!Home had provided NO protection although it was on, enabled, and fully updated.

Then, all of sudden, all my open programs began to close out one by one, and the system restarted on its own. I immediately began hitting F5 to activate the SAFE MODE selection window, and selected SAFE MODE.

I ran Avast! Home's scanner in safe mode, and it picked up nothing. Troubled, I restarted in normal mode, and immediately a new icon in the system tray (not Avast or any of my current security software) proclaimed that my system was infected and to click on the balloon window to download necessary software to "pervent" (sic) serious damage.

Of course I did not. I instead attempted to run Spybot S&D, but it was acting funny, not showing any updates available although the program hadn't been used in probably 2 months. Moments later, Avast popped up an error and screamed the siren, explaining that "Your system is infected with a rootkit. It is recommended that you immediately restart and schedule a full system scan."

So I turned the computer off, restarted in SAFE MODE WITH NETWORKING, and proceeded to download SuperAntiSpyware, Malwarebytes', and the updated definitions file for Spybot. (It wasn't until later that I learned that a rootkit can still operate just fine in Safe Mode -- I was devastated and immediately fearful of my data's security...)

I then installed the definitions file, which immediately showed "Done", which I felt was peculiar. Still, I ran the scan and it deleted several files including CoolWebSearch.

I then tried to install SuperAntiSpyware and was informed that the administrator has made settings preventing its installation. I then restarted and ran in normal mode with networking physically turned off (via switch on side of laptop), then installed both SuperAntiSpyware and Malwarebytes', running a thorough scan after each.

SuperAntiSpyware found 5 horrible items:
  • Trojan.DNSChanger-Codec registry key: HKU\S-1-5-21-2157769812-1539610544-3004968214-1006\Software\videosoft
  • Trojan.Dropper/Gen file: C:\Documents and Settings\Tré\Local Settings\Temp\~.exe
  • Trojan.Dropper/Gen-NV file: C:\Documents and Settings\Tré\Application Data\SERES.exe
  • Trojan.Dropper/Gen-NV file: C:\System Volume Information\_RESTORE{5808F9B6-96B5-4803-A039-47EB1E010CB7}\RP1344\A0209000.exe
  • Trojan.Dropper/Gen-NV file: C:\System Volume Information\_RESTORE{5808F9B6-96B5-4803-A039-47EB1E010CB7}\RP1344\A0209035.exe
Malwarebytes' was then run.

Found during the Quick Scan:
  • Trojan.FakeAlert file: C:\Documents and Settings\Tré\Application Data\lizkavd.exe
  • Trojan.FakeAlert registry key: HKCU\Software\Microsoft\Windows\CurrentVersion\Run\mserv --> value: mserv
System required restarting to remove all of components. Did so then ran again and found during Thorough Scan:
  • Trojan.FakeAlert file: C:\System Volume Information\_restore{5808F9B6-96B5-4803-A039-47EB1E010CB7}\RP1345\A0209073.exe
I am worried the computer still is infected. I'm afraid to connect it to the internet to download any further programs/tools for fear that sensitive info will be transmitted to the rootkit/virus creator's servers. Is there a way you can check the file from Mininova and tell me if my computer is even worth trying to repair? Of course, I'd rather salvage the 250GB of data on the hard disk (family photos, client data, lots of school work, etc), but if it's impossible to know it's safe, I cringe at the thought of re-imaging.

Can you help me?

-----

Toshiba Satellite A45-S151 laptop
Windows XP Home, all updates through 9-2009
Avast! Home, all updates through 9-2009
Comodo Firewall, all updates through 9-2009
Upgraded to 3.06GHz P4, 2GB RAM, 250GB WD2500BEVE drive (split into two 125GB partitions, but still needed WD's DDO utility for laptop to see beyond 137GB - meh)

Edited by garmanma, 31 October 2009 - 09:09 PM.


BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:01:37 PM

Posted 31 October 2009 - 09:12 PM

Run this application first and then Update mbam and run a FULL scan
Please post the results


Please download Rkill by Grinler and save it to your desktop.Link 2
Link 3
Link 4
  • Double-click on the Rkill desktop icon to run the tool.
  • If using Vista, right-click on it and Run As Administrator.
  • A black DOS box will briefly flash and then disappear. This is normal and indicates the tool ran successfully.
  • If not, delete the file, then download and use the one provided in Link 2.
  • If it does not work, repeat the process and attempt to use one of the remaining links until the tool runs.
  • If the tool does not run from any of the links provided, please let me know.
Any time the computer restarts you will need to run the application again

================================


We Need to check for Rootkits with RootRepeal
  • Download RootRepeal from the following location and save it to your desktop.
  • Extract RootRepeal.exe from the archive (If you did not use the "Direct Download" mirror).
  • Open Posted Image on your desktop.
  • Click the Posted Image tab.
  • Click the Posted Image button.
  • Check all seven boxes: Posted Image
  • Push Ok
  • Check the box for your main system drive (Usually C:), and press Ok.
  • Allow RootRepeal to run a scan of your system. This may take some time.
  • Once the scan completes, push the Posted Image button. Save the log to your desktop, using a distinctive name, such as RootRepeal.txt. Include this report in your next reply, please.

----------------------------------

Please note: If Rootrepeal fails to run, try this step: Click Settings - Options. Set the Disk Access slider to High

Also try: right-click on rootrepeal.exe and rename it to tatertot.scr

Edited by garmanma, 31 October 2009 - 09:14 PM.

Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users