Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't open Spybot S&D because of rootkit!! Need help resetting permissions and disinfecting!


  • Please log in to reply
2 replies to this topic

#1 rb404

rb404

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:37 AM

Posted 27 October 2009 - 06:20 PM

Hi,

Yesterday I tried downloading a random video and it required me to download some unheard of file to allow me to decode it. It didn't work and I deleted th video. Like a complete moron I'd let my system get taken over by some virus... Symptoms:

- search results on google redirected randomly - especially anything to do with spyware software
- Spybot won't open now - says I don't have permission
- Hijackthis wouldnt open
- Avast antivirus started misbehaving

Anyways, i panicked and found these forums... I ran through a few of the programs: ComboFix allowed my computer to stabilise at leasyt and now my google searches are running. MBAM got downloaded and it cleaned a few things. I know I probably did a lot of these things in the wrong order foolishly but I really panicked because I don't want to lose all my university work! I've been through the preliminary steps of renaming and reinstalling spybot but nothing works! It just keeps saying 'windows cannot access the specified device, path or file' - undon't have permissions etc. I can tell a lot of people on this forum have had this same kind of problem with rootkits so I was hoping to get some help here...

I haven't used any code whatsoever from these pages - just to be clear. Just let the programs run.

I'm lucky in a way because I didn't ess anything up but now there is still the problem of SPybot not opening because of the issue with my permissions and I was hoping I could get some help resetting those??? I have logs for everything I've run that I can provide as needed, or follow whatever instructions are kindly given - accurately I promise!

I have a worry that I haven't completely disinfected my system either so help with that would be most appreciated also!

I look forward to your reply.

Thanks
R

BC AdBot (Login to Remove)

 


#2 Orange Blossom

Orange Blossom

    OBleepin Investigator


  • Moderator
  • 36,958 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Bloomington, IN
  • Local time:03:37 AM

Posted 27 October 2009 - 08:37 PM

As no logs have been posted, I am shifting this topic from the specialized HiJack This forum to the Am I Infected forum.

==>PLEASE DO NOT NOW POST LOGS<== unless a log is specifically requested.
Help us help you. If HelpBot replies, you MUST follow step 1 in its reply so we know you need help.

Orange Blossom

An ounce of prevention is worth a pound of cure

SpywareBlaster, WinPatrol Plus, ESET Smart Security, Malwarebytes' Anti-Malware, NoScript Firefox ext., Norton noscript

#3 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:03:37 AM

Posted 29 October 2009 - 01:39 PM

Run this and your scan tools might work
I would also suggest a Root repeal scan



Please download Rkill by Grinler and save it to your desktop.Link 2
Link 3
Link 4
  • Double-click on the Rkill desktop icon to run the tool.
  • If using Vista, right-click on it and Run As Administrator.
  • A black DOS box will briefly flash and then disappear. This is normal and indicates the tool ran successfully.
  • If not, delete the file, then download and use the one provided in Link 2.
  • If it does not work, repeat the process and attempt to use one of the remaining links until the tool runs.
  • If the tool does not run from any of the links provided, please let me know.
Do not reboot the computer or you will have to run it again

=============================


We Need to check for Rootkits with RootRepeal
  • Download RootRepeal from the following location and save it to your desktop.
  • Extract RootRepeal.exe from the archive (If you did not use the "Direct Download" mirror).
  • Open Posted Image on your desktop.
  • Click the Posted Image tab.
  • Click the Posted Image button.
  • Check all seven boxes: Posted Image
  • Push Ok
  • Check the box for your main system drive (Usually C:), and press Ok.
  • Allow RootRepeal to run a scan of your system. This may take some time.
  • Once the scan completes, push the Posted Image button. Save the log to your desktop, using a distinctive name, such as RootRepeal.txt. Include this report in your next reply, please.

----------------------------------

Please note: If Rootrepeal fails to run, try this step: Click Settings - Options. Set the Disk Access slider to High

Also try: right-click on rootrepeal.exe and rename it to tatertot.scr
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users