Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop won't charge


  • Please log in to reply
2 replies to this topic

#1 LeeWillie

LeeWillie

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:54 PM

Posted 27 October 2009 - 07:05 AM

My Compaq XL1000 won't charge. I plug it in and the charger light blinks and the light that tells you you're connected to the internet does too. I took the battery out and it still won't power on. I bought what was supposed to be a comparable battery and it fit but then it didn't blink or work at all. I assumed it wasn't the correct battery. I put the original battery back in and the blinking started again. Up to the point where this problem happened the battery wouldn't hold a charge any longer than hour. I figured it was nearing the end of its life.

When I searched the net I only found a few possible causes 1) get a new battery or 2) the motherboard.

Any advice is greatly appreciated.

BC AdBot (Login to Remove)

 


#2 Delta16

Delta16

  • Members
  • 417 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Malta
  • Local time:06:54 PM

Posted 28 October 2009 - 10:25 AM

If the original battery that came with the laptop, was holding the charge for 1 hour only than the battery should be replaced with an original one.

You can find one on ebay or if there isn't on ebay, google it. "Compaq XL1000 Battery" and you'll get a list to buy one.

#3 DaffyKantReed

DaffyKantReed

  • Members
  • 190 posts
  • OFFLINE
  •  
  • Location:Vancouver, BC
  • Local time:08:54 AM

Posted 28 October 2009 - 11:23 AM

My Compaq XL1000 won't charge. I plug it in and the charger light blinks and the light that tells you you're connected to the internet does too. I took the battery out and it still won't power on.

When I searched the net I only found a few possible causes 1) get a new battery or 2) the motherboard.


Your laptop should run when the power supply is connected to the AC mains, even without a battery. Use a DMM to determine the output voltage.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users