Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Keyboard does not work at W2K Logon Screen


  • Please log in to reply
2 replies to this topic

#1 Phlimm

Phlimm

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:06:39 AM

Posted 25 October 2009 - 11:31 PM

My PS2 Port failed, so I bought a Microsoft Comfort Curve 2000 USB Keyboard. Plugged it in and Windows 2000 detected like 4 USB devices one after the other, I did not read any of them...I figured it was just installing. Then it said it needed a reboot. So fine, reboot. Get to the login screen to enter the password and nothing, No key press responds at all. Num lock light is locked on. Restart the PC, keyboard works fine in the BIOS. It just fails once I get to the login screen. I tried all the USB ports with the same result. I turned on the USB Legacy Keyboard support in the BIOS - then the keyboard only works in the BIOS - it fails at the OS selection screen for Ubuntu / Windows...but once the timeout for Ubuntu is reached, it works fine,

I am currently using the keyboard fine with Ubuntu so I know the hardware works fine. I would just stick with Ubuntu but it does not support my outdated video.

So...how to get Windows 2000 to recognize the keyboard? Remember that I cannot access the OS at all because I cannot type in a password, nor can I use a PS2 keyboard because the port has failed.

EDIT TO ADD: I tried to login to Safe Mode and the system Blue Screens with "Attempt to write to read only memory"

Edited by Phlimm, 26 October 2009 - 12:28 AM.


BC AdBot (Login to Remove)

 


#2 secret_id

secret_id

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:08:39 AM

Posted 01 November 2009 - 06:15 PM

I would try unplugging the keyboard and plugging it back in once you are at the login screen. Also try another USB port. If that doesn't work I would borrow another USB keyboard and try that. You could also try repairing your windows installation with your windows disk. Windows 2k should support USB keyboards with a standard installation.

#3 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:09:39 AM

Posted 02 November 2009 - 03:33 PM

When rebooting the computer, go into the BIOS and look for USB Legacy support and make sure that it is enabled
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users