Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

b.exe, Taskbar gone, exe's getting errors.


  • This topic is locked This topic is locked
1 reply to this topic

#1 LeDrew

LeDrew

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Local time:11:53 AM

Posted 20 October 2009 - 09:47 PM

Ok, I will first state that this problem is on a friends computer. I don't know when or how he got it. Nor do I have daily access to his computer.

Anyway. He is Running XP (Home I assume) and on a fairly new computer. He is Running McAfee total protection.

(note: he was also having USB problems ... objects being inserted not being recognized)

He was first having some google redirect problems. I looked in MSCONFIG and say that b.exe was staring up with his computer. So I followed the path to his temp file .. in there, not only did I find b.exe, but also a.exe, c.exe, d.exe, and several others. I disallowed b.exe from starting up.

So I downloaded MBAM for him. Installed fine, updated fine and I get this message:
"Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."
Or similar...

Restarted the computer and waited a bit ... but nothing came up. So it must have hit explorer.exe. I opened TASK MANAGER and saw that explorer WAS infact running fine. but b.exe was running again. Checked MSCONFIG "Through TM run" and it had a second entry. So I closed it from TM and explorer freed up partly. I can see the icon he has on his desk top, but where his TASKBAR would be, is replaced by a very thin grey bar. Thankfully he has a folder on his desktop that give me allowance to limited explorer options.

So next thing I tryed was get to the internet I hit the IE icon and get this message:
"The application failed to initialize properly (Numbers) Click on OK to terminate the application"

All other Icons besides McAfee, IE, and MBAM work .. suggesting that the virus is protecting itself.

Nothing else to do here but restart in safe mode ... so thats what I tried. Didn't work, the computer just restart before it even got to the login screen. Tryed it with networking and the other one. Still nothing. The only other option that worked was last known good ... anyway. I chose that and it did not solve the problem.

Then i tried for a system restore. Also didn't work ... the virus just closes Help and support down as soon as you try to open it. in all manors.

So I remember above exe fix and some other programs that could help him. I tested if USB was being recognized and it ws not, then I tryed his DVD and its blocking the DVD popup from opening so what ever has to be done, has to be done on his computer.

I now have b.exe removed from his computer and from start up ... I can get the desktop to reappear by resetting McAfees firewall, but the taskbar is still missing and nothings opening.

BC AdBot (Login to Remove)

 


#2 LeDrew

LeDrew
  • Topic Starter

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Local time:11:53 AM

Posted 24 October 2009 - 02:19 PM

This has been taken care of. It would seem that a fresh install of windows was a faster/better option.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users