Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

System Restore (SVI) Folder – “Access Denied”


  • Please log in to reply
6 replies to this topic

#1 black069

black069

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tabor City, NC
  • Local time:08:52 AM

Posted 20 October 2009 - 05:02 AM

For the last ~3 wks, I have not been able to access my (WinXP Home SP3-running) computer's System Volume Information (SVI) folders which, as most of you know, are where the System Restore points are stored. (See my computer's specs at bottom of this post.) There are 2 SVI folders on my HDD; one is located in my Windows Directory (C:) and another in a data partition on my HDD (E:). I DO have the folders configured such that they show hidden files/folders and protected operating system files. I am able to visualize the SVI folders in both directories. However, when I hover over the folders, they both read "Folder is empty." And when I click on the folders, a message appears: "C[or E]:\System Volume Information is not accessible. Access is denied."

I know that there are restore points stored there, though, because (A) I have manually created System Restore points without any problems, and (B) I can use a feature on CCleaner to view/delete old system restore points, and when I do this, there are many restore points visible there.

I have checked System Restore tab in My Computer's Properties. The box for turning off system restore is unticked, and beside both C: and E:, it reads "Monitoring."

I have tried to rectify the problem by turning off system restore through ticking the box which turns it off, clicking Apply, rebooting, etc., but I still have the same issue when I turn System Restore back on. (I have also tried to use some command-line interface fixes found via a Google search, but without success.)

To the best of my knowledge, I have not changed any policies or permissions on my system, although I do have to admit that I "tinker" quite a bit trying to learn how computers operate and have programs like TweakUI and others that could do this, I suppose. My wife is the only person who ever uses this computer, but she would never change any settings. We have the computer set up for one user which we both use so that login/logoff not required when boot, etc.

I should point out that I HAVE HAD access to SVI folder(s) up until the recent past. I reinstalled my OS for the first time (ever and it was 7 years old) about 2-3 months ago. Since it was the first reinstall I have ever done, it is quite possible that I didn't configure something correctly. I definitely could access SVI prior to reinstalling OS. After the reinstall, I am ~100% certain that I tried and was able to access the SVI folders...just not for the last 3 weeks or so. I cannot correlate the time with the installation of any new programs with the one possible exception of switching from AVG Free 8.5 to avast! for my antivirus program somewhere around that time.




I should also mention that multiple scans with avast, MBAM, SAS, Panda Anti-Rootkit, and a couple of free online scanners have not found any malware. I also have Windows Firewall enabled plus I have the inherent firewall capabilities of my wireless router. I also am up-to-date with Windows Updates and have checked Dell's website for any new recommended drivers.



So, if anyone can help me figure out what is going on and/or how to fix it, I would greatly appreciate it. I realize that I could just live with it, but it bothers me that a change occurred, plus I would like to create a home network to share files and folders between my much newer, more highly optimized laptop, but I don't want to risk causing issues with my laptop.

Thanks in advance!

My (desktop) computer's specs are the following:
Dell Dimension 4550 — Windows XP Home SP3 — Intel 4 CPU —
2GB RAM
Display Adapter: ATI Radeon 9700 TX (128 MB RAM)


Sound Card: Creative SoundBlaster Live! (WDM) Series
Network Adapter: Intel PRO/100 VE Network Connnection



BC AdBot (Login to Remove)

 


#2 joseibarra

joseibarra

  • Members
  • 1,180 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:08:52 AM

Posted 20 October 2009 - 06:26 AM

You are the curious one - like me :thumbsup:

What you describe sounds "normal", but I cannot explain how it seems to have changed for that folder in the last few weeks. There were some MS security updates last Tuesday... It takes more than view hidden files, etc. to see in there.

I find the most efficient way (other methods may be offered) to view the SVI folder on a drive is to use the cacls command which you can read about here:

http://www.microsoft.com/resources/documen...s.mspx?mfr=true

Enter the following command (or by typing the command in Start, Run) while having sufficient permissions (being the only user of a machine or logging in as administrator should be sufficient).

cacls "C:\System Volume Information" /E /P Jose:F

That should all be on one line, press Enter.

Now Jose can access all of that stuff and Jose should be careful.

To change it back the way it was before, enter the following on a line by itself, and press Enter

cacls "C:\System Volume Information" /E /R Jose

Edited by joseibarra, 20 October 2009 - 06:47 AM.

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#3 black069

black069
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tabor City, NC
  • Local time:08:52 AM

Posted 20 October 2009 - 03:29 PM

Thanks for the info, Jose.

Does Windows XP Home vs. Pro make a difference in terms of whether or not one is able to open SVI folder?

The reason I ask is because I have a laptop that runs Windows XP Pro SP3 (vs. the desktop that I described in prior post that runs Home version).

With the laptop, I literally click "My Computer" and then click on "C: drive". When the C: drive's window opens, I change the settings in folder options to "Show Hidden Files and Folders" and to show "protected operating system files." As soon as I do that, the SVI folder appears. When I hover over the folder, it does not say "Empty Folder"....it says "Size:1.09 GB". And when I double-click, I do not get "access denied"; it opens just like any other folder.

Then in laptop's SVI folder, there are 2 files:
(A) a text document entitled "Tracking.log" that contains a bunch of scrambled symbols and boxes; and
(B) a System File entitled "MountPointManagerRemoteDatabase" that contains 0 KB and which I cannot open.
There are also 2 folders:
© "catalog.wci" that contains about 30 files with extensions such as .000, .001, .dir, .hsh, etc.; and finally
(D) "_restore {46DE8921-1D39-44D2-A9...}" which contains a couple of .cfg files and .log files, but MOST IMPORTANTLY, IT CONTAINS SEVERAL FOLDERS LABELLED "RP15", "RP16", "RP17",.....WHICH OBVIOUSLY CONTAIN THE DATA NEEDED TO PERFORM SYSTEM RESTORE TO THE DATES/TIMES CORRESPONDING TO THOSE ON THE FOLDERS THEMSELVES.

I definitely haven't changed any settings on my laptop because as I said earlier, it works very well and we keep business records, etc. on it. I guess it is always possible that I inadvertently changed a global policy or something, but I definitely didn't go through any command-line interface as in your previous post or anything of that nature.

So to sum up, can anyone explain why my desktop which runs WinXP Home SP3 does not allow me (the only user) to access the System Volume Information folder, whereas my laptop, which runs WinXP Pro SP3 does allow me to access it without any problem whatsoever. The major differences in the computers are the age (desktop is 7yo, laptop is 2); the laptop contains all of its original hardware whereas the desktop has been upgraded (RAM, monitor, etc.); the OS has never been reinstalled on the laptop whereas I did reinstall OS on desktop ~3 months ago; and finally, the laptop just has one partition in the HDD (not counting Dell's diagnostic partition) whereas when I reinstalled the OS on the desktop, I made a primary partition for applications and Windows files, and then made a second partition for all of my data.

Anybody an expert in SVI/System Restore care to help me out? How about you, Jose?

Thanks a bunch. (Again, this isn't just for curiosity; I want to create a home network to transfer files between the 2 computers, etc., but not at the risk of damaging my laptop if something is actually wrong with my desktop as evidenced by this (at least to me) bizarre loss of accessibility to SVI folder on my desktop.)

Thanks a bunch again!

#4 joseibarra

joseibarra

  • Members
  • 1,180 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:08:52 AM

Posted 20 October 2009 - 04:07 PM

I don't have access to XP Home, but I am pretty sure it comes out of the box hidden and inaccessible for your protection. You might need it someday and it is best left to it's own devices which generally work just fine.

Perhaps someone changed it with a cacls (there is another method) thinking if they could get inside, they could fix some issue. I think your computer that does not have access to the SVI folder is working properly and the one that does have access is somehow afflicted.

Some people find the mere presence of a hidden, secret, can't be browsed folder on a computer they paid good $$$ for intimidating and/or offensive and are compelled to eliminate it. It is sometimes an easy target for other problems that end up unrelated - disk space for one. Poor SVI - it is just misunderstood.

It sounds like yours is fine. Each RP will create a new folder like you saw. Take a look at the System Restore options in System Tools and make sure you see a calendar with available RPs, you may not have one for every day, you may have several in one day but all that can be explained.

I think if you are curious, read about it, explore it and put it back the way it is supposed to work to prevent an accident. Google searches are good.

I think I understand the SVI folder quite thoroughly after some discussions here a while back - curiosity questions not problems. I have no questions about it for the moment. Although I will admit, I have never used SR to fix a problem. I have tried it to see what it does, doesn't do and broken it on purpose though.

I would just set it back the right way - if cacls doesn't work, we can still fix it if you want.

I can't get into my SVI folder naturally either - and I don't care!

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#5 Stang777

Stang777

    Just Hoping To Help


  • Members
  • 1,821 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:06:52 AM

Posted 20 October 2009 - 06:45 PM

Cacl did not work for me to gain access to that folder but changing the permissions on the securtiy tab did. In order to do this in the home version, you have to be in safe mode. Once you are in safe mode, bring up the properties for SVI and click on the security tab. Once there, just make sure the box for full permission is checked. If that does not work, then I am forgetting a step so post back and let me know if that worked, if it didn't, I will search for the steps I may be forgetting

#6 ladagosta

ladagosta

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:pa
  • Local time:08:52 AM

Posted 05 November 2010 - 09:35 PM

I know this is an old post but I know the answer and possibly it will help someone else who needs the answer. restart your computer in safe mode enter administrator of course....and go to the SVI folder mine was / is located in C: right click on the folder and click on properties then go to security and click on Add then add the user log in that you want to gain access or modify the settings to gain access to all the boxes check marked within such as read write etc.. then apply and close out and reboot to normal you should now be able to access your SVI folder with no more "Access denied" warning.. GL

Edited by ladagosta, 05 November 2010 - 09:36 PM.


#7 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:12:52 PM

Posted 06 November 2010 - 01:32 PM

Its a protected directory, and you do not have access to it regardless of what you try and do you will never gain access to you. No account on the computer can access the folder expect for the one that creates it, and i think its the backup account. You cannot login to that account.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users