Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Strange USB problem - Nothing but the Keyboard and mouse recognize?


  • Please log in to reply
1 reply to this topic

#1 slumslum

slumslum

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:16 PM

Posted 05 October 2009 - 11:09 AM

So here is my problem. I have a printer set up via USB. The printer stopped working and I figured it would just require a reboot, take out the USB and put it back in. When I did I noticed that nothing was recognizing. I then thought well maybe the USB cord went bad, so I grabbed a new one and that didn't work either. Then I took my laptop and plugged the printer into there. And it recognized the printer as new hardware. Perplexed, I took a USB memory stick and put it into the port and it didn't recognize. Now I think I have a problem with the USB ports on the front and back of the computer. Here is the strange part. The USB mouse and USB keyboard still work no matter what port I put them in... I tried restarting and restoring the computer several times and no matter what it won't recognize anything but the Mouse and Keyboard.

Is it possible that the USB drivers have locked up? Is there a way to flush all the USB drivers? Or do you know what is going on?

Thanks in advance.

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,727 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:16 PM

Posted 05 October 2009 - 11:17 AM

You can go to Device Manager...remove all USB controllers...and reboot. It may solve something.

http://support.microsoft.com/kb/310575

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users