Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

files on old drive write protected


  • Please log in to reply
11 replies to this topic

#1 cowboyken072474

cowboyken072474

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:20 AM

Posted 04 October 2009 - 12:37 AM

Hello all,

I have a hard disk that I took out of a computer that failed (MB). The disk has all my addresses on it in an address book for Printmaster. Unfortunately I never backed it up. I put this drive into another computer as a slave and was hoping to get the information off of it. Every time I try to move the file or copy it or open it with the program, it either tells me that the file is in use by another person or that the file is write protected. I have tried to change permissions and properties as the administrator and the folder the file is in keeps geting back the read only attribute. So I cannot import to the program. Both the old drive and the new drive have xp professional on them. Any help or suggestions are welcome and appreciated. Reentering all that information would be very time consuming and I would lose some addresses. Thank YOU

Ken

BC AdBot (Login to Remove)

 


#2 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:08:20 AM

Posted 04 October 2009 - 06:05 AM

You could try booting up with a Linux Live CD.

Linux Mint 7 works well for me
and displays everything on my computer and all drives connected.

Just a thought.

(No interference from Windows, which generally seems to prevent copying, etc.)

Edited by battysurreal, 04 October 2009 - 06:11 AM.


#3 DavisMcCarn

DavisMcCarn

  • Members
  • 871 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:20 AM

Posted 04 October 2009 - 07:40 AM

Read-only shouldn't prevent you from copying the file to your new computer's drive which would then fix the permissions in the process. You might need to change the read-only; but, that is a checkbox when you right-click and choose properties.

If that doesn't get it, what you need to do is to take ownership which is done using the advanced button in permissions.
Computer dinosaur, servicing PC's since 1976

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,127 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:20 AM

Posted 04 October 2009 - 09:36 AM

<<..it either tells me that the file is in use by another person or that the file is write protected...>>

Typically, when trying to access files (in Docs & Settings) from another system or a drive which formerly was a system drive...the message will indicate that access is denied. This doesn't seem to be what you are experiencing.

But I believe that the suggestion to try to take ownership is what I would try.

Louis

#5 cowboyken072474

cowboyken072474
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:20 AM

Posted 04 October 2009 - 10:24 AM

SOUNDS LIKE IT IS WORTH A TRY.. COULDYOU EXPLAIN HOW TO TAKE OWNERSHIP. I'VE NEVER RUN INTO THIS BEFORE. THANKS AGAIN.

#6 hamluis

hamluis

    Moderator


  • Moderator
  • 56,127 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:20 AM

Posted 04 October 2009 - 10:28 AM

My error, I should posted this before.

How to take ownership of a file or a folder in Windows XP - http://support.microsoft.com/kb/308421

Louis

#7 cowboyken072474

cowboyken072474
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:20 AM

Posted 04 October 2009 - 08:29 PM

That did the trick...I was able to place the file on the c drive and open the address book. Thank You

#8 cowboyken072474

cowboyken072474
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:20 AM

Posted 04 October 2009 - 09:08 PM

It seems I spoke too soon. I was in safe mode under the Admin log in when I opened the file. After I logged in under my user name, which has administrator privileges, The program said that it could not open the address book. The address book is located in an "all users" file. I also tried to take ownership of the folder in my user account but it would not let me access or move it.
Any thoughts??

#9 KamakaZ

KamakaZ

  • Members
  • 739 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Victoria
  • Local time:06:20 PM

Posted 04 October 2009 - 09:14 PM

login as admin again and give your user account permission, or there is a group called "everyone" try that.

There's no place like 127.0.0.1
There are 10 types of people in the world, those that can read binary, and those who can't.


#10 cowboyken072474

cowboyken072474
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:20 AM

Posted 04 October 2009 - 09:34 PM

I tried but the only options listed were Administrator and Administrators

#11 cowboyken072474

cowboyken072474
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:20 AM

Posted 04 October 2009 - 11:15 PM

ok NOW I am all set. I needed to give "file" permission not "folder" permission. Thanks Again.

#12 hamluis

hamluis

    Moderator


  • Moderator
  • 56,127 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:20 AM

Posted 05 October 2009 - 10:16 AM

Kudos to KamakaZ...happy computing :thumbsup:.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users