Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SATA Drives not detected in BIOS


  • Please log in to reply
2 replies to this topic

#1 TerriH

TerriH

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:39 AM

Posted 03 October 2009 - 02:17 AM

Hi there,

I've Googled this problem in many ways, and I haven't found anything outlining my same situation. A lot of people have had a similar problem, but only with new hard drives, whereas mine were only working yesterday, and now zilch.

I guess I was to blame, as I was firstly trying to install another harddrive, which was IDE. After Windows 7 didn't recognise the drive, I thought 'Mneh' and took it out. I then booted up my computer, only to see the following message on my screen:

"Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key_"

The first thing I did was shut down and check all the connections - all fine. Booted up again, same message.

Rebooted, checked my BIOS, the Boot-Up config was in the right order - DVD-ROM, Floppy then Hard Drive. But I noticed in the BIOS that my two HDDs weren't being detected - only my SATA DVD-ROM drive was.

So, logically, I unplugged my HDDs and tried the DVD-ROM cable into the 3 other SATA ports on my mobo, and the BIOS detected it on all of the ports, so nothing is up with the ports (I think, I hope).

I plugged one of the HDDs into my fiance's computer, and again it wasn't being detected in BIOS.

I'm not really sure what else to try. I think I can hear the HDDs spinning, but I'm not sure. This kind of leads me to believe it's the cables from the HDDs to the SATA Ports, but I'm not sure as I'm relatively new to computer building.

I have an ASUS P5K SE mobo and 2 Seagate HDDs (80GB and 160GB). Windows 7 is installed on the 80GB.

I really don't want to lose any data - I have years of work on my PC and would like to try and save it.

Any ideas?

BC AdBot (Login to Remove)

 


#2 TerriH

TerriH
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:39 AM

Posted 03 October 2009 - 07:02 PM

Ok, after much research I found that it was because the jumper leads weren't connected to the drives. Which I am now finding really strange, as it's run for the last 18 months without them. *shrugs* the joys of computers.

#3 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,136 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:10:39 AM

Posted 04 October 2009 - 08:16 PM

Sorry we were not able to help you faster. Glad you solved it. Thanks for posting your solution it will help people searching for the same problem in the future :thumbsup:
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users