Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Registry Editor Problem


  • Please log in to reply
7 replies to this topic

#1 DColeLA

DColeLA

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Los Angeles, CA
  • Local time:06:19 PM

Posted 27 September 2009 - 03:20 PM

Something I did recently, while in DOS mode, seems to have modified my Start>Run behavior for Regedit, and I'd like to restore it.
I don't have a problem opening Regedit.exe, if I type Start>Run>regedit.exe, nor to open it in DOS mode.
This is a very insignificant problem that probably has an incredibly simple solution, but I have not been able to find it.
Thanx, in advance, for your help!
dave
:thumbsup:

BC AdBot (Login to Remove)

 


#2 Guest_SteinPooch_*

Guest_SteinPooch_*

  • Guests
  • OFFLINE
  •  

Posted 28 September 2009 - 05:18 AM

Okay, you're right. There is an incredibly simple solution to this. Do you remember what DAY you did this? If you do, then all you have to do is run a System Restore to the day before that. Beware, though, a System Restore will delte any downloaded EXEs, and delte and programs you may have installed during that time. It will not delte and personal files, however.

#3 DColeLA

DColeLA
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Los Angeles, CA

Posted 28 September 2009 - 07:44 PM

SteinPooch,
I considered a System Restore, but don't have any available Restore points dated prior to this problem.
thanx,
dave
:thumbsup:

#4 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:06:19 PM

Posted 29 September 2009 - 12:00 AM

1. Can you open all other EXE programs normally? If no then you have file association problem. I will post solution later if you think this is your problem.

2. If you get this "Open with..." box only with regedit then search for all files named regedit in your Windows folder (%windir%) which is C:\Windows for most of users. And also in System32 folder (%windir%\system32) which is C:\Windows\System32 for most of users. Delete any file named regedit in System32 folder. Leave only regedit.exe in Windows folder.

What I am expecting is that you have a file named regedit (with or without an extension) in System32 folder. When you issue regedit command, Windows first looks in System32 folder finds the file and tries to open it.

Edited by Romeo29, 29 September 2009 - 12:04 AM.


#5 DColeLA

DColeLA
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Los Angeles, CA
  • Local time:08:19 PM

Posted 29 September 2009 - 01:14 PM

Romeo29,
No 'Regedit' file found in Windows or System32 folders.
Meanwhile, it occurred to me to use the 'Open With' window to navigate to C:\Windows to locate Regedit.exe, which would certainly be the appropriate application to execute this Run command. When I selected it and clicked OK, Regedit appeared (and was highlighted) in the 'Open With' window. When I clicked OK again, I was a little un-nerved by this message:

ARE YOU SURE YOU WANT TO ADD THIS INFORMATION TO THE REGISTRY?

I think this is the solution, but I decided that I'd rather be safe than sorry. Do you agree that this action would resolve my problem, or do you think it would make matters worse??
regards,
dave

Attached Files



#6 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:06:19 PM

Posted 29 September 2009 - 02:19 PM

No, that is not the solution.

Search for a file named regedit in C:\Documents and Settings\%username% as shown in the steps below :
1. Open Start Menu > Search > For Files and Folders
2. In search box, click All files and folders.
3. In More Advanced Options select Look for hidden files or folders
4. Then enter Look in: C:\Documents and Settings\%username%\ For filename type regedit
Posted Image
5. Whatever you find, right click on it and select rename. Rename it to something other than regedit for example, regedit.001

If you do not find anything in the above steps then do this:
1. Open Start Menu > Run, type cmd to open command prompt window
2. Type or copy/paste the following line and press Enter:
ren "c:\documents and settings\dcole.RWXPBUY001\regedit" reg.txt

Edited by Romeo29, 29 September 2009 - 02:20 PM.


#7 DColeLA

DColeLA
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Los Angeles, CA
  • Local time:08:19 PM

Posted 30 September 2009 - 07:45 PM

Romeo29,
Yours was the magic solution!! I did find regedit in the folder you indicated, then used CMD to execute the 'reg.txt' code you provided.
...and VOILA!!! Regedit was restored!!
Thanx a lot!!
dave
:thumbsup:

#8 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:06:19 PM

Posted 01 October 2009 - 03:08 AM

I am glad it worked for you :thumbsup: You're welcome :flowers:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users