Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

DVD auto play not working


  • Please log in to reply
11 replies to this topic

#1 Chris4835

Chris4835

  • Members
  • 182 posts
  • OFFLINE
  •  
  • Local time:01:11 PM

Posted 24 September 2009 - 04:08 PM

All of a sudden The DVD player-writers on both of my Widows XP home computers, don't auto play any DVDs or even Cd's, audio or movies. I tried a couple of things myself. But neither helped any.

First I tried going to the DVD player PROPERTIES and then clicked on Auto Play. There I highlighted Music files and then in Actions I selected Play using Windows Media Player. And then Apply and OK. I even re-booted the computer. But it did not change anything.

Second I downloaded and installed the Windows auto fix tool and ran it, and logged off and on again. But it didn't help either.

Still this bleeping computer only shows me the contents of the CD, instead of starting to play it. One thing that is common to both computes is that I let Windows install Media Player 11. Could that be the problem? and what can I do about it?

20 views and not one reply???

Attached Files


Edited by Chris4835, 25 September 2009 - 03:57 PM.


BC AdBot (Login to Remove)

 


#2 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:11 AM

Posted 27 September 2009 - 05:10 PM

Open the Device Manager (Start > Run > type "devmgmt.msc"). Locate the CD/DVD drive, right click on it and select "Uninstall". After it has uninstalled reboot the computer (it will be automatically reinstalled).
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#3 Chris4835

Chris4835
  • Topic Starter

  • Members
  • 182 posts
  • OFFLINE
  •  
  • Local time:01:11 PM

Posted 01 October 2009 - 04:39 PM

Thank you very much Budapest. Unfortunately that did not help either. As I said before: When I put a CD in the drive, Windows XP only shows me the contents of the CD.

To re-phrase my question: Could updating my Microsoft media player 10 to media playert 11 have caused that problem? Because this is the only thing that is common to both of my computers. Both act exactly the same.

#4 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:11 AM

Posted 01 October 2009 - 06:02 PM

Right-click on My Computer > Manage > Services and Applications > Services. Double-click the IMAPI CD Burning service and change the "Startup type" to Automatic. Then click Start.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#5 Chris4835

Chris4835
  • Topic Starter

  • Members
  • 182 posts
  • OFFLINE
  •  
  • Local time:01:11 PM

Posted 02 October 2009 - 01:45 PM

Thanks again Budapest. But this did not help either. I even re-booted the computer to see if it was needed.
I also attached a screen shot, so you can see if I was in the right place.

Attached Files


Edited by Chris4835, 02 October 2009 - 01:46 PM.


#6 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:11 AM

Posted 04 October 2009 - 11:31 PM

Is this the one you tried:

Autoplay Repair Wizard.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#7 Chris4835

Chris4835
  • Topic Starter

  • Members
  • 182 posts
  • OFFLINE
  •  
  • Local time:01:11 PM

Posted 05 October 2009 - 06:50 PM

Yes, that's the one. When I ran it on my other computer the Result was: this auto play setting was successfully fixes. Required action: must log off and on again. I did all that, but still didn't get it to auto play.

As you can see from the attached file I ran the auto fix program on my second computer. And I'm attaching a document with some screen shots. The Result is slightly different. But both computers still don't auto play. Isn't that spooky?

Couldn't uplad, sayis it's larger than available space. But it's only 461 KB. Basically the message was that autix found the problem but couldn' fix it.

Edited by Chris4835, 05 October 2009 - 06:52 PM.


#8 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:11 AM

Posted 05 October 2009 - 09:49 PM

Right-click on My Computer > Manage > Services and Applications > Services. Make sure the Shell Hardware Detection service is set to Automatic. Reboot.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#9 Chris4835

Chris4835
  • Topic Starter

  • Members
  • 182 posts
  • OFFLINE
  •  
  • Local time:01:11 PM

Posted 06 October 2009 - 02:13 PM

The Shell Hardware Detection is ruining and it is set to Automatic. So far every setting seems to be normal. And every auto play and auto run is set OK. But the computer just will not start plying the Cd's. Yet it always did before.

Attached Files



#10 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:11 AM

Posted 06 October 2009 - 04:53 PM

Get TweakUI, a Microsoft PowerToys for Windows XP, and go to My Computer > Autoplay > Drives and check the settings.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#11 Chris4835

Chris4835
  • Topic Starter

  • Members
  • 182 posts
  • OFFLINE
  •  
  • Local time:01:11 PM

Posted 07 October 2009 - 02:34 PM

Finally got the auto-play to work on both computers. Thank you very much for having so much patience with me, Budapest.

But earlier on I googled auto-play and they directed me to Microsoft Help and Support where I downloaded a document to fix this problem. Of the 5 steps, three of them required editing the Registry. But I wanted to avoid doing that, if at all possible.

So yesterday I figured your patience will be running out soon, so tried it on the cheaper, Dell GX 520 first. I had to change the value for: allocatecdroms from a 1 to a 0. It didn't auto-play yet. But then after I went to CD-ROM Properties and set the auto-play again to use Windows Media Player for music. It worked just fine. Except, today when I put in an audio CD it started playing, but with Cyberlink DVD Player, instead of Windows Media Player. But I won't worry about that at all.

On my Gateway computer I changed the same setting from the1 to a 0.
And on the: NoDriveTypeAutoRunn it was set to 90 I changed it to 91 as per instructions. The Dell was set to 91 already, so I didn't have to change it.

As with the Dell, my Gateway still didn't auto-play. Then I remembered that you, Budapest, told me to uninstall the DVD player from the Device Manager and let Windows re-detect it. I had done that on the Dell a few days ago. But never did it on the Gateway. Well, as soon as I did, and re-booted, the auto-play was fixed on the Gateway too.

What puzzles me though is how could these registry entries have changed all of a sudden and all by themselves, and on both computers?

#12 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:11 AM

Posted 07 October 2009 - 04:38 PM

I'm happy you figured it out!

As to why the registry values were changed in the first place - who knows? It's one of those mysteries of life...
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users