Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Changed regestry item and can't log into computer


  • Please log in to reply
5 replies to this topic

#1 winger_354

winger_354

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:25 AM

Posted 24 September 2009 - 10:19 AM

After having problems with my computer, I found the "my documents" page would load up as soon as I turned on my computer. I looked up on-line how to get rid of the problem and found a solution on the microsoft site. The following is what I used to try and fix the problem.

1.Start>Run>Regedit>ok

2.Now navigate to the following key:-
HKEY_ LOCAL_ MACHINE\SOFTWARE\Microsoft\Win苓ows NT\CurrentVersion\Winlogon

3.Look down the list in the Right Hand pane,scroll down to the value Userinit This value should read: C:\WINDOWS\system32\userinit.e軍e, (The comma at the end must also be there)

4.If the value is different from that mentioned above then Right Click on the Userinit value and, from the drop down menu, select Modify. Type in the value C:\WINDOWS\system32\userinit.e軍e,in the Modify dialogue box click OK

5.Exit the Registry.Restart your computer.

I found everything fine except the value in step 4 read: C:\WINDOWS\system32\userinit.e軍e, userinit.exe,

I deleted the second userinit.exe, and also changed it from D: to C:. I think mine was supposed to be located in the D drive and I changed it to the C drive to match the instructions. Now the computer won't let me access anything. When I used to turn on the computer, it started up my desktop with no login screens or passwords. Now it starts up with my Kurt or guest. In safe mode it has my Kurt or admin. When I click on any of them it says its loading my settings and then flashes to my wallpaper and back to the login screen saying it is saving my settings.

Is there any way I can get access to change the value back to D:\WINDOWS\system32\userinit.e軍e, instead of the C:.

I accidently put this on the introduction page. Sorry.

BC AdBot (Login to Remove)

 


#2 RTCTech1

RTCTech1

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Local time:03:25 AM

Posted 24 September 2009 - 10:33 AM

Try using a PE Disk. Such as WinPE or BartPE. Make sure you bind the registry, and if you plan on making any more changes, BACK UP YOUR REGISTRY!!

#3 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:07:25 PM

Posted 24 September 2009 - 11:00 AM

BACK UP YOUR REGISTRY!!

Heed the advice!

Try the following ...
Start tapping the F8 key after you press the ON button, and continue tapping until you are presented with the "Windows Advanced Options Menu" screen. Use the UP/DOWN arrow keys to select "Last known good configuration that worked", and press the Enter key. The computer will attempt to load Windows.

If Windows does not start, try the same thing again .... and continue trying for at least 10 times, before you rule that option out as a means of getting your OS up and running again, normally.

Why 10 times? Based on past experience, a successful result is sometimes achieved after several consecutive failed attempts.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#4 winger_354

winger_354
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:25 AM

Posted 28 September 2009 - 03:11 PM

I tried the "past known working config" 10 times idea and nothing changed. I just don't know why changing the drive of "my documents" would not allow me to even log in as the Admin or guest.

Edited by winger_354, 28 September 2009 - 03:12 PM.


#5 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:07:25 PM

Posted 28 September 2009 - 03:49 PM

changed it from D: to C:. I think mine was supposed to be located in the D drive and I changed it to the C drive to match the instructions

Please confirm that your WINDOWS operating system is on D: drive (and not on C: drive as is usually the case).

If that is the situation, then use an off-line registry editor to reverse the change you made and "change the value back to D:\WINDOWS\system32\userinit.e軍e, instead of the C:".

Choose one of the following options:

1. Bart's Preinstalled Environment (BartPE) bootable live windows CD/DVD
http://www.nu2.nu/pebuilder/

Download, build and burn yourself a bootable BartPE CD.
Boot the afflicted computer with the CD, and amend the WINDOWS registry.

How to Create a BartPE Bootable CD Using PE Builder
http://www.winhelponline.com/blog/create-b...ing-pe-builder/

My preferred method:
1). Choose to create an ISO file (note the name and location of this, because you will need to know this in the next step)
2). Download, install and use IMGBURN to burn the IMAGE (ISO) to disk (CD).
IMGBURN home page http://www.imgburn.com/
IMGBURN download http://www.imgburn.com/index.php?act=download

How to edit the registry offline using BartPE boot CD
http://windowsxp.mvps.org/peboot.htm

2. Hiren's Boot CD 10.0
http://www.hirensbootcd.net/

Download and burn to CD.
Use the Registry Editor Wizard to amend the WINDOWS registry.
---------------------

You said: "I just don't know why changing the drive of "my documents" would not allow me to even log in as the Admin or guest."
You actually changed the drive in which WINDOWS will look to find "userinit.exe" to enable you to log in to the system.

Edited by AustrAlien, 28 September 2009 - 10:00 PM.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#6 winger_354

winger_354
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:25 AM

Posted 05 October 2009 - 09:51 AM

Thanks for all the help. I got my system back up and running using the windows XP disc that came with my computer. Just put it in and did a repair. Had to do a lot of updates, but everything is still there. The only new problem now is all my files look like they changed drives as well and I'm getting the red circle with the white X in it and when I try to shut down I get the pro quota warning saying I'm way over my files quota. Anyone know how to fix this new problem.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users