Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My sound card is not detected after I reformat my pc to XP SP3


  • Please log in to reply
2 replies to this topic

#1 john23jay

john23jay

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Laguna
  • Local time:10:45 PM

Posted 22 September 2009 - 06:14 AM

what will I do if the sound card is not detected?

I am experiencing this kind of problem after I reformat my pc into Windows XP SP3. When I go to the Device Manager, there is "Other Devices" section which is unknown and not yet installed. I tried to install the sound card but it says that the driver is missing.

I have a Creative Sound Blaster AWE64 sound card installed on my PC. And i have also gone to the manufacturer's website to download driver for this one. But on the drivers page, there is no driver available for download for Sound Blaster AWE64. Maybe because this sound card is old. It is released since 1998.

Now, what will I do then?

I don't want to use other software for drivers (i.e driver detective, driver update software, etc..) because that PC having a sound card problem doesn't have an internet connection.

Thanks for any support. :D

BC AdBot (Login to Remove)

 


#2 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:45 AM

Posted 22 September 2009 - 07:38 AM

The AWE64 is listed on the Legacy Page here. There are several models of it.

#3 john23jay

john23jay
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Laguna
  • Local time:10:45 PM

Posted 22 September 2009 - 09:21 PM

sorry, but i only found the model number for my sound card: Sound Blaster AWE64 PnP CT4380. that site doesn't offer any driver for that specific device.. I only found applications with regards to Sound Blaster AWE64 PnP CT4380. Actually, I only found Sound blaster AWE64 on their archive (no AWE64 PnP found for driver download).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users