Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Website hosting locally


  • Please log in to reply
14 replies to this topic

#1 xXAlphaXx

xXAlphaXx

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:03:16 AM

Posted 17 September 2009 - 12:30 PM

The website I am hosting is only hosting from within my network, I have tried opening port 80, which successfully was oppened, I check with my ISP and they do NOT by default block port 80.

However port 80 never comes back as open when I test it.

Does windows fire wall block this port by defualt? Anything else I should check?
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

BC AdBot (Login to Remove)

 


#2 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:01:16 AM

Posted 17 September 2009 - 04:24 PM

THe only thing that would block port 80 is your firewall or your router. On what did you open port 80, and do you have a router?

#3 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:03:16 AM

Posted 17 September 2009 - 08:00 PM

Yes, the port was opened on the router, through the local host address (198.168.2.1) I acually didnt want too go through any specifcs so I compleatly disabled the firewall too see if that got it out, It did not.

Yes I have a router.
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#4 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:12:16 AM

Posted 17 September 2009 - 08:19 PM

Make sure that port 80 is being forwarded to the server by the router.

#5 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:03:16 AM

Posted 17 September 2009 - 08:44 PM

Ok I got it too see service on port 80. But its still local? :thumbsup:
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#6 KamakaZ

KamakaZ

  • Members
  • 739 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Victoria
  • Local time:06:16 PM

Posted 17 September 2009 - 08:52 PM

I think what AA was trying to say is when you open a port on your router, you have to choose a destination IP. This means if a browser comes knocking at the routers door asking to go through port 80, the router replies, sure go to this IP...

But its still local?


What do you mean by this?

Edited by KamakaZ, 17 September 2009 - 08:54 PM.

There's no place like 127.0.0.1
There are 10 types of people in the world, those that can read binary, and those who can't.


#7 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:12:16 AM

Posted 17 September 2009 - 08:56 PM

Make sure that the server has a static IP on the LAN. Forward port 80 to that LAN IP. Make sure the server is running an HTTP server daemon (like Apache) and is configured to listen on port 80.

Go to What's My IP to get your external IP address. Enter that IP address into the address bar of your browser. If it's working, you'll see your web page. If it's not, the error message may prove helpful.

#8 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:03:16 AM

Posted 17 September 2009 - 09:05 PM

Bah! I've just hit more snags.

I had too change a setting in my php.ini and its almost blank -_-

Apache is set up too be hosted through a no-IP client right now, would this have any effect on why its only staying on my network?

Static ip what? I've been working with the local host, loopback, internal, external ip's I have no idea what is what right now >_<

Edited by xXAlphaXx, 17 September 2009 - 09:06 PM.

If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#9 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:02:16 AM

Posted 17 September 2009 - 09:09 PM

IMHO,
If you are going to run Apache only on local network (LAN) then you do not have to forward port 80 to external internet.
You need to create LAN clients or a LAN group in your router and then allow them to access port 80 (it would be similar to port forwarding process).

Edited by Romeo29, 17 September 2009 - 09:32 PM.


#10 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:01:16 AM

Posted 17 September 2009 - 10:22 PM

Yep, you are confused so let's back up for a moment.

You have a server set up on your computer. The server runs on Port 80, so the firewall on the system running the server has to have port 80 open in order for the server to get requests. Next, your router has to forward incoming requests (from the internet) on port 80 to the system running your server. As Andrew already stated, you need to set up the system running the server to have a static IP. The IP that you have to use depends on your router. For instance, on my internal network, the IP numbers run from 192.168.1.1 to 192.168.1.8. On the internal network, my router takes the 192.168.1.1 address, my server takes 192.168.1.2, and the rest of the systems in my house take up the rest of the IPs in that range. So when I port forward, I have to tell my router that any requests on port 80 go to my server located at internal address 192.168.1.2

Your external address is different. That address is the one that the rest of the world uses to connect to your computer. Since you are using No-Ip, then you have set up a domain od some sort, and No-ip knows what that domain is. You tell No-IP what [u]your[/i] ip address is (which is the one you find by using a service like Whatsmyip.com, as AA mentioned). No-Ip then registers that domain and IP with its name servers. When someone types in the URL for your website, the request gets routed through the global domain servers, which then route the request down to No-Ip's name servers. Once it gets there, then No-Ip matches up the URL with your IP address. Then the request is sent to your server. Your router gets the request and passes the request to the server.

#11 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:02:16 AM

Posted 17 September 2009 - 10:54 PM

Pardon me, I thought you were going to use web site on LAN only.

The website I am hosting is only hosting from within my network

This got me confused.

#12 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:03:16 AM

Posted 18 September 2009 - 08:16 AM

Romeo, it was hosting within the LAN which is not what I wanted, should be open too everyone too visit it.

groovicus, I finally have port 80 open, it is seeing service on it. However, I am still having problems with No-IP. I had it set too the computers ip, the 69.x.x.x Not the 192.x.x.x

I was unable too get anything host it thorugh the 69.x.x.x and the 192.x.x.x (trial and error) how ever I started getting it host locally when I used 127.0.0.1 along with loopback adapter.'



EDIT:

AHA! I got it! I can successfully view the website on external computers. Thank you all for all the help.
Im going too guess it was the firewall blocking the port. I have No-IP hosting the website off of "127.0.0.1" with the combination of the microsoft loopback adapter it grabs my site perfectly.

Now too fix this php.ini >_<

Edited by xXAlphaXx, 18 September 2009 - 11:57 AM.

If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#13 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:12:16 AM

Posted 18 September 2009 - 12:21 PM

Wait... No-IP is sending visitors to your web site to IP address 127.0.0.1? That'll never work. That just sends them to their own computer.

#14 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:01:16 AM

Posted 18 September 2009 - 01:21 PM

That'll never work. That just sends them to their own computer.

Which, if you are trying to view the web-site on the same computer as has the server, it will only appear to be working, when in reality it is only working on that one computer.

#15 xXAlphaXx

xXAlphaXx
  • Topic Starter

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:03:16 AM

Posted 19 September 2009 - 11:09 AM

Mmm, your right.

Got it changed too the external 69.x.x.x ip

Working fine now, just got some php issues I have too resolve now. Oh well.

Thanks for all the help :thumbsup:
If I am helping you and I do not respond within 24 hours, please send me a PM. :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users