Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

.Net Framework 3.0, 3.5, 2.0 Errors


  • Please log in to reply
4 replies to this topic

#1 ChewieBacca

ChewieBacca

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:12:33 AM

Posted 16 September 2009 - 07:42 AM

So I'm trying to get .net Framework 3.5 installed, and its a big fat fail. It errored out of me like 40 times before I decieded to use google. I cleaned out all the .nfw I had installed and re-installed all of them, except 2.0 REFUSED to uninstall due to some program using it. No biggie I say, I continue re-installing the rest of the .net Frameworks (1.0, 1.1, Reinstalled 2.0) I get to 3.0, and it errors out with the following error:

[09/16/09,05:42:01] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[09/16/09,05:42:04] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
[09/16/09,05:42:04] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[09/16/09,06:32:13] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[09/16/09,06:32:16] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
[09/16/09,06:32:16] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.



I tried 3.5 and go this error message

[09/16/09,05:56:47] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[09/16/09,05:56:58] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.
[09/16/09,06:19:48] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[09/16/09,06:19:58] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.
[09/16/09,06:28:17] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[09/16/09,06:28:24] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.


Things I've tried

Complete re-install and install of all .net frameworks
Setting the parent inherit permissions for the Secure Service 3.0.0.0 Registry file
Clearing out my temp folder

I do not have IIS installed (I've seen that removing this may fix the problem.)

I don't know what else to do

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,246 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:33 AM

Posted 16 September 2009 - 10:17 AM

What operating system?

What SP-level?

I would remove everything refflecting NET via Add/Remove Programs...install SP3 if you haven't done so already...and then just download/install the 3.5 download for MS.NET, http://www.microsoft.com/downloads/details...;displaylang=en. As noted, this is a cumulative update.

If that failed, I would either run sfc /scannow or do a repair install of XP...before trying again.

Louis

I would install the Full Package.

Edited by hamluis, 16 September 2009 - 10:19 AM.


#3 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:02:33 AM

Posted 16 September 2009 - 10:29 AM

Adding to what hamluis has already said:

You should, use .NET Framework Cleanup Tool to get rid of .NET on your system. After that you can install fresh .NET 3.5 as suggested by hamluis
You can download .NET Framework Cleanup Tool and also read User's Guide from here : http://blogs.msdn.com/astebner/pages/8904493.aspx

#4 ChewieBacca

ChewieBacca
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:12:33 AM

Posted 16 September 2009 - 11:58 AM

I tried to use that clean up tool to get rid of everything but .net Framework 2.0 fails to uninstall/remove. I'm running Windows XP Sp3.

When trying to uninstall .net framework 2.0 it says (Unable to uninstall because it would effect a program that uses it) or something to that degree.

Edit: Resolved. I tried the clean up tool once more, and it actually removed 2.0 this time. I restarted and used the 3.5 installer that I was linked to and it worked. Before I was using a 3.5 installer that did'nt require any download. Thanks for the help

Edited by ChewieBacca, 16 September 2009 - 12:25 PM.


#5 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:02:33 AM

Posted 16 September 2009 - 01:13 PM

I am glad you had it resolved :thumbsup:

The error that you posted earlier comes when a .NET 2.0 application is running while you are trying to remove .NET 2.0 using CleaupTool




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users