Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Installer Problem...


  • Please log in to reply
20 replies to this topic

#1 DEATH-2-COME

DEATH-2-COME

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Santa Rosa, CA
  • Local time:11:43 PM

Posted 15 September 2009 - 08:42 PM

Ello there guys, I have a slight problem, well, a pretty big problem. I believe somehow, my Windows Installer was removed from my computer, by my own stupidity, or my annoying sisters who screw with my computer all the time, >.< Well, either way, it must've happened, because whenever I download a program, or anything that needs to be installed, an installer does not open, but instead, a window pops up which is labeled, "Open File With..." And I must choose a program in which to open the program/file with. I'm not sure if this means I do/don't have Windows installer, but nothing will install because I must open the file I am downloading with a chosen program from the list, in which I try 7-Zip, which never works... Please help, I'd like to play some gamez PLOX.

-Thank you
Devyn Kelly
DEATH-2-COME

BC AdBot (Login to Remove)

 


#2 DEATH-2-COME

DEATH-2-COME
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Santa Rosa, CA
  • Local time:11:43 PM

Posted 15 September 2009 - 08:56 PM

Please help... I'd like to install some programs...

#3 pablo49

pablo49

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:southern california
  • Local time:09:43 PM

Posted 15 September 2009 - 08:57 PM

Gotta ask - are you really running Win 9x/ME on that computer?
You can get the installer at this site.

#4 DEATH-2-COME

DEATH-2-COME
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Santa Rosa, CA
  • Local time:11:43 PM

Posted 15 September 2009 - 09:02 PM

Hm... Because I don't have Windows Installer, I have to tell the computer which program to open the Windows Installer with... Which program should I use...?

#5 DEATH-2-COME

DEATH-2-COME
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Santa Rosa, CA
  • Local time:11:43 PM

Posted 15 September 2009 - 09:37 PM

Bump^ How do I install the installer, without using Windows Installer...?

#6 pablo49

pablo49

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:southern california
  • Local time:09:43 PM

Posted 15 September 2009 - 09:45 PM

Good question.. what currently happens with you double click on a .exe file?

#7 DEATH-2-COME

DEATH-2-COME
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Santa Rosa, CA
  • Local time:11:43 PM

Posted 15 September 2009 - 10:00 PM

Well, the main file "instmsi," for Windows Installer from that site, when double clicked, launches a window called, "Windows Installer," and in it says, ""Please wait while Windows configures Windows Installer." And then just disappears after the load bar is filled, as if nothing happened. And when I double click the "msiexec" file in the "InstMsiA.exe" download from the sight, it says,
"Incorrect command line parameters

Windows Installer. V 2.00.2600.2
Copyright C 200 Microsoft Corporation. All rights reserved
Portions of this software are based in part on the work of
the independent JPEG Group."


I don't know if it's working or not...

#8 DEATH-2-COME

DEATH-2-COME
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Santa Rosa, CA
  • Local time:11:43 PM

Posted 15 September 2009 - 10:05 PM

Also, when I try to use the "msinst" file, it says, "Wrong OS or OS version for application"

#9 pablo49

pablo49

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:southern california
  • Local time:09:43 PM

Posted 15 September 2009 - 10:27 PM

What operating system are you running? The reason I asked initially is that your post is filed under "Operating Systems > Windows 95/88/ME"

#10 DEATH-2-COME

DEATH-2-COME
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Santa Rosa, CA
  • Local time:11:43 PM

Posted 15 September 2009 - 10:32 PM

Yea, that's the operating system I believed to have, but it says it's a Microsoft Windows XP Home Edition Version 2002... I'n not a computer techie obviously, and do not know how that would effect it... >.<

#11 pablo49

pablo49

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:southern california
  • Local time:09:43 PM

Posted 15 September 2009 - 10:42 PM

Probably the easiest solution is to perform a repair installation of XP, provided that you have the installation disk. Otherwise check this site with has some information and steps for troubleshooting and re installing Windows Installer.
Good luck

#12 starcraftmaster

starcraftmaster

  • Members
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:australia
  • Local time:03:43 PM

Posted 16 September 2009 - 05:44 AM

if its windows xp then post this in the XP forums
and download the newer windows installer
go on the Microsoft website and download it (search)
i would get it now for ya but am downloading some thing on bleeptie 56k dailup lol

#13 Leurgy

Leurgy

    Voted most likely


  • Members
  • 3,831 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Collingwood, Ontario, Canada
  • Local time:11:43 PM

Posted 16 September 2009 - 07:10 AM

Try Windows Updates, that should give you the Windows Installer. This could also be malware related. Try running FixEx.reg to reset the default associations for .exe files.

When the only tool you own is a hammer, every problem begins to resemble a nail. Abraham Maslo

**** We use our powers for good, not evil ****

 Trying to remove your data from the web is like trying to remove pee from a swimming pool


#14 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:11:43 PM

Posted 16 September 2009 - 10:13 AM

Hi,

You have lost file association with EXE file types. To restore most common extensions associations back on XP, download the file Restore.Inf to your desktop, right-click on it and select Install. This will not install anything, this is just a trick to restore file associations in the registry. You must have admin access to do that.

Also losing of important file associations like EXE is sometimes associated with malware infection, so you should also check your computer with Malwarebytes' AntiMalware. Basic usage of MBAM involves three steps :

1. Download MBAM from here : http://majorgeeks.com/Malwarebytes_Anti-Malware_d5756.html
2. Install and update it. Without updating it will not work like it should.
3. Scan your computer with "full scan" option.

If you find anything, report back with MBAM report that is shown after the scan and BC experts will be able to guide you further. Also installing a good antivirus products and keeping it update is a good idea. You can download free antivirus products like avast! and install it. If you suspect you are infected or need guidance regarding malware infection, then post in the section : Am I Infected? What to do?

Have a nice day :thumbsup:

Edited by Romeo29, 16 September 2009 - 10:14 AM.


#15 DEATH-2-COME

DEATH-2-COME
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Santa Rosa, CA
  • Local time:11:43 PM

Posted 19 September 2009 - 12:03 PM

Yea... I got Windows installer to work a few times, but it would just stop without warning... I can't download any of that stuff, because My Windows Installer isn't working, so it won't install...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users