Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

browsers have beome slow snce last w7 update


  • Please log in to reply
No replies to this topic

#1 razorflores

razorflores

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:32 PM

Posted 14 September 2009 - 06:19 PM

I have been running windows7 OS for since the first RC came out, and have had zero to no problems. I use multiple browsers, but mainly FF3.5 and Chrome.

Since the other night when the OS updated with a few security features, the browsers have responded with slow page loads and download times.

I would like to figure out if it is just the OS itself or my system.

I have begun to try and figure it out myself, as I heard that some device drivers may be causing the problem. Have used CCleaner, but still have slow load times for internet pages.

Can you help me?

Thanks,
Razor

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users