Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

XP sp3 and LPD / LPR printing not working


  • Please log in to reply
No replies to this topic

#1 pcar

pcar

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:30 PM

Posted 13 September 2009 - 01:19 PM

Not wanting to open my network up to security problems, I don't want to enable netbios and MS File and Print sharing. LPD/LPR is a logical solution, but so far I can't get working. That's true even on the computer running the LPDSVC service and a locally attached printer. Here is the configuration.

Machine 1: XP Home Edition, SP3
1. Local printer (HP DeskJet-882C) is attached via parallel port (LPT-1)
2. LPDSVC is running (TCPIP Print Service)
3. Unix ("other") print services component is installed
4. Firewall allows port 9100 and 515 for both RAW and LPR traffic, but the result is the same even with it disabled
5. Printers have been created using both "LPR" and "Standard TCPIP" port configurations
6. In the case of the "Std" port, both RAW and LPR formatting options have been tried
7. In LPR mode, the queue name is short with no spaces
8. Both 127.0.0.1 (loopback) and the actual IP address have been tried to identify the computer where the printer is attached.
9. netstat doesn't show any of the ports I expect to see, but they may be momentary.

Even the test page won't print. I can see the job in the queue but it won't leave the queue and the printer cannot be seen by the LPD. I have sent only a plain TXT document with the same results... no surprise there.

Very frustrating. Any guru's got an idea of how I can debug this further?

Edited by pcar, 13 September 2009 - 04:18 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users