Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Wireless connected but no internet


  • Please log in to reply
1 reply to this topic

#1 Guest_WelshSteve_*

Guest_WelshSteve_*

  • Guests
  • OFFLINE
  •  

Posted 10 September 2009 - 07:33 AM

I have a bizarre situation.

I received a new laptop today and proceeded with setting it up. All was well to begin with. As soon as it was setup, I connected to the wireless network here and downloaded some free software off the internet (AVG Free and Ashampoo Firewall).

I then installed the software and rebooted the machine.

Everything seemed fine except suddenly the internet connection dropped out, despite still being connected to the wireless network (with an "Excellent" connection strength).

I tried releasing and renewing the IP at the command prompt, but this didn't seem to solve the issue. I then tried pinging a few web addresses from the command prompt and they returned fine.

I decided to shut down the new firewall and anti virus software to se if they were interfering, but this didn't make any difference. I also stopped the windows firewall as well, but still no joy.

This wireless network is setup as a LAN with many machines using the internet fine, both wired and wirelessly, so there is no problem with the internet connection, and as I said, I'm able to ping web addresses from the command prompt, and can also ping local LAN machines (including the default gateway) ok without any problems.

I don't think it's a DNS issue as the TCP/IP settings are told to auto detect and I cannot get to the IP address of any website in the browser. The browser also doesn't appear to have any LAN or proxy settings of it's own entered.

Is anybody able to assist at all? Is there something I've missed? The fact the internet connection was working initially suggests something has changed on the laptop, but all I've done is install the software as mentioned. I've done this install on numerous laptops in the past without any issues.

EDIT: OK, I decided to remove the security software and this seems to have worked, so god only knows why software I have used perfectly fine on other machines has caused this. I have decided to try installing different software instead, as it needs security software. I would install Comodo Internet Security, as I've found this very good, but the user who's going to be using this laptop is not likely to be very "techy", and COmodo is a little advanced. So am going with Avast for anti-virus, and maybe the PC Tools free firewall. Will try each program one by one followed by a reboot so I know what causes the problem should it re-occur. I will post back later.

Cheers

Steve

Edited by WelshSteve, 10 September 2009 - 08:38 AM.


BC AdBot (Login to Remove)

 


#2 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,577 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost

Posted 14 September 2009 - 09:33 PM

In the firewall you very likely need to permit communication for DNS lookup.
If you enable logging in the firewall, the logs likely will show you the attempted contact from your computer to some remote IP and remote port 53.
Normally you just need UDP protocol in and out from any local port to remote port 53. Some people think including TCP out is needed as well. Remote IP will most likely be your router, and, in the firewall setup it should match what you put into the firewall.

If the firewall you use has no port control (though I think Ashampoo does, and PC Tools definitely does), usually there will be some setting of a global nature - something like 'permit DNS'. For the web browsing to function, that connection needs to be kept alive.

Edited by tos226, 14 September 2009 - 09:34 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users