Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I cant stop Avast Home 'On-Access Protection' from loading at startup.


  • Please log in to reply
8 replies to this topic

#1 vladmir21

vladmir21

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:05:04 AM

Posted 09 September 2009 - 08:20 AM

I have the latest Avast Home version, and no matter how many times i go into msconfig and specifically uncheck ashDisp.exe, it comes right back on the next startup, and i have to right-click the avast icon in the tray to "Stop On-Access Protection".

Please, tell me there is a way to disable this, without having to uninstall the thing. Some registry hack, or something.

It is slowing up my boot-up time. I prefer to only do manual scans.

BC AdBot (Login to Remove)

 


#2 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:04 AM

Posted 09 September 2009 - 09:47 AM

Seems I remember reading a similar question some where else. I believe the answer was, "it can not be done". Avast was not designed that way.

#3 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:06:04 AM

Posted 09 September 2009 - 10:33 AM

Instead of using msconfig to disable things, it's safer to use a startup manager such as
Codestuff Starter:
http://www.snapfiles.com/get/starter.html
Better~Autoruns:
http://technet.microsoft.com/en-us/sysinte...s/bb963902.aspx
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#4 Bambo

Bambo

  • Members
  • 133 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Denmark
  • Local time:12:04 PM

Posted 09 September 2009 - 12:00 PM

Dont have access to Avast right now but that process could be started from a service. So you need to take it all out. Open a cmd box and run "net /?" and you figure it out. Google "net start stop" Put commands in a batchfile and you can start/stop easy. How well Avast take this I dont know - have never tried this either.

There is a setting about delaying Avast at boot - so you lose early activation but boot should be a few secs faster. A bit doubtful about how much delay you can notice if resident detection is deactivated. Sure something is not conflicting?

Edited by Bambo, 09 September 2009 - 12:01 PM.


#5 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:04 AM

Posted 09 September 2009 - 12:11 PM

Bambo is correct. It is a service.

Setting it to Manual may be a better option. But as stated, Avast may not play well this way.

#6 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,577 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:06:04 AM

Posted 09 September 2009 - 01:16 PM

It's much safer to use the on-access method than the manual scans.
Especially at boot time, so that the AV can catch something bad attempting to run during the booting process and before user login.
JMO.

Edit: The Loadorder utility shows everything loading during the booting process.
When you run it, you will see how very early in the process, often before the "Automatic" section various firewall and antivirus files load. Most load well before any GUI interface icon appears in the system tray.
http://technet.microsoft.com/en-us/sysinte...s/bb897416.aspx

Edited by tos226, 09 September 2009 - 01:26 PM.


#7 Bambo

Bambo

  • Members
  • 133 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Denmark
  • Local time:12:04 PM

Posted 09 September 2009 - 02:03 PM

If on Vista this should help troubleshoot what is taking so long http://content.zdnet.com/2346-12354_22-64715.html

#8 vladmir21

vladmir21
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:05:04 AM

Posted 09 September 2009 - 07:39 PM

Thanks for all your replys guys.
Well, here's what happened.
I go to services.msc, and set the 3 avast processes that are set at automatic mode and i make them manual.
I reboot, and my mouse, taskmanager etc. nothing responds, everything is just frozen. :flowers:
So, clearly Avast was not happy with that, ...twice.
I finally had to go into safe mode, to unistall it.
So, thats where things stand now.

I remember before this, i had the Avast Pro trial for 60 days.
I was easily able to turn off the real-time scanning option.
Apparently, the free Home version decides to take matter in its own hands,
even telling me that i dont have permission to end a process in the task manager. :trumpet:

Now, i get it, Avast is trying to protect itself from being disabled by malware.
While MBAM is easily stopped from running by viruses and rootkits, Avast can still install and run successfully, and kill them, all due to its fighting spirit.
But i am a user who practices safe browsing, and 6-7 seconds of slowdown is quite a drag to go thru everyday.... :thumbsup:
Its not really my system, its running XP Pro, 1GB RAM and a Dual Core.
(Ok, so i dont have 4 GB, but since when does a barebones XP suddenly need more than 1GB ram?)

#9 Bambo

Bambo

  • Members
  • 133 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Denmark
  • Local time:12:04 PM

Posted 09 September 2009 - 08:28 PM

You could go to settings, troubleshooting section and disable Avast Self-defense - also where you find delay trick. Not much Avast left if you keep up.

Ive used Avast on slower computers so know it is no speedking. But if you disable resident protection, take out all the more or less unnecessary modules (just keep standard shield), tell it not to delay bootup, then I dont think Avast is causing problems - since hardly there how can it? If you activate standard shield you could disable check of what is written to disk - since we assume reads are clean. Better to tweak Standard shield than to shut it down. http://forum.avast.com/index.php?topic=33344.0 Another way is to enable balloon thingy so you a period of time will get a feel for which files are being scanned - those you exclude :thumbsup:

Edited by Bambo, 09 September 2009 - 08:31 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users