Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Post Virus: Cannot Stream Videos [Flash]


  • Please log in to reply
7 replies to this topic

#1 Invisible City

Invisible City

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 08 September 2009 - 02:26 PM

Hello:

I had a Google Search Redirect virus awhile back and was able to succesfully remove it from my computer using Malwarebytes and Dr Web.

However, after the removal I had some lingering issues [I assume wreckage from the virus].

1) I had no sound. There was no little speaker icon in my lower taskbar. When I checked control panel, audio devices It said no device was installed. After some searching I figured out that I should re-download/install the realtek ac97 driver.
This worked perfectly! This issue is resolved.

2) I cannot stream video any longer from various sites. I get the error that I need to install the latest version of flash. However, I've done this many times over and also made sure that java scripting is enabled in my browser. Still no luck.

I am using xpProf with ie7.

Does anyone know what the issue could be?

Thanks for any help.

IC

Edit: Moved topic from XP to the more appropriate forum. ~ Animal

Edited by Animal, 09 September 2009 - 12:14 PM.


BC AdBot (Login to Remove)

 


#2 Invisible City

Invisible City
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 09 September 2009 - 08:10 AM

Anyone?

Perhaps I should add that playing videos on wmplayer, GOM, realplayer, etc, works fine.

It's just an issue with streaming [flash] videos.

#3 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:01:51 PM

Posted 09 September 2009 - 12:10 PM

Did you uninstall the old version of Flash before installing the new version?

#4 Invisible City

Invisible City
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 09 September 2009 - 12:53 PM

Yes, I've uninstalled and re-installed Flash v.10. It appears to download just fine via the Adobe Download Manager (I get the "Installation Complete" with the green checkmark)

Also, I've triple-checked that "Active Scripting" is Enabled in ie7.

Edited by Invisible City, 09 September 2009 - 12:53 PM.


#5 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:01:51 PM

Posted 09 September 2009 - 06:22 PM

Does that mean you used the Flash uninstall tool?

#6 Invisible City

Invisible City
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 10 September 2009 - 08:31 AM

Exactly. Yes.

Is it possible that Flash appears to install, but does not actually install?

#7 Invisible City

Invisible City
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 10 September 2009 - 09:12 AM

Here's my install log from Flash v10.

Delete: DeleteFile("C:\WINDOWS\system32\Macromed\Flash\Flash10c.ocx")
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash6.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash6a.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash7.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash7a.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash7b.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash7c.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash7d.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash8.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash8a.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash8b.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash8c.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash8d.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash8e.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9a.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9b.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9c.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9d.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9e.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9f.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9g.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash9h.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash10.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\Flash10a.ocx"
Delete: "C:\WINDOWS\system32\Macromed\Flash\GetFlash.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\GetFlash.exe.manifest"
Delete: "C:\WINDOWS\system32\Macromed\Flash\UninstFl.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil9a.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil9b.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil9c.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil9d.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil9e.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil9f.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil9g.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil9h.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil10.exe"
Delete: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil10a.exe"
End Call Uninstallers
File: overwriteflag=4, allowskipfilesflag=2, name="Flash10c.ocx"
File: wrote 3979680 to "C:\WINDOWS\system32\Macromed\Flash\Flash10c.ocx"
IfFileExists: file "C:\WINDOWS\system32\Macromed\Flash\Flash10c.ocx" exists, jumping 352
File: overwriteflag=4, allowskipfilesflag=2, name="FlashUtil10c.exe"
File: skipped: "C:\WINDOWS\system32\Macromed\Flash\FlashUtil10c.exe" (overwriteflag=1)
End Main Section
Section: ""
Start Post Section
Register Player
Registration Successful
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Macromedia\FlashPlayerActiveX\Components" "Main"="1"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Macromedia\FlashPlayerActiveX" "Path"="C:\WINDOWS\system32\Macromed\Flash"
created uninstaller: 10253, "C:\WINDOWS\system32\Macromed\Flash\uninstall_activeX.exe"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "DisplayName"="Adobe Flash Player 10 ActiveX"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "DisplayVersion"="10.0.32.18"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "Publisher"="Adobe Systems Incorporated"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "URLInfoAbout"="http://www.adobe.com/go/getflashplayer"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "VersionMajor"="10"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "VersionMinor"="0"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "HelpLink"="http://www.adobe.com/go/flashplayer_support/"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "URLUpdateInfo"="http://www.adobe.com/go/flashplayer/"
Call: 1285
File: overwriteflag=1, allowskipfilesflag=0, name="C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\System.dll"
File: skipped: "C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\System.dll" (overwriteflag=1)
Call: 1285
File: overwriteflag=1, allowskipfilesflag=0, name="C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\System.dll"
File: skipped: "C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\System.dll" (overwriteflag=1)
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "DisplayIcon"="C:\WINDOWS\system32\Macromed\Flash\uninstall_activeX.exe"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "UninstallString"="C:\WINDOWS\system32\Macromed\Flash\uninstall_activeX.exe"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "RequiresIESysFile"="4.70.0.1155"
WriteRegDWORD: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "NoModify"="0x00000001"
WriteRegDWORD: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX" "NoRepair"="0x00000001"
WriteRegDWORD: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{D27CDB6E-AE6D-11CF-96B8-444553540000}" "Compatibility Flags"="0x00000000"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents" "Flash"="application/x-shockwave-flash"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{D27CDB6E-AE6D-11CF-96B8-444553540000}" ""="Adobe Flash Player"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{D27CDB6E-AE6D-11CF-96B8-444553540000}" "ComponentID"="Flash"
WriteRegBin: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{D27CDB6E-AE6D-11CF-96B8-444553540000}" "IsInstalled"="01 00 00 00"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{D27CDB6E-AE6D-11CF-96B8-444553540000}" "Version"="10.0.32.18"
WriteRegStr: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{D27CDB6E-AE6D-11CF-96B8-444553540000}" "Locale"="EN"
WriteRegStr: "HKEY_CURRENT_USER\SOFTWARE\Macromedia\FlashPlayer" "FlashPlayerVersion"="10.0.32.18"
End Post Section
Call: 1285
File: overwriteflag=1, allowskipfilesflag=2, name="C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\NSISArray.dll"
File: skipped: "C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\NSISArray.dll" (overwriteflag=1)
Delete: DeleteFile("C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\fpinstall.dll")
Delete: DeleteFile("C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\nsExec.dll")
Delete: DeleteFile("C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\NSISArray.dll")
Delete: DeleteFile("C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\System.dll")
Delete: DeleteFile("C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\UserInfo.dll")
RMDir: RemoveDirectory("C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsm51.tmp\")

#8 Invisible City

Invisible City
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 10 September 2009 - 10:23 AM

Problem SOLVED!!!!!!!!!!!!!!!!!!!!!!!!!

I found this post by someone on another site. It refers to v9 but also applied to my v10, as well.

[I went to C:\WINDOWS\system32\Macromed\Flash and copied "Flash9.ocx" and then pasted it back in the same directory. This created "Copy of Flash9.ocx" which I then renamed to "Flash.ocx." (Thus I had "Flash.ocx" and "Flash9.ocx", both the same file with a different name in the same directory.)
the actual flash name may be slightly different for example, it could be Flash9a.ocx, but just copy whatever you have there, and rename it to flash.ocx and keep it in the same file]

I did this and youtube worked again!!!!!

Thanks for your responses Frank. I hope this thread helps someone else with a similar problem.

Very best,

IC




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users