Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Windows 7 hangs at classpnp.sys for 10 minutes

  • Please log in to reply
3 replies to this topic

#1 fetchcomms


  • Members
  • 4 posts
  • Local time:11:42 PM

Posted 01 September 2009 - 10:10 AM

I've been using my Windows 7 Ultimate RTM for 3 days, when suddenly when I turn it on, it stays on the "Starting Windows" boot screen for a long time. I tried safe moed, and it seemed to be just after the classpnp.sys was loaded. For about 10-15 mins, all there is is my computer cliking inside, then it starts going again. After I log in, it works fine, but it just takes forever to load.

BC AdBot (Login to Remove)


#2 Jacee


    Bleeping around

  • Malware Response Team
  • 3,716 posts
  • Gender:Female
  • Local time:09:42 PM

Posted 01 September 2009 - 04:03 PM

Read this article:

MS MVP Windows-Security 2006-2016
Member of UNITE, the Unified Network of Instructors and Trusted Eliminators

Admin PC Pitstop

#3 fetchcomms

  • Topic Starter

  • Members
  • 4 posts
  • Local time:11:42 PM

Posted 02 September 2009 - 01:31 PM

That article only applies to Windows 2000 and I could not find the hotfix, anyway.

#4 duvidl


  • Members
  • 1 posts
  • Local time:12:42 AM

Posted 21 September 2009 - 12:37 PM

I had this same problem and solved it by changing 2 BIOS settings. This is an eMachines T2245, don't know what the motherboard is, you can look it up if you want to:

1. Disable CPI APIC support
2. Under PCI/PnP settings, set Plug and Play O/S = YES.

I don't know if both are necessary, just know that after making these changes the PC boots in Win 7. I believe it is build 7600.

Good luck, hope this helps some of you.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users