Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

MBR Rootkit removal


  • This topic is locked This topic is locked
2 replies to this topic

#1 Grassroots Spa

Grassroots Spa

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:37 PM

Posted 31 August 2009 - 05:35 PM

Mt wife's employer, Grassroots Spa, called me today with this problem. Whenever the computer boots or attempts to run a program, an error pops up saying "Error" in the top bar, then displaying the file path of the program which has been blocked. This applies to any and all programs run. With most, when "Ok" is clicked, it pops up two more times. Some programs will then run, most will not. McAfee is disabled and cannot be re-enabled, Add/Remove programs will not open, and any .msi files are blocked by an administrator setting, "The system Administrator has set policies to prevent this installation" Opening gpedit.msc and looking at the group policy, Local Computer Policy->Computer Configuration->Admistrative Template->Windows Components->Windows Installer->Disable Windows Installer is set to Not Configured. I attempted to re-install McAfee, and it will not re-install due to Java being out of date, and Java updates are also not able to run. Malwarebytes cannot install, HijackThis and DDS are also blocked. The attached .jpg is the error shown when running DDS. As with any other program, the error pops up 2-3 times, certain programs run afterwards. Most do not. I was able to update Firefox, but not install Chrome. I have attempted to install and run Avast!, and Spybot with no success on either. RootRepeal was able to generate a log, included at the end. I noticed it found a rootkit, which finally gave me a title for the post. Not being able to do any scans left me with no idea what was going on. I have tried everything I can think of, and now must ask for assistance. If I have left anything out, please let me know and I will attempt to get you the information as quickly as possible.


Update:
Neither Ad-Aware nor SUPERAntispyware will install, same error.

RootRepeal

ROOTREPEAL AD, 2007-2009
==================================================
Scan Start Time: 2009/08/31 16:08
Program Version: Version 1.3.5.0
Windows Version: Windows XP Media Center Edition SP2
==================================================

Drivers
-------------------
Name: dump_atapi.sys
Image Path: C:\WINDOWS\System32\Drivers\dump_atapi.sys
Address: 0xF6E5E000 Size: 98304 File Visible: No Signed: -
Status: -

Name: dump_WMILIB.SYS
Image Path: C:\WINDOWS\System32\Drivers\dump_WMILIB.SYS
Address: 0xF7B10000 Size: 8192 File Visible: No Signed: -
Status: -

Name: rootrepeal.sys
Image Path: C:\WINDOWS\system32\drivers\rootrepeal.sys
Address: 0xF67DC000 Size: 49152 File Visible: No Signed: -
Status: -

Name: win32k.sys:1
Image Path: C:\WINDOWS\win32k.sys:1
Address: 0xF7936000 Size: 20480 File Visible: No Signed: -
Status: -

Name: win32k.sys:2
Image Path: C:\WINDOWS\win32k.sys:2
Address: 0xF7836000 Size: 61440 File Visible: No Signed: -
Status: -

Hidden/Locked Files
-------------------
Path: Volume C:\
Status: MBR Rootkit Detected!

Path: Volume C:\, Sector 62
Status: Sector mismatch

Path: Volume D:\
Status: MBR Rootkit Detected!

Path: Volume D:\, Sector 62
Status: Sector mismatch

Stealth Objects
-------------------
Object: Hidden Module [Name: UACfd18.tmpgouuef.dll]
Process: svchost.exe (PID: 808) Address: 0x009a0000 Size: 217088

Object: Hidden Module [Name: UACbhoyedocbl.dll]
Process: svchost.exe (PID: 808) Address: 0x00960000 Size: 73728

Object: Hidden Module [Name: UACjcrytvqvdm.dll]
Process: svchost.exe (PID: 808) Address: 0x00aa0000 Size: 77824

Object: Hidden Module [Name: kbiwkmqbrrultp.dll]
Process: svchost.exe (PID: 808) Address: 0x10000000 Size: 57344

Object: Hidden Module [Name: UACjcrytvqvdm.dll]
Process: Explorer.EXE (PID: 1572) Address: 0x00ba0000 Size: 77824

Object: Hidden Module [Name: kbiwkmebmpayps.dll]
Process: Explorer.EXE (PID: 1572) Address: 0x10000000 Size: 28672

Object: Hidden Module [Name: kbiwkmebmpayps.dll]
Process: firefox.exe (PID: 1320) Address: 0x007d0000 Size: 28672

==EOF==

Attached Files


Edited by Grassroots Spa, 31 August 2009 - 06:30 PM.


BC AdBot (Login to Remove)

 


#2 Blade

Blade

    Strong in the Bleepforce


  • Site Admin
  • 12,702 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US
  • Local time:05:37 PM

Posted 15 September 2009 - 03:00 PM

Hello and welcome to Bleeping Computer

We apologize for the delay in responding to your request for help. Here at Bleeping Computer we get overwhelmed at times, and we are trying our best to keep up. Please note that your topic was not intentionally overlooked. Our mission is to help everyone in need, but sometimes it takes just a little longer to get to every request for help. No one is ignored here.

If you have since resolved the original problem you were having, we would appreciate you letting us know. If not please perform the following steps below so we can have a look at the current condition of your machine.

If you have not done so, include a clear description of the problems you're having, along with any steps you may have performed so far.

Upon completing the steps below another staff member will review and take the steps necessary with you to get your machine back in working order clean and free of malware.

If you have already posted a DDS log, please do so again, as your situation may have changed.
Use the 'Add Reply' and add the new log to this thread.


Thanks and again sorry for the delay.

We need to see some information about what is happening in your machine. Please perform the following scan:
  • Download DDS by sUBs from one of the following links. Save it to your desktop.
  • Double click on the DDS icon, allow it to run.
  • A small box will open, with an explaination about the tool. No input is needed, the scan is running.
  • Notepad will open with the results.
  • Follow the instructions that pop up for posting the results.
  • Close the program window, and delete the program from your desktop.
Please note: You may have to disable any script protection running if the scan fails to run. After downloading the tool, disconnect from the internet and disable all antivirus protection. Run the scan, enable your A/V and reconnect to the internet.

Information on A/V control HERE

Posted Image

If I am helping you, it has been 48 hours since your last post, and I have yet to reply to your topic, please send me a PM
Become a BleepingComputer fan: Facebook
Follow us on Twitter!
Circle us on Google+


#3 teacup61

teacup61

    Bleepin' Texan!


  • Malware Response Team
  • 17,075 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Wills Point, Texas
  • Local time:04:37 PM

Posted 22 September 2009 - 12:01 PM

Due to the lack of feedback this Topic is closed.

If you need this topic reopened, please request this by sending the moderating team a PM with the address of the thread. This applies only to the original topic starter.

Everyone else please begin a New Topic
Please make a donation so I can keep helping people just like you.
Every little bit helps! :)
You can even use your credit card! Thank you!

Posted Image


Error reading poptart in Drive A: Delete kids y/n?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users